ignore errors from setting utime() for source file on read-only filesystem
(#500742)
This commit is contained in:
parent
3f4a491f9a
commit
b5434c3876
13
tar-1.22-atime-rofs.patch
Normal file
13
tar-1.22-atime-rofs.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -urNp tar-1.22-orig/src/create.c tar-1.22/src/create.c
|
||||
--- tar-1.22-orig/src/create.c 2009-05-15 10:50:38.000000000 +0200
|
||||
+++ tar-1.22/src/create.c 2009-05-15 10:51:52.000000000 +0200
|
||||
@@ -1691,7 +1691,8 @@ dump_file0 (struct tar_stat_info *st, co
|
||||
exit_status = TAREXIT_DIFFERS;
|
||||
}
|
||||
else if (atime_preserve_option == replace_atime_preserve
|
||||
- && set_file_atime (fd, p, restore_times) != 0)
|
||||
+ && set_file_atime (fd, p, restore_times) != 0
|
||||
+ && errno != EROFS )
|
||||
utime_error (p);
|
||||
}
|
||||
|
8
tar.spec
8
tar.spec
@ -2,7 +2,7 @@ Summary: A GNU file archiving program
|
||||
Name: tar
|
||||
Epoch: 2
|
||||
Version: 1.22
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Applications/Archiving
|
||||
URL: http://www.gnu.org/software/tar/
|
||||
@ -14,6 +14,7 @@ Patch2: tar-1.15.1-vfatTruncate.patch
|
||||
Patch3: tar-1.19-xattrs.patch
|
||||
Patch4: tar-1.19-xattrs-conf.patch
|
||||
Patch5: tar-1.17-wildcards.patch
|
||||
Patch6: tar-1.22-atime-rofs.patch
|
||||
Prereq: info
|
||||
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk rsh
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
@ -39,6 +40,7 @@ the rmt package.
|
||||
%patch3 -p1 -b .xattrs
|
||||
%patch4 -p1 -b .xattrs-conf
|
||||
%patch5 -p1 -b .wildcards
|
||||
%patch6 -p1 -b .rofs
|
||||
|
||||
%build
|
||||
%configure --bindir=/bin --libexecdir=/sbin
|
||||
@ -89,6 +91,10 @@ fi
|
||||
%{_infodir}/tar.info*
|
||||
|
||||
%changelog
|
||||
* Fri May 15 2009 Ondrej Vasik <ovasik@redhat.com> 2:1.22-3
|
||||
- ignore errors from setting utime() for source file
|
||||
on read-only filesystem (#500742)
|
||||
|
||||
* Fri Mar 06 2009 Kamil Dudka <kdudka@redhat.com> 2:1.22-2
|
||||
- improve tar-1.14-loneZeroWarning.patch (#487315)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user