New upstream release v1.33
Drop two patches applied upstream. Resolves: rhbz#1913774 Version: 1.33-1
This commit is contained in:
parent
9f913ff266
commit
854081fb66
4
sources
4
sources
@ -1,2 +1,2 @@
|
||||
SHA512 (tar-1.32.tar.xz) = 1bd13854009b6ee08958481738e6bf661e40216a2befe461d06b4b350eb882e431b3a4eeea7ca1d35d37102df76194c9d933df2b18b3c5401350e9fc17017750
|
||||
SHA512 (tar-1.32.tar.xz.sig) = 28eaf5db3ad32b50ce08891e245a84482771eef37b62c4266d9867f7504e0b9f6ad9fc05a53efda531bcb7e7bdfdc79bace81785d1a12556a355821db9bbd7d8
|
||||
SHA512 (tar-1.33.tar.xz) = d7c31147fafcd815bb54e3862c078dccc3f192a9fa149c2275bd89a21fcd54a4bdaa8343cacf4f76cadc2f57fd4ed955682c1b6f23d438add5a13cc35bd25260
|
||||
SHA512 (tar-1.33.tar.xz.sig) = a8801b2a7bb135a12d7944dff6958c4ff5671e379682593eed93569220d41fbe58eb095b80c4b04d97e4b5244aabab0cc7a0b65251ab115925ef3391a292c146
|
||||
|
@ -40,15 +40,15 @@ diff --git a/src/names.c b/src/names.c
|
||||
index 037b869..d96ad71 100644
|
||||
--- a/src/names.c
|
||||
+++ b/src/names.c
|
||||
@@ -137,7 +137,7 @@ static struct argp_option names_options[] = {
|
||||
{"no-ignore-case", NO_IGNORE_CASE_OPTION, 0, 0,
|
||||
N_("case sensitive matching (default)"), GRID+1 },
|
||||
{"wildcards", WILDCARDS_OPTION, 0, 0,
|
||||
- N_("use wildcards (default for exclusion)"), GRID+1 },
|
||||
+ N_("use wildcards (default)"), GRID+1 },
|
||||
@@ -146,7 +146,7 @@ static struct argp_option names_options[] = {
|
||||
{"no-wildcards", NO_WILDCARDS_OPTION, 0, 0,
|
||||
N_("verbatim string matching"), GRID+1 },
|
||||
N_("verbatim string matching"), GRID_MATCH },
|
||||
{"wildcards-match-slash", WILDCARDS_MATCH_SLASH_OPTION, 0, 0,
|
||||
- N_("wildcards match '/' (default for exclusion)"), GRID_MATCH },
|
||||
+ N_("wildcards match '/' (default)"), GRID_MATCH },
|
||||
{"no-wildcards-match-slash", NO_WILDCARDS_MATCH_SLASH_OPTION, 0, 0,
|
||||
N_("wildcards do not match '/'"), GRID_MATCH },
|
||||
|
||||
@@ -195,8 +195,7 @@ names_parse_opt (int key, char *arg, struct argp_state *state)
|
||||
/* Wildcard matching settings */
|
||||
enum wildcards
|
||||
|
@ -1,25 +0,0 @@
|
||||
From 1864e189c710414f2f837ddd6b9cf575a05846cd Mon Sep 17 00:00:00 2001
|
||||
From: Pavel Raiskup <praiskup@redhat.com>
|
||||
Date: Mon, 13 Jul 2020 08:23:29 +0200
|
||||
Subject: [PATCH] Bugfix --sparse --diff mode
|
||||
|
||||
---
|
||||
src/sparse.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/sparse.c b/src/sparse.c
|
||||
index d642a46..ac78894 100644
|
||||
--- a/src/sparse.c
|
||||
+++ b/src/sparse.c
|
||||
@@ -684,7 +684,7 @@ check_data_region (struct tar_sparse_file *file, size_t i)
|
||||
}
|
||||
size_left -= bytes_read;
|
||||
mv_size_left (file->stat_info->archive_file_size - file->dumped_size);
|
||||
- if (memcmp (blk->buffer, diff_buffer, rdsize))
|
||||
+ if (memcmp (blk->buffer, diff_buffer, bytes_read))
|
||||
{
|
||||
report_difference (file->stat_info, _("Contents differ"));
|
||||
return false;
|
||||
--
|
||||
2.24.1
|
||||
|
@ -1,73 +0,0 @@
|
||||
commit 14f00a2c7adefcbe50e85f6bf2ebce922e0dceb0
|
||||
Author: Sergey Poznyakoff <gray@gnu.org>
|
||||
Date: Mon Nov 25 08:01:04 2019 +0200
|
||||
|
||||
Testsuite fixes
|
||||
|
||||
* tests/sparse06.at: Skip the test if genfile is unable to create
|
||||
sparse files.
|
||||
* tests/sptrcreat.at: Likewise.
|
||||
* tests/sptrdiff00.at: Likewise.
|
||||
* tests/sptrdiff01.at: Likewise.
|
||||
|
||||
diff --git a/tests/sparse06.at b/tests/sparse06.at
|
||||
index 650b4f5..ceb5abb 100644
|
||||
--- a/tests/sparse06.at
|
||||
+++ b/tests/sparse06.at
|
||||
@@ -23,7 +23,7 @@ AT_KEYWORDS([sparse sparse06 chdir])
|
||||
|
||||
m4_define([check_pattern],[
|
||||
rm -rf out archive.tar smallsparse && mkdir out
|
||||
-genfile --sparse --quiet --file smallsparse $1
|
||||
+genfile --sparse --quiet --file smallsparse $1 || AT_SKIP_TEST
|
||||
tar -cSf archive.tar smallsparse
|
||||
tar -xf archive.tar -C out
|
||||
cmp smallsparse out/smallsparse
|
||||
@@ -33,7 +33,7 @@ AT_TAR_CHECK([
|
||||
AT_SEEKHOLE_PREREQ
|
||||
|
||||
TAR_OPTIONS="$TAR_OPTIONS --hole-detection=seek"
|
||||
-genfile --sparse --file bigsparse 0 ABC 8G DEF
|
||||
+genfile --sparse --file bigsparse 0 ABC 8G DEF || AT_SKIP_TEST
|
||||
tar -cSf a bigsparse
|
||||
test $? -eq 0 || exit 1
|
||||
|
||||
diff --git a/tests/sptrcreat.at b/tests/sptrcreat.at
|
||||
index 2c730cc..d913ddf 100644
|
||||
--- a/tests/sptrcreat.at
|
||||
+++ b/tests/sptrcreat.at
|
||||
@@ -35,7 +35,7 @@ AT_KEYWORDS([truncate filechange sparse sptr sptrcreat])
|
||||
|
||||
AT_TAR_CHECK([
|
||||
genfile --sparse --block-size=1024 --file foo \
|
||||
- 0 ABCDEFGHIJ 1M ABCDEFGHIJ 10M ABCDEFGHIJ 200M ABCDEFGHIJ
|
||||
+ 0 ABCDEFGHIJ 1M ABCDEFGHIJ 10M ABCDEFGHIJ 200M ABCDEFGHIJ || AT_SKIP_TEST
|
||||
genfile --file baz
|
||||
genfile --run --checkpoint 3 --length 200m --truncate foo -- \
|
||||
tar --sparse -vcf bar foo baz
|
||||
diff --git a/tests/sptrdiff00.at b/tests/sptrdiff00.at
|
||||
index 990c6fa..482e9e5 100644
|
||||
--- a/tests/sptrdiff00.at
|
||||
+++ b/tests/sptrdiff00.at
|
||||
@@ -29,7 +29,7 @@ AT_KEYWORDS([truncate filechange sparse sptr sptrdiff diff])
|
||||
# This triggers short read in check_sparse_region.
|
||||
AT_TAR_CHECK([
|
||||
genfile --sparse --block-size=1024 --file foo \
|
||||
- 0 ABCDEFGHIJ 1M ABCDEFGHIJ 10M ABCDEFGHIJ 200M ABCDEFGHIJ
|
||||
+ 0 ABCDEFGHIJ 1M ABCDEFGHIJ 10M ABCDEFGHIJ 200M ABCDEFGHIJ || AT_SKIP_TEST
|
||||
genfile --file baz
|
||||
echo creating
|
||||
tar --sparse -vcf bar foo baz
|
||||
diff --git a/tests/sptrdiff01.at b/tests/sptrdiff01.at
|
||||
index fcada14..81232a1 100644
|
||||
--- a/tests/sptrdiff01.at
|
||||
+++ b/tests/sptrdiff01.at
|
||||
@@ -29,7 +29,7 @@ AT_KEYWORDS([truncate filechange sparse sptr sptrdiff diff])
|
||||
# This triggers short read in check_data_region.
|
||||
AT_TAR_CHECK([
|
||||
genfile --sparse --block-size=1024 --file foo \
|
||||
- 0 ABCDEFGHIJ 1M ABCDEFGHIJ 10M ABCDEFGHIJ 200M ABCDEFGHIJ
|
||||
+ 0 ABCDEFGHIJ 1M ABCDEFGHIJ 10M ABCDEFGHIJ 200M ABCDEFGHIJ || AT_SKIP_TEST
|
||||
genfile --file baz
|
||||
echo creating
|
||||
tar --sparse -vcf bar foo baz
|
13
tar.spec
13
tar.spec
@ -4,13 +4,13 @@
|
||||
Summary: GNU file archiving program
|
||||
Name: tar
|
||||
Epoch: 2
|
||||
Version: 1.32
|
||||
Release: 6%{?dist}
|
||||
Version: 1.33
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
URL: https://www.gnu.org/software/tar/
|
||||
|
||||
Source0: https://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz
|
||||
Source1: https://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.xz.sig
|
||||
Source0: https://ftp.gnu.org/gnu/tar/tar-%{version}.tar.xz
|
||||
Source1: https://ftp.gnu.org/gnu/tar/tar-%{version}.tar.xz.sig
|
||||
|
||||
# Note that all patches are documented in patch files (git format-patch format)
|
||||
Patch1: tar-1.28-loneZeroWarning.patch
|
||||
@ -18,8 +18,6 @@ Patch2: tar-1.28-vfatTruncate.patch
|
||||
Patch3: tar-1.29-wildcards.patch
|
||||
Patch4: tar-1.28-atime-rofs.patch
|
||||
Patch9: tar-1.28-document-exclude-mistakes.patch
|
||||
Patch10: tar-1.32-testsuite-fix.patch
|
||||
Patch11: tar-1.32-bugfix-sparse-diff-mode.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -114,6 +112,9 @@ make check || (
|
||||
|
||||
|
||||
%changelog
|
||||
* Thu Jan 07 2021 Pavel Raiskup <praiskup@redhat.com> - 1.33-1
|
||||
- new upstream release (see the packaged NEWS file)
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2:1.32-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user