auto-import changelog data from tar-1.14-1.src.rpm
Mon Jun 07 2004 Jeff Johnson <jbj@jbj.org> 1.14-1 - upgrade to 1.14.
This commit is contained in:
parent
81cf615d8e
commit
7c8a0afc58
@ -1 +1 @@
|
||||
tar-1.13.25.tar.bz2
|
||||
tar-1.14.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
1235fbe4f1e71712888113622eb38961 tar-1.13.25.tar.bz2
|
||||
f1932e0fbd4641885bfdcc75495c91b7 tar-1.14.tar.bz2
|
||||
|
223
tar-1.14-nolibrt.patch
Normal file
223
tar-1.14-nolibrt.patch
Normal file
@ -0,0 +1,223 @@
|
||||
--- tar-1.14/configure.librt 2004-06-07 17:22:05.777889401 -0400
|
||||
+++ tar-1.14/configure 2004-06-07 17:22:50.460419882 -0400
|
||||
@@ -9907,20 +9907,20 @@
|
||||
# dnl Persuade glibc <time.h> to declare these functions.
|
||||
|
||||
|
||||
- # Solaris 2.5.1 needs -lposix4 to get the clock_gettime function.
|
||||
+ # Solaris 2.5.1 needs -lposix4 to get the clock_gettyme function.
|
||||
# Solaris 7 prefers the library name -lrt to the obsolescent name -lposix4.
|
||||
|
||||
# Save and restore LIBS so e.g., -lrt, isn't added to it. Otherwise, *all*
|
||||
# programs in the package would end up linked with that potentially-shared
|
||||
# library, inducing unnecessary run-time overhead.
|
||||
fetish_saved_libs=$LIBS
|
||||
- echo "$as_me:$LINENO: checking for library containing clock_gettime" >&5
|
||||
-echo $ECHO_N "checking for library containing clock_gettime... $ECHO_C" >&6
|
||||
-if test "${ac_cv_search_clock_gettime+set}" = set; then
|
||||
+ echo "$as_me:$LINENO: checking for library containing clock_gettyme" >&5
|
||||
+echo $ECHO_N "checking for library containing clock_gettyme... $ECHO_C" >&6
|
||||
+if test "${ac_cv_search_clock_gettyme+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_func_search_save_LIBS=$LIBS
|
||||
-ac_cv_search_clock_gettime=no
|
||||
+ac_cv_search_clock_gettyme=no
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -9934,11 +9934,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -9965,7 +9965,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="none required"
|
||||
+ ac_cv_search_clock_gettyme="none required"
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
@@ -9973,7 +9973,7 @@
|
||||
fi
|
||||
rm -f conftest.err conftest.$ac_objext \
|
||||
conftest$ac_exeext conftest.$ac_ext
|
||||
-if test "$ac_cv_search_clock_gettime" = no; then
|
||||
+if test "$ac_cv_search_clock_gettyme" = no; then
|
||||
for ac_lib in rt posix4; do
|
||||
LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
@@ -9989,11 +9989,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -10020,7 +10020,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="-l$ac_lib"
|
||||
+ ac_cv_search_clock_gettyme="-l$ac_lib"
|
||||
break
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
@@ -10033,18 +10033,18 @@
|
||||
fi
|
||||
LIBS=$ac_func_search_save_LIBS
|
||||
fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettime" >&5
|
||||
-echo "${ECHO_T}$ac_cv_search_clock_gettime" >&6
|
||||
-if test "$ac_cv_search_clock_gettime" != no; then
|
||||
- test "$ac_cv_search_clock_gettime" = "none required" || LIBS="$ac_cv_search_clock_gettime $LIBS"
|
||||
- test "$ac_cv_search_clock_gettime" = "none required" ||
|
||||
- LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettime
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettyme" >&5
|
||||
+echo "${ECHO_T}$ac_cv_search_clock_gettyme" >&6
|
||||
+if test "$ac_cv_search_clock_gettyme" != no; then
|
||||
+ test "$ac_cv_search_clock_gettyme" = "none required" || LIBS="$ac_cv_search_clock_gettyme $LIBS"
|
||||
+ test "$ac_cv_search_clock_gettyme" = "none required" ||
|
||||
+ LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettyme
|
||||
fi
|
||||
|
||||
|
||||
|
||||
|
||||
-for ac_func in clock_gettime clock_settime
|
||||
+for ac_func in clock_gettyme clock_settime
|
||||
do
|
||||
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
echo "$as_me:$LINENO: checking for $ac_func" >&5
|
||||
@@ -13823,7 +13823,7 @@
|
||||
|
||||
# gettime
|
||||
|
||||
- # Need clock_gettime.
|
||||
+ # Need clock_gettyme.
|
||||
|
||||
|
||||
|
||||
@@ -17829,17 +17829,17 @@
|
||||
# programs in the package would end up linked with that potentially-shared
|
||||
# library, inducing unnecessary run-time overhead.
|
||||
|
||||
-# Solaris 2.5.1 needs -lposix4 to get the clock_gettime function.
|
||||
+# Solaris 2.5.1 needs -lposix4 to get the clock_gettyme function.
|
||||
# Solaris 7 prefers the library name -lrt to the obsolescent name -lposix4.
|
||||
tar_save_LIBS=$LIBS
|
||||
LIB_CLOCK_GETTIME=
|
||||
- echo "$as_me:$LINENO: checking for library containing clock_gettime" >&5
|
||||
-echo $ECHO_N "checking for library containing clock_gettime... $ECHO_C" >&6
|
||||
-if test "${ac_cv_search_clock_gettime+set}" = set; then
|
||||
+ echo "$as_me:$LINENO: checking for library containing clock_gettyme" >&5
|
||||
+echo $ECHO_N "checking for library containing clock_gettyme... $ECHO_C" >&6
|
||||
+if test "${ac_cv_search_clock_gettyme+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_func_search_save_LIBS=$LIBS
|
||||
-ac_cv_search_clock_gettime=no
|
||||
+ac_cv_search_clock_gettyme=no
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -17853,11 +17853,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -17884,7 +17884,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="none required"
|
||||
+ ac_cv_search_clock_gettyme="none required"
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
@@ -17892,7 +17892,7 @@
|
||||
fi
|
||||
rm -f conftest.err conftest.$ac_objext \
|
||||
conftest$ac_exeext conftest.$ac_ext
|
||||
-if test "$ac_cv_search_clock_gettime" = no; then
|
||||
+if test "$ac_cv_search_clock_gettyme" = no; then
|
||||
for ac_lib in rt posix4; do
|
||||
LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
@@ -17908,11 +17908,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -17939,7 +17939,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="-l$ac_lib"
|
||||
+ ac_cv_search_clock_gettyme="-l$ac_lib"
|
||||
break
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
@@ -17952,19 +17952,19 @@
|
||||
fi
|
||||
LIBS=$ac_func_search_save_LIBS
|
||||
fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettime" >&5
|
||||
-echo "${ECHO_T}$ac_cv_search_clock_gettime" >&6
|
||||
-if test "$ac_cv_search_clock_gettime" != no; then
|
||||
- test "$ac_cv_search_clock_gettime" = "none required" || LIBS="$ac_cv_search_clock_gettime $LIBS"
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettyme" >&5
|
||||
+echo "${ECHO_T}$ac_cv_search_clock_gettyme" >&6
|
||||
+if test "$ac_cv_search_clock_gettyme" != no; then
|
||||
+ test "$ac_cv_search_clock_gettyme" = "none required" || LIBS="$ac_cv_search_clock_gettyme $LIBS"
|
||||
|
||||
fi
|
||||
|
||||
- case "$ac_cv_search_clock_gettime" in
|
||||
- -l*) LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettime;;
|
||||
+ case "$ac_cv_search_clock_gettyme" in
|
||||
+ -l*) LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettyme;;
|
||||
esac
|
||||
|
||||
|
||||
-for ac_func in clock_gettime
|
||||
+for ac_func in clock_gettyme
|
||||
do
|
||||
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
echo "$as_me:$LINENO: checking for $ac_func" >&5
|
44
tar.spec
44
tar.spec
@ -1,18 +1,14 @@
|
||||
Summary: A GNU file archiving program.
|
||||
Name: tar
|
||||
Version: 1.13.25
|
||||
Release: 14
|
||||
Version: 1.14
|
||||
Release: 1
|
||||
License: GPL
|
||||
Group: Applications/Archiving
|
||||
Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2
|
||||
Source0: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2
|
||||
Source1: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2.sig
|
||||
Patch0: tar-1.13.18-manpage.patch
|
||||
Patch1: tar-1.13.25-sock.patch
|
||||
Patch2: tar-1.13.25-autoconf.patch
|
||||
Patch6: tar-1.13.22-nolibrt.patch
|
||||
Patch7: tar-1.13.19-error.patch
|
||||
Patch8: tar-1.13.19-absolutenames.patch
|
||||
Patch9: tar-1.13.25-argv.patch
|
||||
Patch10: tar-1.13.25-dots.patch
|
||||
Patch6: tar-1.14-nolibrt.patch
|
||||
Patch7: tar-1.14-err.patch
|
||||
Prereq: info
|
||||
BuildRequires: autoconf automake
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -32,28 +28,12 @@ the rmt package.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .manpage
|
||||
%patch1 -p1 -b .sock
|
||||
%patch2 -p1 -b .253
|
||||
%patch6 -p1 -b .librt
|
||||
%patch7 -p1 -b .err
|
||||
%patch8 -p1 -b .absn
|
||||
%patch9 -p1 -b .argv
|
||||
%patch10 -p1 -b .dots
|
||||
|
||||
%build
|
||||
|
||||
%ifos linux
|
||||
unset LINGUAS || :
|
||||
%define optflags $RPM_OPT_FLAGS -DHAVE_STRERROR -D_GNU_SOURCE
|
||||
########### Start workaround for legacy auto* tools ############
|
||||
for i in autoconf autoheader autom4te autoreconf autoscan autoupdate ifnames; do
|
||||
ln -s %{_bindir}/$i-2.53 $i
|
||||
done
|
||||
for i in aclocal automake; do
|
||||
ln -s %{_bindir}/$i-1.5 $i
|
||||
done
|
||||
export PATH="`pwd`:$PATH"
|
||||
########### End workaround ###########
|
||||
%configure --bindir=/bin --libexecdir=/sbin
|
||||
make LIBS=-lbsd
|
||||
%else
|
||||
@ -99,6 +79,12 @@ rm -f ${RPM_BUILD_ROOT}/sbin/rmt
|
||||
|
||||
%find_lang %name
|
||||
|
||||
%check
|
||||
make check
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%post
|
||||
/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
|
||||
|
||||
@ -107,9 +93,6 @@ if [ $1 = 0 ]; then
|
||||
/sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
|
||||
fi
|
||||
|
||||
%clean
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%ifos linux
|
||||
@ -125,6 +108,9 @@ rm -rf ${RPM_BUILD_ROOT}
|
||||
%{_infodir}/tar.info*
|
||||
|
||||
%changelog
|
||||
* Mon Jun 7 2004 Jeff Johnson <jbj@jbj.org> 1.14-1
|
||||
- upgrade to 1.14.
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user