- fix problem when options at the end of command line were not recognized
(#188707)
This commit is contained in:
parent
75cdd6bdb5
commit
4892f79503
14
tar-1.15.1-optionsOrder.patch
Normal file
14
tar-1.15.1-optionsOrder.patch
Normal file
@ -0,0 +1,14 @@
|
|||||||
|
--- tar-1.15.1/src/tar.c.optionsOrder 2006-04-24 15:25:55.000000000 +0200
|
||||||
|
+++ tar-1.15.1/src/tar.c 2006-04-24 15:27:01.000000000 +0200
|
||||||
|
@@ -617,9 +617,9 @@
|
||||||
|
|
||||||
|
switch (key)
|
||||||
|
{
|
||||||
|
- case 1:
|
||||||
|
+ case ARGP_KEY_ARG:
|
||||||
|
/* File name or non-parsed option, because of ARGP_IN_ORDER */
|
||||||
|
- name_add (optarg);
|
||||||
|
+ name_add (arg);
|
||||||
|
args->input_files++;
|
||||||
|
break;
|
||||||
|
|
8
tar.spec
8
tar.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A GNU file archiving program.
|
Summary: A GNU file archiving program.
|
||||||
Name: tar
|
Name: tar
|
||||||
Version: 1.15.1
|
Version: 1.15.1
|
||||||
Release: 15
|
Release: 16
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
URL: http://www.gnu.org/software/tar/
|
URL: http://www.gnu.org/software/tar/
|
||||||
@ -19,6 +19,7 @@ Patch14: tar-1.15.1-padCorrectly.patch
|
|||||||
Patch15: tar-1.15.1-vfatTruncate.patch
|
Patch15: tar-1.15.1-vfatTruncate.patch
|
||||||
Patch16: tar-1.15.1-heapOverflow.patch
|
Patch16: tar-1.15.1-heapOverflow.patch
|
||||||
Patch17: tar-1.15.1-hugeSparse.patch
|
Patch17: tar-1.15.1-hugeSparse.patch
|
||||||
|
Patch18: tar-1.15.1-optionsOrder.patch
|
||||||
|
|
||||||
Prereq: info
|
Prereq: info
|
||||||
BuildRequires: autoconf automake gzip
|
BuildRequires: autoconf automake gzip
|
||||||
@ -49,6 +50,7 @@ the rmt package.
|
|||||||
%patch15 -p1 -b .vfatTruncate
|
%patch15 -p1 -b .vfatTruncate
|
||||||
%patch16 -p0 -b .heapOverflow
|
%patch16 -p0 -b .heapOverflow
|
||||||
%patch17 -p1 -b .hugeSparse
|
%patch17 -p1 -b .hugeSparse
|
||||||
|
%patch18 -p1 -b .optionsOrder
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -119,6 +121,10 @@ fi
|
|||||||
%{_infodir}/tar.info*
|
%{_infodir}/tar.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Apr 24 2006 Peter Vrabec <pvrabec@redhat.com> 1.15.1-16
|
||||||
|
- fix problem when options at the end of command line were
|
||||||
|
not recognized (#188707)
|
||||||
|
|
||||||
* Thu Apr 13 2006 Peter Vrabec <pvrabec@redhat.com> 1.15.1-15
|
* Thu Apr 13 2006 Peter Vrabec <pvrabec@redhat.com> 1.15.1-15
|
||||||
- fix segmentation faul introduced with hugeSparse.patch
|
- fix segmentation faul introduced with hugeSparse.patch
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user