correctly pad archive members that shrunk during archiving (#172373)
This commit is contained in:
parent
d207d61f0a
commit
45f4d36981
22
tar-1.15.1-padCorrectly.patch
Normal file
22
tar-1.15.1-padCorrectly.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- tar-1.15.1/src/create.c.padCorrectly 2005-11-04 10:18:08.000000000 -0500
|
||||||
|
+++ tar-1.15.1/src/create.c 2005-11-04 10:21:05.000000000 -0500
|
||||||
|
@@ -877,8 +877,8 @@
|
||||||
|
return dump_status_short;
|
||||||
|
}
|
||||||
|
size_left -= count;
|
||||||
|
-
|
||||||
|
- set_next_block_after (blk + (bufsize - 1) / BLOCKSIZE);
|
||||||
|
+ if (count)
|
||||||
|
+ set_next_block_after (blk + (bufsize - 1) / BLOCKSIZE);
|
||||||
|
|
||||||
|
if (count != bufsize)
|
||||||
|
{
|
||||||
|
@@ -892,7 +892,7 @@
|
||||||
|
STRINGIFY_BIGINT (size_left, buf)));
|
||||||
|
if (! ignore_failed_read_option)
|
||||||
|
exit_status = TAREXIT_FAILURE;
|
||||||
|
- pad_archive (size_left);
|
||||||
|
+ pad_archive (size_left - (bufsize-count));
|
||||||
|
return dump_status_short;
|
||||||
|
}
|
||||||
|
}
|
8
tar.spec
8
tar.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A GNU file archiving program.
|
Summary: A GNU file archiving program.
|
||||||
Name: tar
|
Name: tar
|
||||||
Version: 1.15.1
|
Version: 1.15.1
|
||||||
Release: 10
|
Release: 11
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
URL: http://www.gnu.org/software/tar/
|
URL: http://www.gnu.org/software/tar/
|
||||||
@ -15,6 +15,8 @@ Patch10: tar-1.15.1-gcc4.patch
|
|||||||
Patch11: tar-1.15.1-lseek.patch
|
Patch11: tar-1.15.1-lseek.patch
|
||||||
Patch12: tar-1.15.1-sparseTotals.patch
|
Patch12: tar-1.15.1-sparseTotals.patch
|
||||||
Patch13: tar-1.15.1-newerOption.patch
|
Patch13: tar-1.15.1-newerOption.patch
|
||||||
|
Patch14: tar-1.15.1-padCorrectly.patch
|
||||||
|
|
||||||
Prereq: info
|
Prereq: info
|
||||||
BuildRequires: autoconf automake gzip
|
BuildRequires: autoconf automake gzip
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -40,6 +42,7 @@ the rmt package.
|
|||||||
%patch11 -p1 -b .lseek
|
%patch11 -p1 -b .lseek
|
||||||
%patch12 -p1 -b .sparseTotals
|
%patch12 -p1 -b .sparseTotals
|
||||||
%patch13 -p1 -b .newerOption
|
%patch13 -p1 -b .newerOption
|
||||||
|
%patch14 -p1 -b .padCorrectly
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -110,6 +113,9 @@ fi
|
|||||||
%{_infodir}/tar.info*
|
%{_infodir}/tar.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 04 2005 Peter Vrabec <pvrabec@redhat.com> 1.15.1-11
|
||||||
|
- correctly pad archive members that shrunk during archiving (#172373)
|
||||||
|
|
||||||
* Tue Sep 06 2005 Peter Vrabec <pvrabec@redhat.com> 1.15.1-10
|
* Tue Sep 06 2005 Peter Vrabec <pvrabec@redhat.com> 1.15.1-10
|
||||||
- provide man page (#163709, #54243, #56041)
|
- provide man page (#163709, #54243, #56041)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user