upgrade, which also fix incremental backup (#206121)
This commit is contained in:
parent
b3e6d159c6
commit
3be11666d4
@ -1,3 +1,3 @@
|
||||
tar-1.15.91.tar.gz
|
||||
tar-1.15.91.tar.gz.sig
|
||||
tar.1
|
||||
tar-1.15.90.tar.gz.sig
|
||||
tar-1.15.90.tar.gz
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
fd74a2f1840e80d27bc6cc4bd07d5374 tar-1.15.91.tar.gz
|
||||
2aabe87c0ea26c84c51e1d446ad4327f tar-1.15.91.tar.gz.sig
|
||||
0ee6e8f5657a0b8f08723bb0095aec18 tar.1
|
||||
34c34e2936988408c9b834978c70e78a tar-1.15.90.tar.gz.sig
|
||||
f7009caa98f15ed4efa2b2f7c4d702e0 tar-1.15.90.tar.gz
|
||||
|
@ -1,214 +0,0 @@
|
||||
--- tar-1.15.1/configure.nolibrt 2004-12-21 13:30:30.000000000 +0000
|
||||
+++ tar-1.15.1/configure 2005-01-07 11:18:51.878839553 +0000
|
||||
@@ -11470,20 +11470,20 @@
|
||||
# dnl Persuade glibc <time.h> to declare these functions.
|
||||
|
||||
|
||||
- # Solaris 2.5.1 needs -lposix4 to get the clock_gettime function.
|
||||
+ # Solaris 2.5.1 needs -lposix4 to get the clock_gettyme function.
|
||||
# Solaris 7 prefers the library name -lrt to the obsolescent name -lposix4.
|
||||
|
||||
# Save and restore LIBS so e.g., -lrt, isn't added to it. Otherwise, *all*
|
||||
# programs in the package would end up linked with that potentially-shared
|
||||
# library, inducing unnecessary run-time overhead.
|
||||
fetish_saved_libs=$LIBS
|
||||
- echo "$as_me:$LINENO: checking for library containing clock_gettime" >&5
|
||||
-echo $ECHO_N "checking for library containing clock_gettime... $ECHO_C" >&6
|
||||
-if test "${ac_cv_search_clock_gettime+set}" = set; then
|
||||
+ echo "$as_me:$LINENO: checking for library containing clock_gettyme" >&5
|
||||
+echo $ECHO_N "checking for library containing clock_gettyme... $ECHO_C" >&6
|
||||
+if test "${ac_cv_search_clock_gettyme+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_func_search_save_LIBS=$LIBS
|
||||
-ac_cv_search_clock_gettime=no
|
||||
+ac_cv_search_clock_gettyme=no
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -11497,11 +11497,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -11528,7 +11528,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="none required"
|
||||
+ ac_cv_search_clock_gettyme="none required"
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
@@ -11536,7 +11536,7 @@
|
||||
fi
|
||||
rm -f conftest.err conftest.$ac_objext \
|
||||
conftest$ac_exeext conftest.$ac_ext
|
||||
-if test "$ac_cv_search_clock_gettime" = no; then
|
||||
+if test "$ac_cv_search_clock_gettyme" = no; then
|
||||
for ac_lib in rt posix4; do
|
||||
LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
@@ -11552,11 +11552,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -11583,7 +11583,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="-l$ac_lib"
|
||||
+ ac_cv_search_clock_gettyme="-l$ac_lib"
|
||||
break
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
@@ -11596,18 +11596,18 @@
|
||||
fi
|
||||
LIBS=$ac_func_search_save_LIBS
|
||||
fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettime" >&5
|
||||
-echo "${ECHO_T}$ac_cv_search_clock_gettime" >&6
|
||||
-if test "$ac_cv_search_clock_gettime" != no; then
|
||||
- test "$ac_cv_search_clock_gettime" = "none required" || LIBS="$ac_cv_search_clock_gettime $LIBS"
|
||||
- test "$ac_cv_search_clock_gettime" = "none required" ||
|
||||
- LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettime
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettyme" >&5
|
||||
+echo "${ECHO_T}$ac_cv_search_clock_gettyme" >&6
|
||||
+if test "$ac_cv_search_clock_gettyme" != no; then
|
||||
+ test "$ac_cv_search_clock_gettyme" = "none required" || LIBS="$ac_cv_search_clock_gettyme $LIBS"
|
||||
+ test "$ac_cv_search_clock_gettyme" = "none required" ||
|
||||
+ LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettyme
|
||||
fi
|
||||
|
||||
|
||||
|
||||
|
||||
-for ac_func in clock_gettime clock_settime
|
||||
+for ac_func in clock_gettyme clock_settime
|
||||
do
|
||||
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
echo "$as_me:$LINENO: checking for $ac_func" >&5
|
||||
@@ -20541,17 +20541,17 @@
|
||||
# programs in the package would end up linked with that potentially-shared
|
||||
# library, inducing unnecessary run-time overhead.
|
||||
|
||||
-# Solaris 2.5.1 needs -lposix4 to get the clock_gettime function.
|
||||
+# Solaris 2.5.1 needs -lposix4 to get the clock_gettyme function.
|
||||
# Solaris 7 prefers the library name -lrt to the obsolescent name -lposix4.
|
||||
tar_save_LIBS=$LIBS
|
||||
LIB_CLOCK_GETTIME=
|
||||
- echo "$as_me:$LINENO: checking for library containing clock_gettime" >&5
|
||||
-echo $ECHO_N "checking for library containing clock_gettime... $ECHO_C" >&6
|
||||
-if test "${ac_cv_search_clock_gettime+set}" = set; then
|
||||
+ echo "$as_me:$LINENO: checking for library containing clock_gettyme" >&5
|
||||
+echo $ECHO_N "checking for library containing clock_gettyme... $ECHO_C" >&6
|
||||
+if test "${ac_cv_search_clock_gettyme+set}" = set; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
ac_func_search_save_LIBS=$LIBS
|
||||
-ac_cv_search_clock_gettime=no
|
||||
+ac_cv_search_clock_gettyme=no
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
_ACEOF
|
||||
@@ -20565,11 +20565,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -20596,7 +20596,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="none required"
|
||||
+ ac_cv_search_clock_gettyme="none required"
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
sed 's/^/| /' conftest.$ac_ext >&5
|
||||
@@ -20604,7 +20604,7 @@
|
||||
fi
|
||||
rm -f conftest.err conftest.$ac_objext \
|
||||
conftest$ac_exeext conftest.$ac_ext
|
||||
-if test "$ac_cv_search_clock_gettime" = no; then
|
||||
+if test "$ac_cv_search_clock_gettyme" = no; then
|
||||
for ac_lib in rt posix4; do
|
||||
LIBS="-l$ac_lib $ac_func_search_save_LIBS"
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
@@ -20620,11 +20620,11 @@
|
||||
#endif
|
||||
/* We use char because int might match the return type of a gcc2
|
||||
builtin and then its argument prototype would still apply. */
|
||||
-char clock_gettime ();
|
||||
+char clock_gettyme ();
|
||||
int
|
||||
main ()
|
||||
{
|
||||
-clock_gettime ();
|
||||
+clock_gettyme ();
|
||||
;
|
||||
return 0;
|
||||
}
|
||||
@@ -20651,7 +20651,7 @@
|
||||
ac_status=$?
|
||||
echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
(exit $ac_status); }; }; then
|
||||
- ac_cv_search_clock_gettime="-l$ac_lib"
|
||||
+ ac_cv_search_clock_gettyme="-l$ac_lib"
|
||||
break
|
||||
else
|
||||
echo "$as_me: failed program was:" >&5
|
||||
@@ -20664,19 +20664,19 @@
|
||||
fi
|
||||
LIBS=$ac_func_search_save_LIBS
|
||||
fi
|
||||
-echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettime" >&5
|
||||
-echo "${ECHO_T}$ac_cv_search_clock_gettime" >&6
|
||||
-if test "$ac_cv_search_clock_gettime" != no; then
|
||||
- test "$ac_cv_search_clock_gettime" = "none required" || LIBS="$ac_cv_search_clock_gettime $LIBS"
|
||||
+echo "$as_me:$LINENO: result: $ac_cv_search_clock_gettyme" >&5
|
||||
+echo "${ECHO_T}$ac_cv_search_clock_gettyme" >&6
|
||||
+if test "$ac_cv_search_clock_gettyme" != no; then
|
||||
+ test "$ac_cv_search_clock_gettyme" = "none required" || LIBS="$ac_cv_search_clock_gettyme $LIBS"
|
||||
|
||||
fi
|
||||
|
||||
- case "$ac_cv_search_clock_gettime" in
|
||||
- -l*) LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettime;;
|
||||
+ case "$ac_cv_search_clock_gettyme" in
|
||||
+ -l*) LIB_CLOCK_GETTIME=$ac_cv_search_clock_gettyme;;
|
||||
esac
|
||||
|
||||
|
||||
-for ac_func in clock_gettime
|
||||
+for ac_func in clock_gettyme
|
||||
do
|
||||
as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
|
||||
echo "$as_me:$LINENO: checking for $ac_func" >&5
|
31
tar.spec
31
tar.spec
@ -1,20 +1,18 @@
|
||||
Summary: A GNU file archiving program.
|
||||
Name: tar
|
||||
Version: 1.15.90
|
||||
Release: 7
|
||||
Version: 1.15.91
|
||||
Release: 1
|
||||
License: GPL
|
||||
Group: Applications/Archiving
|
||||
URL: http://www.gnu.org/software/tar/
|
||||
Source0: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.gz
|
||||
Source1: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.gz.sig
|
||||
Source2: tar.1
|
||||
Patch1: tar-1.14-nolibrt.patch
|
||||
Patch2: tar-1.14-loneZeroWarning.patch
|
||||
Patch3: tar-1.15.1-vfatTruncate.patch
|
||||
Patch4: tar-1.15.90-makeCheck.patch
|
||||
Patch5: tar-1.15.90-permissions.patch
|
||||
Patch6: tar-1.15.90-incompatibility.patch
|
||||
Patch7: tar-1.15.90-xattrSupport.patch
|
||||
Patch1: tar-1.14-loneZeroWarning.patch
|
||||
Patch2: tar-1.15.1-vfatTruncate.patch
|
||||
Patch3: tar-1.15.91-makeCheck.patch
|
||||
Patch4: tar-1.15.90-incompatibility.patch
|
||||
Patch5: tar-1.15.90-xattrSupport.patch
|
||||
Prereq: info
|
||||
BuildRequires: autoconf automake gzip
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||
@ -33,13 +31,11 @@ the rmt package.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
#%patch1 -p1 -b .nolibrt
|
||||
%patch2 -p1 -b .loneZeroWarning
|
||||
%patch3 -p1 -b .vfatTruncate
|
||||
%patch4 -p1 -b .makeCheck
|
||||
%patch5 -p1 -b .permissions
|
||||
%patch6 -p1 -b .incompatibility
|
||||
%patch7 -p1 -b .xattrSupport
|
||||
%patch1 -p1 -b .loneZeroWarning
|
||||
%patch2 -p1 -b .vfatTruncate
|
||||
%patch3 -p1 -b .makeCheck
|
||||
%patch4 -p1 -b .incompatibility
|
||||
%patch5 -p1 -b .xattrSupport
|
||||
|
||||
%build
|
||||
%configure --bindir=/bin --libexecdir=/sbin
|
||||
@ -96,6 +92,9 @@ fi
|
||||
%{_infodir}/tar.info*
|
||||
|
||||
%changelog
|
||||
* Wed Sep 13 2006 Peter Vrabec <pvrabec@redhat.com> 1.15.91-1
|
||||
- upgrade, which also fix incremental backup (#206121)
|
||||
|
||||
* Fri Sep 08 2006 Peter Vrabec <pvrabec@redhat.com> 1.15.90-7
|
||||
- fix tar-debuginfo package (#205615)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user