*** empty log message ***
This commit is contained in:
parent
d76f59ce70
commit
2f94796276
24
tar-1.14-loneZeroWarning.patch
Normal file
24
tar-1.14-loneZeroWarning.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
--- tar-1.14/src/list.c.loneZeroWarning 2004-05-10 13:49:09.000000000 +0200
|
||||||
|
+++ tar-1.14/src/list.c 2004-10-11 14:19:31.492760992 +0200
|
||||||
|
@@ -138,6 +138,13 @@
|
||||||
|
|
||||||
|
if (!ignore_zeros_option)
|
||||||
|
{
|
||||||
|
+ /*
|
||||||
|
+ * According to POSIX tar specs, this is wrong, but on the web
|
||||||
|
+ * there are some tar specs that can trigger this, and some tar
|
||||||
|
+ * implementations create tars according to that spec. For now,
|
||||||
|
+ * let's not be pedantic about issuing the warning.
|
||||||
|
+ */
|
||||||
|
+#if 0
|
||||||
|
char buf[UINTMAX_STRSIZE_BOUND];
|
||||||
|
|
||||||
|
status = read_header (false);
|
||||||
|
@@ -145,6 +152,7 @@
|
||||||
|
break;
|
||||||
|
WARN ((0, 0, _("A lone zero block at %s"),
|
||||||
|
STRINGIFY_BIGINT (current_block_ordinal (), buf)));
|
||||||
|
+#endif
|
||||||
|
break;
|
||||||
|
}
|
||||||
|
status = prev_status;
|
8
tar.spec
8
tar.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: A GNU file archiving program.
|
Summary: A GNU file archiving program.
|
||||||
Name: tar
|
Name: tar
|
||||||
Version: 1.14
|
Version: 1.14
|
||||||
Release: 3
|
Release: 4
|
||||||
License: GPL
|
License: GPL
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
URL: http://www.gnu.org/software/tar/
|
URL: http://www.gnu.org/software/tar/
|
||||||
@ -10,6 +10,7 @@ Source1: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.bz2.sig
|
|||||||
Patch0: tar-1.13.18-manpage.patch
|
Patch0: tar-1.13.18-manpage.patch
|
||||||
Patch6: tar-1.14-nolibrt.patch
|
Patch6: tar-1.14-nolibrt.patch
|
||||||
Patch7: tar-1.14-err.patch
|
Patch7: tar-1.14-err.patch
|
||||||
|
Patch8: tar-1.14-loneZeroWarning.patch
|
||||||
Prereq: info
|
Prereq: info
|
||||||
BuildRequires: autoconf automake gzip
|
BuildRequires: autoconf automake gzip
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
Buildroot: %{_tmppath}/%{name}-%{version}-root
|
||||||
@ -31,6 +32,7 @@ the rmt package.
|
|||||||
%patch0 -p1 -b .manpage
|
%patch0 -p1 -b .manpage
|
||||||
%patch6 -p1 -b .librt
|
%patch6 -p1 -b .librt
|
||||||
%patch7 -p1 -b .err
|
%patch7 -p1 -b .err
|
||||||
|
%patch8 -p1 -b .loneZeroWarning
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -99,6 +101,10 @@ fi
|
|||||||
%{_infodir}/tar.info*
|
%{_infodir}/tar.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Oct 11 2004 Peter Vrabec <pvrabec@redhat.com>
|
||||||
|
- patch to stop issuing lone zero block warnings
|
||||||
|
- rebuilt
|
||||||
|
|
||||||
* Mon Oct 11 2004 Peter Vrabec <pvrabec@redhat.com>
|
* Mon Oct 11 2004 Peter Vrabec <pvrabec@redhat.com>
|
||||||
- URL added to spec file
|
- URL added to spec file
|
||||||
- spec file clean up
|
- spec file clean up
|
||||||
|
Loading…
Reference in New Issue
Block a user