tests: avoid two false failures related to -T
Version: 1.28-6
This commit is contained in:
parent
132f2c7962
commit
0bf621e87f
47
tar-1.28-T-tests-false-failure.patch
Normal file
47
tar-1.28-T-tests-false-failure.patch
Normal file
@ -0,0 +1,47 @@
|
||||
From: Pavel Raiskup <praiskup@redhat.com>
|
||||
Date: Wed, 17 Dec 2014 07:22:28 +0100
|
||||
Subject: [PATCH 12/12] testsuite: sort (otherwise random) expected output
|
||||
|
||||
Downstream, proposed:
|
||||
http://www.mail-archive.com/bug-tar@gnu.org/msg04798.html
|
||||
|
||||
diff --git a/tests/T-dir00.at b/tests/T-dir00.at
|
||||
index 7f89fcf..8ff6ba8 100644
|
||||
--- a/tests/T-dir00.at
|
||||
+++ b/tests/T-dir00.at
|
||||
@@ -28,13 +28,14 @@
|
||||
AT_SETUP([recursive extraction from --files-from])
|
||||
AT_KEYWORDS([files-from extract T-dir T-dir00])
|
||||
AT_TAR_CHECK([
|
||||
+AT_SORT_PREREQ
|
||||
mkdir dir
|
||||
genfile -f dir/file1
|
||||
genfile -f dir/file2
|
||||
tar cf archive dir
|
||||
rm -rf dir
|
||||
echo dir > list
|
||||
-tar xfTv archive list
|
||||
+tar xfTv archive list | sort
|
||||
],
|
||||
[0],
|
||||
[dir/
|
||||
diff --git a/tests/T-dir01.at b/tests/T-dir01.at
|
||||
index 155a373..db92292 100644
|
||||
--- a/tests/T-dir01.at
|
||||
+++ b/tests/T-dir01.at
|
||||
@@ -28,13 +28,14 @@
|
||||
AT_SETUP([trailing slash in --files-from])
|
||||
AT_KEYWORDS([files-from extract T-dir T-dir01])
|
||||
AT_TAR_CHECK([
|
||||
+AT_SORT_PREREQ
|
||||
mkdir dir
|
||||
genfile -f dir/file1
|
||||
genfile -f dir/file2
|
||||
tar cf archive dir
|
||||
rm -rf dir
|
||||
echo dir/ > list
|
||||
-tar xfTv archive list
|
||||
+tar xfTv archive list | sort
|
||||
],
|
||||
[0],
|
||||
[dir/
|
2
tar.spec
2
tar.spec
@ -25,6 +25,7 @@ Patch11: tar-1.28-sparse-inf-loops.patch
|
||||
Patch12: tar-1.28-big-sparse-listing.patch
|
||||
Patch13: tar-1.28-T-matchflags.patch
|
||||
Patch14: tar-1.28-T-recursion-tests.patch
|
||||
Patch15: tar-1.27-T-tests-false-failure.patch
|
||||
|
||||
# run "make check" by default
|
||||
%bcond_without check
|
||||
@ -120,6 +121,7 @@ fi
|
||||
%changelog
|
||||
* Fri Jun 26 2015 Pavel Raiskup <praiskup@redhat.com> - 1.28-6
|
||||
- fix --files-from and -T cooperation (rhbz#1230762)
|
||||
- avoid two testsuite false alarms related to --files-from option
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2:1.28-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
Loading…
Reference in New Issue
Block a user