fixed wrong documentation for xattrs/selinux/acl options (#466517), fixed
bug with null file terminator and change dirs(upstream)
This commit is contained in:
parent
7ba1de606a
commit
0aec5e967e
23
tar-1.19-null-terminator.patch
Normal file
23
tar-1.19-null-terminator.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
diff -urNp tar-1.20-orig/src/names.c tar-1.20/src/names.c
|
||||||
|
--- tar-1.20-orig/src/names.c 2008-09-24 10:53:41.000000000 +0200
|
||||||
|
+++ tar-1.20/src/names.c 2008-09-24 10:57:28.000000000 +0200
|
||||||
|
@@ -289,8 +289,7 @@ static int matching_flags; /* exclude_fn
|
||||||
|
static storage and can't be relied upon across two calls.
|
||||||
|
|
||||||
|
If CHANGE_DIRS is true, treat any entries of type NELT_CHDIR as
|
||||||
|
- the request to change to the given directory. If filename_terminator
|
||||||
|
- is NUL, CHANGE_DIRS is effectively always false.
|
||||||
|
+ the request to change to the given directory.
|
||||||
|
|
||||||
|
Entries of type NELT_FMASK cause updates of the matching_flags
|
||||||
|
value. */
|
||||||
|
@@ -301,9 +300,6 @@ name_next_elt (int change_dirs)
|
||||||
|
const char *source;
|
||||||
|
char *cursor;
|
||||||
|
|
||||||
|
- if (filename_terminator == '\0')
|
||||||
|
- change_dirs = 0;
|
||||||
|
-
|
||||||
|
while (name_index != names)
|
||||||
|
{
|
||||||
|
struct name_elt *ep;
|
@ -36,6 +36,74 @@ diff -up tar-1.17/configure.ac.xattrs tar-1.17/configure.ac
|
|||||||
diff -up tar-1.17/doc/tar.texi.xattrs tar-1.17/doc/tar.texi
|
diff -up tar-1.17/doc/tar.texi.xattrs tar-1.17/doc/tar.texi
|
||||||
--- tar-1.17/doc/tar.texi.xattrs 2007-06-08 10:25:19.000000000 +0200
|
--- tar-1.17/doc/tar.texi.xattrs 2007-06-08 10:25:19.000000000 +0200
|
||||||
+++ tar-1.17/doc/tar.texi 2007-12-10 15:31:54.000000000 +0100
|
+++ tar-1.17/doc/tar.texi 2007-12-10 15:31:54.000000000 +0100
|
||||||
|
@@ -2345,6 +2345,10 @@ Normally when creating an archive, @comm
|
||||||
|
@samp{/} from member names. This option disables that behavior.
|
||||||
|
@xref{absolute}.
|
||||||
|
|
||||||
|
+@opsummary{acl}
|
||||||
|
+@item --acls
|
||||||
|
+Causes @command{tar} to store ACL's. @xref{Attributes}.
|
||||||
|
+
|
||||||
|
@opsummary{after-date}
|
||||||
|
@item --after-date
|
||||||
|
|
||||||
|
@@ -2838,6 +2842,10 @@ contents have changed (as opposed to jus
|
||||||
|
also back up files for which any status information has
|
||||||
|
changed). @xref{after}.
|
||||||
|
|
||||||
|
+@opsummary{no-acl}
|
||||||
|
+@item --no-acls
|
||||||
|
+Causes @command{tar} not to store and not to extract ACL's. @xref{Attributes}.
|
||||||
|
+
|
||||||
|
@opsummary{no-anchored}
|
||||||
|
@item --no-anchored
|
||||||
|
An exclude pattern can match any subsequence of the name's components.
|
||||||
|
@@ -2900,11 +2908,21 @@ When extracting an archive, subtract the
|
||||||
|
the permissions specified in the archive. This is the default behavior
|
||||||
|
for ordinary users.
|
||||||
|
|
||||||
|
+@opsummary{no-selinux}
|
||||||
|
+@item --no-selinux
|
||||||
|
+Causes @command{tar} not to store and not to extract SELinux security context.
|
||||||
|
+@xref{Attributes}.
|
||||||
|
+
|
||||||
|
@opsummary{no-unquote}
|
||||||
|
@item --no-unquote
|
||||||
|
Treat all input file or member names literally, do not interpret
|
||||||
|
escape sequences. @xref{input name quoting}.
|
||||||
|
|
||||||
|
+@opsummary{no-xattrs}
|
||||||
|
+@item --no-xattrs
|
||||||
|
+Causes @command{tar} not to store and not to extract xattrs. This option also
|
||||||
|
+enables @option{--no-selinux} and @option{--no-acls}. @xref{Attributes}.
|
||||||
|
+
|
||||||
|
@opsummary{no-wildcards}
|
||||||
|
@item --no-wildcards
|
||||||
|
Do not use wildcards.
|
||||||
|
@@ -3132,6 +3150,11 @@ locations. Usually @command{tar} determ
|
||||||
|
the archive can be seeked or not. This option is intended for use
|
||||||
|
in cases when such recognition fails.
|
||||||
|
|
||||||
|
+@opsummary{selinux}
|
||||||
|
+@item --selinux
|
||||||
|
+Causes @command{tar} to store SElinux security context. @xref{Attributes}.
|
||||||
|
+
|
||||||
|
+
|
||||||
|
@opsummary{show-defaults}
|
||||||
|
@item --show-defaults
|
||||||
|
|
||||||
|
@@ -3328,6 +3351,11 @@ Used in conjunction with @option{--multi
|
||||||
|
keep track of which volume of a multi-volume archive it is working in
|
||||||
|
@var{file}. @xref{volno-file}.
|
||||||
|
|
||||||
|
+@opsummary{xattrs}
|
||||||
|
+@item --xattrs
|
||||||
|
+Causes @command{tar} to store xattrs. This option also enables
|
||||||
|
+@option{--selinux} and @option{--acls}. @xref{Attributes}.
|
||||||
|
+
|
||||||
|
@opsummary{wildcards}
|
||||||
|
@item --wildcards
|
||||||
|
Use wildcards when matching member names with patterns.
|
||||||
@@ -7845,6 +7845,8 @@ implementation able to read @samp{ustar}
|
@@ -7845,6 +7845,8 @@ implementation able to read @samp{ustar}
|
||||||
most @samp{posix} archives as well, with the only exception that any
|
most @samp{posix} archives as well, with the only exception that any
|
||||||
additional information (such as long file names etc.) will in such
|
additional information (such as long file names etc.) will in such
|
||||||
@ -75,7 +143,7 @@ diff -up tar-1.17/doc/tar.texi.xattrs tar-1.17/doc/tar.texi
|
|||||||
+This option causes @command{tar} not to store the current ACL in the archive
|
+This option causes @command{tar} not to store the current ACL in the archive
|
||||||
+and not to extract any ACL information in an archive.
|
+and not to extract any ACL information in an archive.
|
||||||
+
|
+
|
||||||
+The @option{--acls} option has no equivalent short option name.
|
+The @option{--no-acls} option has no equivalent short option name.
|
||||||
+
|
+
|
||||||
+@opindex no-selinux
|
+@opindex no-selinux
|
||||||
+@item --no-selinux
|
+@item --no-selinux
|
||||||
@ -83,16 +151,16 @@ diff -up tar-1.17/doc/tar.texi.xattrs tar-1.17/doc/tar.texi
|
|||||||
+context information in the archive and not to extract any SELinux information in
|
+context information in the archive and not to extract any SELinux information in
|
||||||
+an archive.
|
+an archive.
|
||||||
+
|
+
|
||||||
+The @option{--selinux} option has no equivalent short option name.
|
+The @option{--no-selinux} option has no equivalent short option name.
|
||||||
+
|
+
|
||||||
+@opindex xattrs
|
+@opindex no-xattrs
|
||||||
+@item --xattrs
|
+@item --no-xattrs
|
||||||
+This option causes @command{tar} not to store the current extended attributes in
|
+This option causes @command{tar} not to store the current extended attributes in
|
||||||
+the archive and not to extract any extended attributes in an archive. This
|
+the archive and not to extract any extended attributes in an archive. This
|
||||||
+option also enables @option{--acls} and @option{--selinux} if
|
+option also enables @option{--no-acls} and @option{--no-selinux} if
|
||||||
+they haven't been set already.
|
+they haven't been set already.
|
||||||
+
|
+
|
||||||
+The @option{--xattrs} option has no equivalent short option name.
|
+The @option{--no-xattrs} option has no equivalent short option name.
|
||||||
+
|
+
|
||||||
@end table
|
@end table
|
||||||
|
|
||||||
|
9
tar.spec
9
tar.spec
@ -2,7 +2,7 @@ Summary: A GNU file archiving program
|
|||||||
Name: tar
|
Name: tar
|
||||||
Epoch: 2
|
Epoch: 2
|
||||||
Version: 1.20
|
Version: 1.20
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
URL: http://www.gnu.org/software/tar/
|
URL: http://www.gnu.org/software/tar/
|
||||||
@ -14,6 +14,7 @@ Patch2: tar-1.15.1-vfatTruncate.patch
|
|||||||
Patch3: tar-1.19-xattrs.patch
|
Patch3: tar-1.19-xattrs.patch
|
||||||
Patch4: tar-1.19-xattrs-conf.patch
|
Patch4: tar-1.19-xattrs-conf.patch
|
||||||
Patch5: tar-1.17-wildcards.patch
|
Patch5: tar-1.17-wildcards.patch
|
||||||
|
Patch6: tar-1.19-null-terminator.patch
|
||||||
Prereq: info
|
Prereq: info
|
||||||
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk
|
BuildRequires: autoconf automake gzip texinfo gettext libacl-devel libselinux-devel gawk
|
||||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
@ -39,6 +40,7 @@ the rmt package.
|
|||||||
%patch3 -p1 -b .xattrs
|
%patch3 -p1 -b .xattrs
|
||||||
%patch4 -p1 -b .xattrs-conf
|
%patch4 -p1 -b .xattrs-conf
|
||||||
%patch5 -p1 -b .wildcards
|
%patch5 -p1 -b .wildcards
|
||||||
|
%patch6 -p1 -b .nullterm
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --bindir=/bin --libexecdir=/sbin
|
%configure --bindir=/bin --libexecdir=/sbin
|
||||||
@ -89,6 +91,11 @@ fi
|
|||||||
%{_infodir}/tar.info*
|
%{_infodir}/tar.info*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 10 2008 Ondrej Vasik <ovasik@redhat.com> 2:1.20-3
|
||||||
|
- Fixed wrong documentation for xattrs options (#466517)
|
||||||
|
- fixed bug with null file terminator and change dirs
|
||||||
|
(upstream)
|
||||||
|
|
||||||
* Fri Aug 29 2008 Ondrej Vasik <ovasik@redhat.com> 2:1.20-2
|
* Fri Aug 29 2008 Ondrej Vasik <ovasik@redhat.com> 2:1.20-2
|
||||||
- patch fuzz clean up
|
- patch fuzz clean up
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user