parent
f1413ea879
commit
07f0cd95cf
@ -0,0 +1,33 @@
|
|||||||
|
From 4c071d7f2a269f1c7b25402a272f90701b8a070c Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||||
|
Date: Mon, 5 Aug 2019 15:02:13 +0200
|
||||||
|
Subject: [PATCH] meson: create (empty) /etc/systemd/system during installation
|
||||||
|
|
||||||
|
We explicitly create /etc/systemd/user and other parts of the basic directory
|
||||||
|
tree. I think we should create /etc/systemd/system too. (The alternative would
|
||||||
|
be to not create those other directories too, but I think it's nice to have
|
||||||
|
the basic directory structure in place after installation.)
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1737362
|
||||||
|
---
|
||||||
|
src/core/meson.build | 7 +++----
|
||||||
|
1 file changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/core/meson.build b/src/core/meson.build
|
||||||
|
index 267d65a3b2..fb6820e109 100644
|
||||||
|
--- a/src/core/meson.build
|
||||||
|
+++ b/src/core/meson.build
|
||||||
|
@@ -212,7 +212,6 @@ meson.add_install_script('sh', '-c', mkdir_p.format(systemsleepdir))
|
||||||
|
meson.add_install_script('sh', '-c', mkdir_p.format(systemgeneratordir))
|
||||||
|
meson.add_install_script('sh', '-c', mkdir_p.format(usergeneratordir))
|
||||||
|
|
||||||
|
-meson.add_install_script('sh', '-c',
|
||||||
|
- mkdir_p.format(join_paths(pkgsysconfdir, 'user')))
|
||||||
|
-meson.add_install_script('sh', '-c',
|
||||||
|
- mkdir_p.format(join_paths(sysconfdir, 'xdg/systemd')))
|
||||||
|
+meson.add_install_script('sh', '-c', mkdir_p.format(join_paths(pkgsysconfdir, 'system')))
|
||||||
|
+meson.add_install_script('sh', '-c', mkdir_p.format(join_paths(pkgsysconfdir, 'user')))
|
||||||
|
+meson.add_install_script('sh', '-c', mkdir_p.format(join_paths(sysconfdir, 'xdg/systemd')))
|
||||||
|
--
|
||||||
|
2.22.0
|
||||||
|
|
@ -15,7 +15,7 @@
|
|||||||
Name: systemd
|
Name: systemd
|
||||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 243~rc1
|
Version: 243~rc1
|
||||||
Release: 1%{?commit:.git%{shortcommit}}%{?dist}
|
Release: 2%{?commit:.git%{shortcommit}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: System and Service Manager
|
Summary: System and Service Manager
|
||||||
@ -52,6 +52,9 @@ i=1; for j in 00*patch; do printf "Patch%04d: %s\n" $i $j; i=$((i+1));done|
|
|||||||
GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[67]* hwdb/parse_hwdb.py > hwdb.patch
|
GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[67]* hwdb/parse_hwdb.py > hwdb.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# Create and therefore own and provide /etc/systemd/system
|
||||||
|
# https://github.com/systemd/systemd/pull/13267
|
||||||
|
Patch0001: 0001-meson-create-empty-etc-systemd-system-during-install.patch
|
||||||
Patch0002: 0002-Revert-units-set-NoNewPrivileges-for-all-long-runnin.patch
|
Patch0002: 0002-Revert-units-set-NoNewPrivileges-for-all-long-runnin.patch
|
||||||
|
|
||||||
Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
||||||
@ -695,6 +698,9 @@ fi
|
|||||||
%files tests -f .file-list-tests
|
%files tests -f .file-list-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Aug 07 2019 Adam Williamson <awilliam@redhat.com> - 243~rc1-2
|
||||||
|
- Backport PR #1737362 so we own /etc/systemd/system again (#1737362)
|
||||||
|
|
||||||
* Tue Jul 30 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 243~rc1-1
|
* Tue Jul 30 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 243~rc1-1
|
||||||
- Update to latest version (#1715699, #1696373, #1711065, #1718192)
|
- Update to latest version (#1715699, #1696373, #1711065, #1718192)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user