Update to v243-rc1
This commit is contained in:
parent
bf71ff0b85
commit
f1413ea879
@ -1,4 +1,4 @@
|
||||
From 86aa208e639b119007332718aa4f453af2a061d0 Mon Sep 17 00:00:00 2001
|
||||
From 0c670fec00f3d5c103d9b7415d4e0510c61ad006 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Fri, 11 Mar 2016 17:06:17 -0500
|
||||
Subject: [PATCH] resolved: create /etc/resolv.conf symlink at runtime
|
||||
@ -18,10 +18,10 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1313085
|
||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/resolve/resolved.c b/src/resolve/resolved.c
|
||||
index f4efddf8e5..3386e3bf67 100644
|
||||
index 2ca9fbdc72..3c8a9ff12a 100644
|
||||
--- a/src/resolve/resolved.c
|
||||
+++ b/src/resolve/resolved.c
|
||||
@@ -45,6 +45,10 @@ static int run(int argc, char *argv[]) {
|
||||
@@ -49,6 +49,10 @@ static int run(int argc, char *argv[]) {
|
||||
/* Drop privileges, but only if we have been started as root. If we are not running as root we assume most
|
||||
* privileges are already dropped. */
|
||||
if (getuid() == 0) {
|
||||
@ -33,19 +33,16 @@ index f4efddf8e5..3386e3bf67 100644
|
||||
/* Drop privileges, but keep three caps. Note that we drop those too, later on (see below) */
|
||||
r = drop_privileges(uid, gid,
|
||||
diff --git a/tmpfiles.d/etc.conf.m4 b/tmpfiles.d/etc.conf.m4
|
||||
index df8d42101c..928105ea8d 100644
|
||||
index f82e0b82ce..66a777bdb2 100644
|
||||
--- a/tmpfiles.d/etc.conf.m4
|
||||
+++ b/tmpfiles.d/etc.conf.m4
|
||||
@@ -13,9 +13,6 @@ L+ /etc/mtab - - - - ../proc/self/mounts
|
||||
@@ -12,9 +12,6 @@ L+ /etc/mtab - - - - ../proc/self/mounts
|
||||
m4_ifdef(`HAVE_SMACK_RUN_LABEL',
|
||||
t /etc/mtab - - - - security.SMACK64=_
|
||||
)m4_dnl
|
||||
-m4_ifdef(`ENABLE_RESOLVE',
|
||||
-L! /etc/resolv.conf - - - - ../run/systemd/resolve/stub-resolv.conf
|
||||
-)m4_dnl
|
||||
C /etc/nsswitch.conf - - - -
|
||||
C! /etc/nsswitch.conf - - - -
|
||||
m4_ifdef(`HAVE_PAM',
|
||||
C /etc/pam.d - - - -
|
||||
--
|
||||
2.19.2
|
||||
|
||||
C! /etc/pam.d - - - -
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (systemd-9d34e79.tar.gz) = 41a5c319f516aba9a515cd6bdaaffe98eb3555820a45435f426d3efc2ba0bb0baf1bb8b1a306601cff862c4cf95223eb3e2a17ee2f413a217d2b6c0f8b4e7bfa
|
||||
SHA512 (systemd-243-rc1.tar.gz) = 6626d7fd5781578d01a30c0d2647a293668d0819f2f85ce78a6aaf62ae1aa4b2c687cf237ca833c5befbc00321a344ff5ca56747cedc6ce00cd0f51c71dd25ff
|
||||
|
20
systemd.spec
20
systemd.spec
@ -1,7 +1,7 @@
|
||||
%global commit 9d34e79ae8ef891adf3757f9248566def70471ad
|
||||
#global commit 9d34e79ae8ef891adf3757f9248566def70471ad
|
||||
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
|
||||
|
||||
%global stable 1
|
||||
#global stable 1
|
||||
|
||||
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
||||
# strip the automatically generated dep here and instead co-own the
|
||||
@ -14,8 +14,8 @@
|
||||
|
||||
Name: systemd
|
||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||
Version: 242
|
||||
Release: 7%{?commit:.git%{shortcommit}}%{?dist}
|
||||
Version: 243~rc1
|
||||
Release: 1%{?commit:.git%{shortcommit}}%{?dist}
|
||||
# For a breakdown of the licensing, see README
|
||||
License: LGPLv2+ and MIT and GPLv2+
|
||||
Summary: System and Service Manager
|
||||
@ -154,7 +154,7 @@ date, locale, maintain a list of logged-in users, system accounts,
|
||||
runtime directories and settings, and daemons to manage simple network
|
||||
configuration, network time synchronization, log forwarding, and name
|
||||
resolution.
|
||||
%if 0%{stable}
|
||||
%if 0%{?stable}
|
||||
This package was built from the %{version}-stable branch of systemd,
|
||||
commit https://github.com/systemd/systemd-stable/commit/%{shortcommit}.
|
||||
%endif
|
||||
@ -331,6 +331,8 @@ CONFIGURE_OPTS=(
|
||||
-Dsplit-bin=true
|
||||
-Db_lto=true
|
||||
-Db_ndebug=false
|
||||
-Dman=true
|
||||
-Ddefault-hierarchy=hybrid
|
||||
-Dversion-tag=v%{version}-%{release}
|
||||
)
|
||||
|
||||
@ -355,11 +357,6 @@ install -Dm0644 -t %{buildroot}/etc/ %{SOURCE5}
|
||||
install -Dm0644 %{SOURCE6} %{buildroot}/etc/sysctl.conf
|
||||
ln -s ../sysctl.conf %{buildroot}/etc/sysctl.d/99-sysctl.conf
|
||||
|
||||
# We create all wants links manually at installation time to make sure
|
||||
# they are not owned and hence overriden by rpm after the user deleted
|
||||
# them.
|
||||
rm -r %{buildroot}%{_sysconfdir}/systemd/system/*.target.wants
|
||||
|
||||
# Make sure these directories are properly owned
|
||||
mkdir -p %{buildroot}%{system_unit_dir}/basic.target.wants
|
||||
mkdir -p %{buildroot}%{system_unit_dir}/default.target.wants
|
||||
@ -698,6 +695,9 @@ fi
|
||||
%files tests -f .file-list-tests
|
||||
|
||||
%changelog
|
||||
* Tue Jul 30 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 243~rc1-1
|
||||
- Update to latest version (#1715699, #1696373, #1711065, #1718192)
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org>
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user