- resolves: #803032
update to 10.0.4 - resolves: #820725 enable sysstat service by default
This commit is contained in:
parent
52a0c289b3
commit
b57930dd7d
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
|||||||
/sysstat-10.0.3.tar.bz2
|
/sysstat-10.0.4.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
9f9d27b3c0e6dde6e4af71cd35b3dc89 sysstat-10.0.3.tar.bz2
|
7f3a302c0c6577ecdefdcfe8b335276f sysstat-10.0.4.tar.bz2
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff -up sysstat-10.0.0/mpstat.c.pom sysstat-10.0.0/mpstat.c
|
|
||||||
--- sysstat-10.0.0/mpstat.c.pom 2011-03-11 18:09:57.000000000 +0100
|
|
||||||
+++ sysstat-10.0.0/mpstat.c 2011-04-04 11:22:20.000000000 +0200
|
|
||||||
@@ -418,6 +418,9 @@ void write_stats_core(int prev, int curr
|
|
||||||
|
|
||||||
/* Recalculate itv for current proc */
|
|
||||||
pc_itv = get_per_cpu_interval(scc, scp);
|
|
||||||
+ if ((scc->cpu_user - scc->cpu_guest) < (scp->cpu_user - scp->cpu_guest))
|
|
||||||
+ pc_itv = pc_itv + (scp->cpu_user - scp->cpu_guest) -
|
|
||||||
+ (scc->cpu_user - scc->cpu_guest);
|
|
||||||
|
|
||||||
if (!pc_itv) {
|
|
||||||
/*
|
|
23
sysstat.spec
23
sysstat.spec
@ -1,14 +1,12 @@
|
|||||||
Name: sysstat
|
Name: sysstat
|
||||||
Version: 10.0.3
|
Version: 10.0.4
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: The sar and iostat system monitoring commands
|
Summary: The sar and iostat system monitoring commands
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://perso.orange.fr/sebastien.godard/
|
URL: http://sebastien.godard.pagesperso-orange.fr/
|
||||||
Source0: http://perso.orange.fr/sebastien.godard/%{name}-%{version}.tar.bz2
|
Source0: http://pagesperso-orange.fr/sebastien.godard/%{name}-%{version}.tar.bz2
|
||||||
Source1: sysstat.service
|
Source1: sysstat.service
|
||||||
# fixes #643380
|
|
||||||
Patch11: sysstat-10.0.0-cpu.patch
|
|
||||||
Patch12: sysstat-10.0.0-makefile.patch
|
Patch12: sysstat-10.0.0-makefile.patch
|
||||||
Requires: sh-utils textutils grep fileutils /etc/cron.d
|
Requires: sh-utils textutils grep fileutils /etc/cron.d
|
||||||
BuildRequires: lm_sensors-devel
|
BuildRequires: lm_sensors-devel
|
||||||
@ -27,7 +25,6 @@ activity.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch11 -p1 -b .cpu
|
|
||||||
%patch12 -p1 -b .ls
|
%patch12 -p1 -b .ls
|
||||||
iconv -f windows-1252 -t utf8 CREDITS > CREDITS.aux
|
iconv -f windows-1252 -t utf8 CREDITS > CREDITS.aux
|
||||||
mv CREDITS.aux CREDITS
|
mv CREDITS.aux CREDITS
|
||||||
@ -49,9 +46,9 @@ sed -i 's|@LIBDIR@|%{_libdir}|g' %{buildroot}%{_unitdir}/sysstat.service
|
|||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
%post
|
%post
|
||||||
if [ $1 -eq 1 ] ; then
|
if [ $1 -eq 1 ] ; then
|
||||||
# Initial installation
|
# Initial installation
|
||||||
/bin/systemctl daemon-reload >/dev/null 2>&1 || :
|
/bin/systemctl enable sysstat.service >/dev/null 2>&1 || :
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%preun
|
%preun
|
||||||
@ -94,6 +91,12 @@ fi
|
|||||||
%{_localstatedir}/log/sa
|
%{_localstatedir}/log/sa
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed May 16 2012 Peter Schiffer <pschiffe@redhat.com> - 10.0.4-1
|
||||||
|
- resolves: #803032
|
||||||
|
update to 10.0.4
|
||||||
|
- resolves: #820725
|
||||||
|
enable sysstat service by default
|
||||||
|
|
||||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 10.0.3-2
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 10.0.3-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user