- update to 7.0.4
- spec file cleanup
This commit is contained in:
parent
3a808413e3
commit
adb1a209cf
@ -1 +1 @@
|
||||
sysstat-7.0.3.tar.bz2
|
||||
sysstat-7.0.4.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
2ec104d877d540793deeaa186717ce0f sysstat-7.0.3.tar.bz2
|
||||
46a6af9c5486809c4f1fb4f8fcdf2684 sysstat-7.0.4.tar.bz2
|
||||
|
13
sysstat-7.0.4-statreset.patch
Normal file
13
sysstat-7.0.4-statreset.patch
Normal file
@ -0,0 +1,13 @@
|
||||
--- sysstat-7.0.4/sysstat.in.stat 2007-01-22 14:02:54.000000000 +0100
|
||||
+++ sysstat-7.0.4/sysstat.in 2007-02-12 13:45:44.000000000 +0100
|
||||
@@ -1,6 +1,9 @@
|
||||
#!/bin/sh
|
||||
#
|
||||
-# chkconfig: 235 03 97
|
||||
+# sysstat Reset the system activity logs
|
||||
+#
|
||||
+# chkconfig: 12345 01 99
|
||||
+# description: Reset the system activity logs
|
||||
# INIT_DIR/sysstat
|
||||
# 2000/01/22 - Sebastien Godard <sebastien.godard@wanadoo.fr>
|
||||
#
|
32
sysstat-7.0.4-tmp.patch
Normal file
32
sysstat-7.0.4-tmp.patch
Normal file
@ -0,0 +1,32 @@
|
||||
--- sysstat-7.0.4/sysstat.in.tmp 2007-01-22 14:02:54.000000000 +0100
|
||||
+++ sysstat-7.0.4/sysstat.in 2007-02-12 13:57:41.000000000 +0100
|
||||
@@ -17,8 +17,9 @@
|
||||
|
||||
RETVAL=0
|
||||
HISTORY=0
|
||||
+TMPDIR=/var/run/
|
||||
# Remove flag indicating that sadc was successfully launched
|
||||
-rm -f /tmp/sysstat.run
|
||||
+rm -f ${TMPDIR}sysstat.run
|
||||
|
||||
# See how we were called.
|
||||
case "$1" in
|
||||
@@ -39,15 +40,15 @@
|
||||
CHOWN ${CURRENTDIR} ${CURRENTFILE} ${CURRENTDIR}/${CURRENTFILE}
|
||||
fi
|
||||
echo -n "Calling the system activity data collector (sadc): "
|
||||
- SU SA_LIB_DIR/sadc -F -L - && touch /tmp/sysstat.run QUOTE
|
||||
+ SU SA_LIB_DIR/sadc -F -L - && touch ${TMPDIR}sysstat.run QUOTE
|
||||
|
||||
# Try to guess if sadc was successfully launched. The difficulty
|
||||
# here is that the exit code is lost when the above command is
|
||||
# run via "su foo -c ..."
|
||||
- if [ ! -f /tmp/sysstat.run ]; then
|
||||
+ if [ ! -f ${TMPDIR}sysstat.run ]; then
|
||||
RETVAL=1
|
||||
else
|
||||
- rm -f /tmp/sysstat.run
|
||||
+ rm -f ${TMPDIR}sysstat.run
|
||||
fi
|
||||
echo
|
||||
;;
|
35
sysstat.spec
35
sysstat.spec
@ -1,7 +1,7 @@
|
||||
Name: sysstat
|
||||
Version: 7.0.3
|
||||
Release: 3%{?dist}
|
||||
Summary: The sar and iostat system monitoring commands.
|
||||
Version: 7.0.4
|
||||
Release: 1%{?dist}
|
||||
Summary: The sar and iostat system monitoring commands
|
||||
License: GPL
|
||||
Group: Applications/System
|
||||
URL: http://perso.orange.fr/sebastien.godard/
|
||||
@ -10,15 +10,15 @@ Source1: sysstat.crond
|
||||
Source2: sysstat.crondaily
|
||||
Source3: sysstat.sysconfig
|
||||
Patch0: sysstat-4.0.1-config.patch
|
||||
Patch3: sysstat-5.0.5-statreset.patch
|
||||
Patch3: sysstat-7.0.4-statreset.patch
|
||||
Patch6: sysstat-5.0.5-append-msg.patch
|
||||
Patch9: sysstat-7.0.0-tmp.patch
|
||||
Patch9: sysstat-7.0.4-tmp.patch
|
||||
Patch10: sysstat-7.0.3-debuginfo.patch
|
||||
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
Requires: /sbin/chkconfig
|
||||
Prereq: sh-utils textutils grep fileutils /etc/cron.d
|
||||
Requires: sh-utils textutils grep fileutils /etc/cron.d
|
||||
BuildRequires: perl %{_includedir}/linux/if.h gettext
|
||||
Requires: %__cp %__mv %__chmod %__grep %__mkdir %__install %__id
|
||||
|
||||
@ -39,7 +39,7 @@ activity.
|
||||
# FIXME: I need to fix the upstream Makefile to use LIBDIR et al. properly and
|
||||
# send the upstream maintainer a patch.
|
||||
CFLAGS="$RPM_OPT_FLAGS -DSADC_PATH=\\\"%{_libdir}/sa/sadc\\\""
|
||||
make CFLAGS="$CFLAGS" PREFIX=%{_prefix} LIB_DIR=%{_libdir} SA_LIB_DIR=%{_libdir}/sa MAN_DIR=%{_mandir} DATA_DIR=%{_datadir} DOC_DIR=%{_docdir}
|
||||
make CFLAGS="$CFLAGS" PREFIX=%{_prefix} LIB_DIR=%{_libdir} SA_LIB_DIR=%{_libdir}/sa MAN_DIR=%{_mandir} DATA_DIR=%{_datadir} DOC_DIR=%{_docdir} %{?_smp_mflags}
|
||||
|
||||
# Thou shalt not write to source files or patches
|
||||
rm -f sysstat.crond
|
||||
@ -102,7 +102,6 @@ rm -rf %{buildroot}
|
||||
%defattr(-,root,root)
|
||||
%doc CHANGES COPYING CREDITS README TODO FAQ
|
||||
%config(noreplace) /etc/cron.d/sysstat
|
||||
#config(noreplace) /etc/cron.daily/sysstat
|
||||
%config(noreplace) /etc/sysconfig/sysstat
|
||||
%config(noreplace) /etc/sysconfig/sysstat.ioconf
|
||||
%{_initrddir}/sysstat
|
||||
@ -113,6 +112,10 @@ rm -rf %{buildroot}
|
||||
/var/log/sa
|
||||
|
||||
%changelog
|
||||
* Mon Feb 12 2007 Ivana Varekova <varekova@redhat.com> - 7.0.4-1
|
||||
- update to 7.0.4
|
||||
- spec file cleanup
|
||||
|
||||
* Tue Jan 30 2007 Ivana Varekova <varekova@redhat.com> - 7.0.3-3
|
||||
- remove -s flag
|
||||
|
||||
@ -251,13 +254,13 @@ rm -rf %{buildroot}
|
||||
* Tue Oct 8 2002 Mike A. Harris <mharris@redhat.com> 4.0.5-6
|
||||
- All-arch rebuild
|
||||
|
||||
* Tue Jul 23 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.5-3
|
||||
* Tue Jul 23 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.5-3
|
||||
- Rebuild
|
||||
|
||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Mon Jun 17 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.5-1
|
||||
* Mon Jun 17 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.5-1
|
||||
- 4.0.5-1
|
||||
- isag is no longer installed by default upstream, removing
|
||||
requirement on gnuplot
|
||||
@ -265,24 +268,24 @@ rm -rf %{buildroot}
|
||||
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Mon Apr 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-1
|
||||
* Mon Apr 22 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.4-1
|
||||
- 4.0.4
|
||||
- Add an explicit requires on gnuplot (#63474)
|
||||
|
||||
* Fri Apr 12 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.3-2
|
||||
* Fri Apr 12 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.3-2
|
||||
- Do the daily sa2 run just before midnight, not at 4AM... you'd
|
||||
only get 4 hours worth of data that way (#63132)
|
||||
|
||||
* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.3-1
|
||||
* Thu Feb 28 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.3-1
|
||||
- 4.0.3
|
||||
|
||||
* Wed Feb 27 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.2-3
|
||||
* Wed Feb 27 2002 Trond Eivind Glomsrød <teg@redhat.com> 4.0.2-3
|
||||
- Rebuild
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Wed Dec 12 2001 Trond Eivind Glomsrød <teg@redhat.com> 4.0.2-1
|
||||
* Wed Dec 12 2001 Trond Eivind Glomsrød <teg@redhat.com> 4.0.2-1
|
||||
- 4.0.2
|
||||
- the kernel patch for extended statistics is in, don't say it needs
|
||||
applying in the man page
|
||||
|
Loading…
Reference in New Issue
Block a user