Update to v12.6.0

Resolves: #2091359
This commit is contained in:
Lukáš Zaoral 2022-05-30 09:41:21 +02:00
parent 10ed8bf6e6
commit 1dec86a2d7
No known key found for this signature in database
GPG Key ID: 39157506DD67752D
4 changed files with 6 additions and 128 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@
/v12.5.3.tar.gz
/v12.5.4.tar.gz
/v12.5.6.tar.gz
/v12.6.0.tar.gz

View File

@ -1,123 +0,0 @@
From 28c490333f9cbaf1c656a786714e2d0b252270f2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Luk=C3=A1=C5=A1=20Zaoral?= <lzaoral@redhat.com>
Date: Thu, 31 Mar 2022 14:06:03 +0200
Subject: [PATCH 1/3] Makefile: honour LDFLAGS passed to ./configure
The configure script help says that the LDFLAGS environment variable can be
used to pass additional flags to linker during build.
However, Makefile.in did not mention this variable at all so the additional
flags were silently skipped.
---
Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile.in b/Makefile.in
index db31aad..99c2e65 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -110,7 +110,7 @@ DFLAGS += $(TFLAGS)
endif
ifndef LFLAGS
-LFLAGS = @STRIP@
+LFLAGS = @STRIP@ @LDFLAGS@
endif
# Commands
--
2.35.1
From 4706c6d4ff06b8f565660f5b6801bf9efb652f88 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Luk=C3=A1=C5=A1=20Zaoral?= <lzaoral@redhat.com>
Date: Thu, 31 Mar 2022 14:33:08 +0200
Subject: [PATCH 2/3] configure: do not overwrite LDFLAGS in test for 32-bit
libsensors
---
configure | 4 +++-
configure.in | 4 +++-
2 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/configure b/configure
index aa5af95..e999217 100755
--- a/configure
+++ b/configure
@@ -4783,7 +4783,8 @@ HAVE_SENSORS32="n"
if test $SENSORS_SUPPORT = "y"; then
CFLAGS_SAVE=$CFLAGS
CFLAGS+=" -m32"
- LDFLAGS=" -lsensors"
+ LDFLAGS_SAVE=$LDFLAGS
+ LDFLAGS+=" -lsensors"
SENSORS=no
# Check for another function to avoid using cached result
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for sensors_cleanup in -lsensors" >&5
@@ -4852,6 +4853,7 @@ rm -f core conftest.err conftest.$ac_objext \
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $SENSORS" >&5
$as_echo "$SENSORS" >&6; }
CFLAGS=$CFLAGS_SAVE
+ LDFLAGS=$LDFLAGS_SAVE
fi
diff --git a/configure.in b/configure.in
index 279347a..11cb3a3 100644
--- a/configure.in
+++ b/configure.in
@@ -191,7 +191,8 @@ HAVE_SENSORS32="n"
if test $SENSORS_SUPPORT = "y"; then
CFLAGS_SAVE=$CFLAGS
CFLAGS+=" -m32"
- LDFLAGS=" -lsensors"
+ LDFLAGS_SAVE=$LDFLAGS
+ LDFLAGS+=" -lsensors"
SENSORS=no
# Check for another function to avoid using cached result
AC_CHECK_LIB(sensors, sensors_cleanup, LFSENSORS32="-lsensors", HAVE_SENSORS32="n")
@@ -201,6 +202,7 @@ if test $SENSORS_SUPPORT = "y"; then
[[sensors_cleanup();]])], SENSORS=yes; HAVE_SENSORS32="y"; DFSENSORS32="-DHAVE_SENSORS32", HAVE_SENSORS32="n"; SENSORS=no)
AC_MSG_RESULT($SENSORS)
CFLAGS=$CFLAGS_SAVE
+ LDFLAGS=$LDFLAGS_SAVE
fi
AC_SUBST(HAVE_SENSORS32)
AC_SUBST(LFSENSORS32)
--
2.35.1
From 6ad29c2f4cfa7d5a3d3b02c4a4922fd8fa3bb103 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Luk=C3=A1=C5=A1=20Zaoral?= <lzaoral@redhat.com>
Date: Thu, 31 Mar 2022 14:36:59 +0200
Subject: [PATCH 3/3] configure: print LDFLAGS in final summary
---
configure | 1 +
configure.in | 1 +
2 files changed, 2 insertions(+)
diff --git a/configure b/configure
index e999217..5f9e57e 100755
--- a/configure
+++ b/configure
@@ -7052,4 +7052,5 @@ echo " Configuration file: ${SYSCONFIG_DIR}/${SYSCONFIG_FILE}
Man pages directory: $mandir
Compiler: $CC
Compiler flags: $CFLAGS
+ Linker flags: $LDFLAGS
"
diff --git a/configure.in b/configure.in
index 11cb3a3..2de5b38 100644
--- a/configure.in
+++ b/configure.in
@@ -803,4 +803,5 @@ echo " Configuration file: ${SYSCONFIG_DIR}/${SYSCONFIG_FILE}
Man pages directory: $mandir
Compiler: $CC
Compiler flags: $CFLAGS
+ Linker flags: $LDFLAGS
"
--
2.35.1

View File

@ -1 +1 @@
SHA512 (v12.5.6.tar.gz) = 6987cb1035a11d15771b2f6b96893176ff37ca642d8f30baf8125a2afe616530620843f7e6491b0194a1e423c7fb888009f3db110731174f428d7f7aac993820
SHA512 (v12.6.0.tar.gz) = f4d0e0dead0cce84782e985c8074871c45e77949c2bcfefd5642280e961f39e9eaa9f9fc93c013d79deba6e3703626894dd665ff64db72550d1c24f404780a5f

View File

@ -1,6 +1,6 @@
Summary: Collection of performance monitoring tools for Linux
Name: sysstat
Version: 12.5.6
Version: 12.6.0
Release: 1%{?dist}
License: GPLv2+
URL: http://sebastien.godard.pagesperso-orange.fr/
@ -10,9 +10,6 @@ Source: https://github.com/sysstat/sysstat/archive/v%{version}.tar.gz
Source1: colorsysstat.csh
Source2: colorsysstat.sh
# https://github.com/sysstat/sysstat/pull/317
Patch1: honor-ldflags.patch
BuildRequires: gcc
BuildRequires: gettext
BuildRequires: git
@ -95,6 +92,9 @@ fi
%{_localstatedir}/log/sa
%changelog
* Mon May 30 2022 Lukáš Zaoral <lzaoral@redhat.com> - 12.6.0-1
- Update to v12.6.0 (#2091359)
* Mon Apr 04 2022 Lukáš Zaoral <lzaoral@redhat.com> - 12.5.6-1
- Update to v12.5.6 (#2059133)
- Build position independent executables