1951f6acfa
Add debugging and accurate exception backtraces (RHBZ#2124571).
29 lines
892 B
Diff
29 lines
892 B
Diff
From 4363354763fe858973af287058d0fa2efe90cdd0 Mon Sep 17 00:00:00 2001
|
|
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
Date: Fri, 2 Sep 2022 12:01:50 +0100
|
|
Subject: [PATCH 06/12] ocaml: Use non-deprecated warning format
|
|
|
|
Alert ocaml_deprecated_cli: Setting a warning with a sequence of lowercase or uppercase letters,
|
|
like 'CDEFLMPSUVXYZ', is deprecated.
|
|
Use the equivalent signed form: +C+D+E+F+L+M+P+S+U+V+X+Y+Z-3.
|
|
---
|
|
src/Makefile.am | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/Makefile.am b/src/Makefile.am
|
|
index c54b63e..0fcc3ad 100644
|
|
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -127,7 +127,7 @@ BOBJECTS = $(SOURCES_ML:.ml=.cmo)
|
|
XOBJECTS = $(SOURCES_ML:.ml=.cmx)
|
|
|
|
OCAMLPACKAGES = -package unix,str
|
|
-OCAMLFLAGS = -warn-error CDEFLMPSUVXYZ-3
|
|
+OCAMLFLAGS = -warn-error +C+D+E+F+L+M+P+S+U+V+X+Y+Z-3
|
|
|
|
if !HAVE_OCAMLOPT
|
|
OBJECTS = $(BOBJECTS)
|
|
--
|
|
2.37.3
|
|
|