supermin/0011-src-Unconditionally-en...

29 lines
886 B
Diff

From 5d3d21b985b328317537e3d9a540840c5dade940 Mon Sep 17 00:00:00 2001
From: "Richard W.M. Jones" <rjones@redhat.com>
Date: Wed, 7 Sep 2022 16:12:12 +0100
Subject: [PATCH 11/12] src: Unconditionally enable -g flag
It's been possible to use -g with ocamlc for years now, and it's
always useful to compile with debugging enabled. In particular this
is necessary to display accurate backtraces.
---
src/Makefile.am | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/Makefile.am b/src/Makefile.am
index 0fcc3ad..5b07e5d 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -127,7 +127,7 @@ BOBJECTS = $(SOURCES_ML:.ml=.cmo)
XOBJECTS = $(SOURCES_ML:.ml=.cmx)
OCAMLPACKAGES = -package unix,str
-OCAMLFLAGS = -warn-error +C+D+E+F+L+M+P+S+U+V+X+Y+Z-3
+OCAMLFLAGS = -g -warn-error +C+D+E+F+L+M+P+S+U+V+X+Y+Z-3
if !HAVE_OCAMLOPT
OBJECTS = $(BOBJECTS)
--
2.37.3