New upstream version 4.1.6.
- Should fix all autotools brokenness. - Man pages are now all in section 1. - Remove patch which is now upstream.
This commit is contained in:
parent
180dde89a0
commit
9862bce897
@ -1,39 +0,0 @@
|
|||||||
From a55d9cf1579f14545636b3d7a2f515c413603107 Mon Sep 17 00:00:00 2001
|
|
||||||
From: "Richard W.M. Jones" <rjones@redhat.com>
|
|
||||||
Date: Sun, 8 Sep 2013 11:13:24 +0100
|
|
||||||
Subject: [PATCH] helper: Don't crash if SUPERMIN_DTB is set and no --dtb on
|
|
||||||
the command line.
|
|
||||||
|
|
||||||
Libguestfs uses supermin-helper -f checksum w/o --dtb. Setting the
|
|
||||||
SUPERMIN_DTB environment variable would cause supermin-helper to
|
|
||||||
crash. Instead of crashing, just ignore SUPERMIN_DTB.
|
|
||||||
---
|
|
||||||
helper/kernel.c | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/helper/kernel.c b/helper/kernel.c
|
|
||||||
index 4ff207b..5c8175d 100644
|
|
||||||
--- a/helper/kernel.c
|
|
||||||
+++ b/helper/kernel.c
|
|
||||||
@@ -122,15 +122,15 @@ has_modpath (const char *kernel_name)
|
|
||||||
static void
|
|
||||||
get_dtb (const char *kernel, const char *dtb_wildcard, const char *dtb)
|
|
||||||
{
|
|
||||||
+ if (!dtb_wildcard)
|
|
||||||
+ return;
|
|
||||||
+
|
|
||||||
char *dtb_env = getenv ("SUPERMIN_DTB");
|
|
||||||
if (dtb_env) {
|
|
||||||
copy_or_symlink_file ("dtb", dtb_env, dtb);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (!dtb_wildcard)
|
|
||||||
- return;
|
|
||||||
-
|
|
||||||
assert (dtb); /* command line arg parsing should ensure this */
|
|
||||||
assert (kernel != NULL);
|
|
||||||
|
|
||||||
--
|
|
||||||
1.8.3.1
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
2b24b7654e7942bed3bea3787bf76859 supermin-4.1.5.tar.gz
|
b8581450b92fd42d5fd26961bc21d2bc supermin-4.1.6.tar.gz
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Tool for creating supermin appliances
|
Summary: Tool for creating supermin appliances
|
||||||
Name: supermin
|
Name: supermin
|
||||||
Version: 4.1.5
|
Version: 4.1.6
|
||||||
Release: 5%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
|
|
||||||
%if 0%{?rhel} >= 7
|
%if 0%{?rhel} >= 7
|
||||||
@ -11,10 +11,6 @@ ExclusiveArch: x86_64
|
|||||||
URL: http://people.redhat.com/~rjones/supermin/
|
URL: http://people.redhat.com/~rjones/supermin/
|
||||||
Source0: http://libguestfs.org/download/supermin/%{name}-%{version}.tar.gz
|
Source0: http://libguestfs.org/download/supermin/%{name}-%{version}.tar.gz
|
||||||
|
|
||||||
# (For ARM) Don't crash if SUPERMIN_DTB is set and --dtb not specified.
|
|
||||||
# Upstream since 2013-09-08.
|
|
||||||
Patch1: 0001-helper-Don-t-crash-if-SUPERMIN_DTB-is-set-and-no-dtb.patch
|
|
||||||
|
|
||||||
BuildRequires: /usr/bin/pod2man
|
BuildRequires: /usr/bin/pod2man
|
||||||
BuildRequires: yum >= 3.2
|
BuildRequires: yum >= 3.2
|
||||||
BuildRequires: /usr/sbin/mke2fs
|
BuildRequires: /usr/sbin/mke2fs
|
||||||
@ -22,13 +18,6 @@ BuildRequires: e2fsprogs-devel
|
|||||||
BuildRequires: glibc-static, zlib-static
|
BuildRequires: glibc-static, zlib-static
|
||||||
BuildRequires: ocaml, ocaml-findlib-devel
|
BuildRequires: ocaml, ocaml-findlib-devel
|
||||||
|
|
||||||
# automake isn't actually required; however the src/.depend file gets
|
|
||||||
# rebuilt which newer automake thinks (wrongly) means that the
|
|
||||||
# Makefile.am has been touched and needs rebuilding. Unfortunately
|
|
||||||
# because of this brokenness we also have to rerun autoreconf. Grrr
|
|
||||||
# stupid autotools.
|
|
||||||
BuildRequires: automake, autoconf, libtool, gettext-devel
|
|
||||||
|
|
||||||
Requires: yum >= 3.2
|
Requires: yum >= 3.2
|
||||||
Requires: yum-utils
|
Requires: yum-utils
|
||||||
Requires: supermin-helper%{?_isa} = %{version}-%{release}
|
Requires: supermin-helper%{?_isa} = %{version}-%{release}
|
||||||
@ -66,10 +55,6 @@ Obsoletes: febootstrap-supermin-helper < 3.21-3
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
# See comment about automake above.
|
|
||||||
autoreconf -i
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --disable-network-tests
|
%configure --disable-network-tests
|
||||||
@ -94,16 +79,22 @@ make check
|
|||||||
%files
|
%files
|
||||||
%doc COPYING README examples/build-basic-vm.sh
|
%doc COPYING README examples/build-basic-vm.sh
|
||||||
%{_bindir}/supermin
|
%{_bindir}/supermin
|
||||||
%{_mandir}/man8/supermin.8*
|
%{_mandir}/man1/supermin.1*
|
||||||
|
|
||||||
|
|
||||||
%files helper
|
%files helper
|
||||||
%doc COPYING
|
%doc COPYING
|
||||||
%{_bindir}/supermin-helper
|
%{_bindir}/supermin-helper
|
||||||
%{_mandir}/man8/supermin-helper.8*
|
%{_mandir}/man1/supermin-helper.1*
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Dec 23 2013 Richard W.M. Jones <rjones@redhat.com> - 4.1.6-1
|
||||||
|
- New upstream version 4.1.6.
|
||||||
|
- Should fix all autotools brokenness.
|
||||||
|
- Man pages are now all in section 1.
|
||||||
|
- Remove patch which is now upstream.
|
||||||
|
|
||||||
* Mon Dec 23 2013 Richard W.M. Jones <rjones@redhat.com> - 4.1.5-5
|
* Mon Dec 23 2013 Richard W.M. Jones <rjones@redhat.com> - 4.1.5-5
|
||||||
- Rerun autoreconf to fix autotools brokenness.
|
- Rerun autoreconf to fix autotools brokenness.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user