- update to 1.5.6
- autoload psvn (#238491, Tom Tromey) - regenerate swig bindings (#480503) - fix build with libtool 2.2 (#469524)
This commit is contained in:
parent
fa6854e443
commit
cadf5d18bc
85
subversion-1.5.6-lt22.patch
Normal file
85
subversion-1.5.6-lt22.patch
Normal file
@ -0,0 +1,85 @@
|
|||||||
|
--- subversion-1.5.6/autogen.sh.lt22
|
||||||
|
+++ subversion-1.5.6/autogen.sh
|
||||||
|
@@ -48,53 +48,7 @@ if [ "x$libtoolize" = "x" ]; then
|
||||||
|
fi
|
||||||
|
|
||||||
|
rm -f build/config.guess build/config.sub
|
||||||
|
-$libtoolize --copy --automake --force
|
||||||
|
-
|
||||||
|
-ltpath="`dirname $libtoolize`"
|
||||||
|
-ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/libtool.m4}
|
||||||
|
-
|
||||||
|
-if [ ! -f $ltfile ]; then
|
||||||
|
- echo "$ltfile not found (try setting the LIBTOOL_M4 environment variable)"
|
||||||
|
- exit 1
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
-echo "Copying libtool helper: $ltfile"
|
||||||
|
-# An ancient helper might already be present from previous builds,
|
||||||
|
-# and it might be write-protected (e.g. mode 444, seen on FreeBSD).
|
||||||
|
-# This would cause cp to fail and print an error message, but leave
|
||||||
|
-# behind a potentially outdated libtool helper. So, remove before
|
||||||
|
-# copying:
|
||||||
|
-rm -f build/libtool.m4
|
||||||
|
-cp $ltfile build/libtool.m4
|
||||||
|
-
|
||||||
|
-for file in ltoptions.m4 ltsugar.m4 ltversion.m4 lt~obsolete.m4; do
|
||||||
|
- rm -f build/$file
|
||||||
|
-
|
||||||
|
- if [ $lt_major_version -ge 2 ]; then
|
||||||
|
- ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/$file}
|
||||||
|
-
|
||||||
|
- if [ ! -f $ltfile ]; then
|
||||||
|
- echo "$ltfile not found (try setting the LIBTOOL_M4 environment variable)"
|
||||||
|
- exit 1
|
||||||
|
- fi
|
||||||
|
-
|
||||||
|
- echo "Copying libtool helper: $ltfile"
|
||||||
|
- cp $ltfile build/$file
|
||||||
|
- fi
|
||||||
|
-done
|
||||||
|
-
|
||||||
|
-if [ $lt_major_version -ge 2 ]; then
|
||||||
|
- for file in config.guess config.sub; do
|
||||||
|
- configfile=${LIBTOOL_CONFIG-`cd $ltpath/../share/libtool/config ; pwd`/$file}
|
||||||
|
-
|
||||||
|
- if [ ! -f $configfile ]; then
|
||||||
|
- echo "$configfile not found (try setting the LIBTOOL_CONFIG environment variable)"
|
||||||
|
- exit 1
|
||||||
|
- fi
|
||||||
|
-
|
||||||
|
- cp $configfile build/$file
|
||||||
|
- done
|
||||||
|
-fi
|
||||||
|
+$libtoolize --copy --automake --force --install
|
||||||
|
|
||||||
|
# Create the file detailing all of the build outputs for SVN.
|
||||||
|
#
|
||||||
|
--- subversion-1.5.6/configure.ac.lt22
|
||||||
|
+++ subversion-1.5.6/configure.ac
|
||||||
|
@@ -11,6 +11,7 @@ AC_INIT([subversion],
|
||||||
|
|
||||||
|
AC_CONFIG_SRCDIR(subversion/include/svn_types.h)
|
||||||
|
AC_CONFIG_AUX_DIR([build])
|
||||||
|
+AC_CONFIG_MACRO_DIR([build])
|
||||||
|
|
||||||
|
AC_MSG_NOTICE([Configuring Subversion ]AC_PACKAGE_VERSION)
|
||||||
|
|
||||||
|
@@ -27,6 +28,7 @@ SVN_CONFIG_NICE(config.nice)
|
||||||
|
|
||||||
|
# Look for a C compiler (before anything can set CFLAGS)
|
||||||
|
AC_PROG_CC
|
||||||
|
+AC_PROG_CXX
|
||||||
|
|
||||||
|
# Look for a C pre-processor
|
||||||
|
AC_PROG_CPP
|
||||||
|
@@ -687,8 +689,7 @@ if test "$do_javahl_build" = "yes"; then
|
||||||
|
Please specify a suitable JDK using the --with-jdk option.])
|
||||||
|
fi
|
||||||
|
|
||||||
|
- AC_PROG_CXX
|
||||||
|
-
|
||||||
|
+
|
||||||
|
dnl The temporary directory where libtool compiles libsvnjavahl.
|
||||||
|
dnl N.B. objdir is "the name of the directory that contains temporary
|
||||||
|
dnl libtool files" and it is set by libtool.m4
|
@ -24,6 +24,7 @@ Source1: subversion.conf
|
|||||||
Source3: filter-requires.sh
|
Source3: filter-requires.sh
|
||||||
Source4: http://www.xsteve.at/prg/emacs/psvn.el
|
Source4: http://www.xsteve.at/prg/emacs/psvn.el
|
||||||
Source5: psvn-init.el
|
Source5: psvn-init.el
|
||||||
|
Patch1: subversion-1.5.6-lt22.patch
|
||||||
Patch2: subversion-0.20.1-deplibs.patch
|
Patch2: subversion-0.20.1-deplibs.patch
|
||||||
Patch3: subversion-1.5.1-rpath.patch
|
Patch3: subversion-1.5.1-rpath.patch
|
||||||
Patch6: subversion-1.5.2-pie.patch
|
Patch6: subversion-1.5.2-pie.patch
|
||||||
@ -104,6 +105,7 @@ This package includes the Ruby bindings to the Subversion libraries.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
%patch1 -p1 -b .lt22
|
||||||
%patch2 -p1 -b .deplibs
|
%patch2 -p1 -b .deplibs
|
||||||
%patch3 -p1 -b .rpath
|
%patch3 -p1 -b .rpath
|
||||||
%patch6 -p1 -b .pie
|
%patch6 -p1 -b .pie
|
||||||
@ -130,7 +132,8 @@ export CC=gcc CXX=g++ JAVA_HOME=%{jdk_path}
|
|||||||
--with-swig --with-neon=%{_prefix} \
|
--with-swig --with-neon=%{_prefix} \
|
||||||
--with-ruby-sitedir=%{ruby_sitearch} \
|
--with-ruby-sitedir=%{ruby_sitearch} \
|
||||||
--with-apxs=%{_sbindir}/apxs --disable-mod-activation \
|
--with-apxs=%{_sbindir}/apxs --disable-mod-activation \
|
||||||
--disable-static --with-sasl=%{_prefix}
|
--disable-static --with-sasl=%{_prefix} \
|
||||||
|
--disable-neon-version-check
|
||||||
make %{?_smp_mflags} all
|
make %{?_smp_mflags} all
|
||||||
make swig-py swig-py-lib %{swigdirs}
|
make swig-py swig-py-lib %{swigdirs}
|
||||||
make swig-pl swig-pl-lib swig-rb swig-rb-lib
|
make swig-pl swig-pl-lib swig-rb swig-rb-lib
|
||||||
@ -285,6 +288,7 @@ rm -rf ${RPM_BUILD_ROOT}
|
|||||||
- update to 1.5.6
|
- update to 1.5.6
|
||||||
- autoload psvn (#238491, Tom Tromey)
|
- autoload psvn (#238491, Tom Tromey)
|
||||||
- regenerate swig bindings (#480503)
|
- regenerate swig bindings (#480503)
|
||||||
|
- fix build with libtool 2.2 (#469524)
|
||||||
|
|
||||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.5-6
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.5-6
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
Loading…
Reference in New Issue
Block a user