cadf5d18bc
- autoload psvn (#238491, Tom Tromey) - regenerate swig bindings (#480503) - fix build with libtool 2.2 (#469524)
86 lines
2.6 KiB
Diff
86 lines
2.6 KiB
Diff
--- subversion-1.5.6/autogen.sh.lt22
|
|
+++ subversion-1.5.6/autogen.sh
|
|
@@ -48,53 +48,7 @@ if [ "x$libtoolize" = "x" ]; then
|
|
fi
|
|
|
|
rm -f build/config.guess build/config.sub
|
|
-$libtoolize --copy --automake --force
|
|
-
|
|
-ltpath="`dirname $libtoolize`"
|
|
-ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/libtool.m4}
|
|
-
|
|
-if [ ! -f $ltfile ]; then
|
|
- echo "$ltfile not found (try setting the LIBTOOL_M4 environment variable)"
|
|
- exit 1
|
|
-fi
|
|
-
|
|
-echo "Copying libtool helper: $ltfile"
|
|
-# An ancient helper might already be present from previous builds,
|
|
-# and it might be write-protected (e.g. mode 444, seen on FreeBSD).
|
|
-# This would cause cp to fail and print an error message, but leave
|
|
-# behind a potentially outdated libtool helper. So, remove before
|
|
-# copying:
|
|
-rm -f build/libtool.m4
|
|
-cp $ltfile build/libtool.m4
|
|
-
|
|
-for file in ltoptions.m4 ltsugar.m4 ltversion.m4 lt~obsolete.m4; do
|
|
- rm -f build/$file
|
|
-
|
|
- if [ $lt_major_version -ge 2 ]; then
|
|
- ltfile=${LIBTOOL_M4-`cd $ltpath/../share/aclocal ; pwd`/$file}
|
|
-
|
|
- if [ ! -f $ltfile ]; then
|
|
- echo "$ltfile not found (try setting the LIBTOOL_M4 environment variable)"
|
|
- exit 1
|
|
- fi
|
|
-
|
|
- echo "Copying libtool helper: $ltfile"
|
|
- cp $ltfile build/$file
|
|
- fi
|
|
-done
|
|
-
|
|
-if [ $lt_major_version -ge 2 ]; then
|
|
- for file in config.guess config.sub; do
|
|
- configfile=${LIBTOOL_CONFIG-`cd $ltpath/../share/libtool/config ; pwd`/$file}
|
|
-
|
|
- if [ ! -f $configfile ]; then
|
|
- echo "$configfile not found (try setting the LIBTOOL_CONFIG environment variable)"
|
|
- exit 1
|
|
- fi
|
|
-
|
|
- cp $configfile build/$file
|
|
- done
|
|
-fi
|
|
+$libtoolize --copy --automake --force --install
|
|
|
|
# Create the file detailing all of the build outputs for SVN.
|
|
#
|
|
--- subversion-1.5.6/configure.ac.lt22
|
|
+++ subversion-1.5.6/configure.ac
|
|
@@ -11,6 +11,7 @@ AC_INIT([subversion],
|
|
|
|
AC_CONFIG_SRCDIR(subversion/include/svn_types.h)
|
|
AC_CONFIG_AUX_DIR([build])
|
|
+AC_CONFIG_MACRO_DIR([build])
|
|
|
|
AC_MSG_NOTICE([Configuring Subversion ]AC_PACKAGE_VERSION)
|
|
|
|
@@ -27,6 +28,7 @@ SVN_CONFIG_NICE(config.nice)
|
|
|
|
# Look for a C compiler (before anything can set CFLAGS)
|
|
AC_PROG_CC
|
|
+AC_PROG_CXX
|
|
|
|
# Look for a C pre-processor
|
|
AC_PROG_CPP
|
|
@@ -687,8 +689,7 @@ if test "$do_javahl_build" = "yes"; then
|
|
Please specify a suitable JDK using the --with-jdk option.])
|
|
fi
|
|
|
|
- AC_PROG_CXX
|
|
-
|
|
+
|
|
dnl The temporary directory where libtool compiles libsvnjavahl.
|
|
dnl N.B. objdir is "the name of the directory that contains temporary
|
|
dnl libtool files" and it is set by libtool.m4
|