4.9-1
- New upstream release: + fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384); + updated CLOCK_* constants (#1088455); + enabled ppc64le support (#1122323); + fixed attach to a process on ppc64le (#1129569).
This commit is contained in:
parent
fe0f47b260
commit
94f9c7485e
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/strace-4.8.tar.xz
|
||||
/strace-4.9.tar.xz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
c575ef43829586801f514fd91bfe7575 strace-4.8.tar.xz
|
||||
885eafadb10f6c60464a266d3929a2a4 strace-4.9.tar.xz
|
||||
|
@ -1,66 +0,0 @@
|
||||
commit 9afc2ee682d2f9fd3ad938756c841d7f0eed5f21
|
||||
Author: Anton Blanchard <anton@samba.org>
|
||||
Date: Thu Jul 11 12:03:57 2013 +1000
|
||||
|
||||
powerpc: enhance 32/64bit detection
|
||||
|
||||
We were using uname to determine if userspace was 32 or 64bit.
|
||||
This fails when we have a 64bit kernel and a 32bit userspace.
|
||||
|
||||
* configure.ac (powerpc*): Similar to x86, use a runtime test
|
||||
to determine if we are 32 or 64bit.
|
||||
|
||||
Signed-off-by: Anton Blanchard <anton@samba.org>
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 03e49fe..b3b62e8 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -54,7 +54,11 @@ alpha*)
|
||||
powerpc*)
|
||||
arch=powerpc
|
||||
AC_DEFINE([POWERPC], 1, [Define for the PowerPC architecture.])
|
||||
- if test $host_cpu = powerpc64; then
|
||||
+ AC_TRY_COMPILE(
|
||||
+[#ifndef __LP64__
|
||||
+# error 32 bit
|
||||
+#endif], [], ppc_bits=64, ppc_bits=32)
|
||||
+ if test "$ppc_bits" = "64"; then
|
||||
AC_DEFINE([POWERPC64], 1, [Define for the PowerPC64 architecture.])
|
||||
fi
|
||||
;;
|
||||
diff -up strace-4.8/configure.ppc64 strace-4.8/configure
|
||||
--- strace-4.8/configure.ppc64 2013-06-05 02:02:43.000000000 +0200
|
||||
+++ strace-4.8/configure 2014-07-25 16:16:01.000000000 +0200
|
||||
@@ -4660,10 +4660,29 @@ powerpc*)
|
||||
|
||||
$as_echo "#define POWERPC 1" >>confdefs.h
|
||||
|
||||
- if test $host_cpu = powerpc64; then
|
||||
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
|
||||
+/* end confdefs.h. */
|
||||
+#ifndef __LP64__
|
||||
+# error 32 bit
|
||||
+#endif
|
||||
+int
|
||||
+main ()
|
||||
+{
|
||||
|
||||
-$as_echo "#define POWERPC64 1" >>confdefs.h
|
||||
+ ;
|
||||
+ return 0;
|
||||
+}
|
||||
+_ACEOF
|
||||
+if ac_fn_c_try_compile "$LINENO"; then :
|
||||
+ ppc_bits=64
|
||||
+else
|
||||
+ ppc_bits=32
|
||||
+fi
|
||||
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
+ if test "$ppc_bits" = "64"; then
|
||||
|
||||
+$as_echo "#define POWERPC64 1" >>confdefs.h
|
||||
+
|
||||
fi
|
||||
;;
|
||||
arm*)
|
@ -1,44 +0,0 @@
|
||||
--- strace-4.8/process.c.orig 2013-12-06 16:18:27.682402291 +0000
|
||||
+++ strace-4.8/process.c 2013-12-06 16:19:14.602165296 +0000
|
||||
@@ -63,7 +63,7 @@
|
||||
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||
# endif
|
||||
-# include <linux/ptrace.h>
|
||||
+# include <asm/ptrace.h>
|
||||
# undef ia64_fpreg
|
||||
# undef pt_all_user_regs
|
||||
#endif
|
||||
--- strace-4.8/signal.c.orig 2013-12-06 16:28:54.800551324 +0000
|
||||
+++ strace-4.8/signal.c 2013-12-06 16:30:26.033019415 +0000
|
||||
@@ -51,7 +51,7 @@
|
||||
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||
# endif
|
||||
-# include <linux/ptrace.h>
|
||||
+# include <asm/ptrace.h>
|
||||
# undef ia64_fpreg
|
||||
# undef pt_all_user_regs
|
||||
#endif
|
||||
--- strace-4.8/syscall.c.orig 2013-12-06 16:29:37.912245321 +0000
|
||||
+++ strace-4.8/syscall.c 2013-12-06 16:30:55.933500132 +0000
|
||||
@@ -48,7 +48,7 @@
|
||||
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||
# endif
|
||||
-# include <linux/ptrace.h>
|
||||
+# include <asm/ptrace.h>
|
||||
# undef ia64_fpreg
|
||||
# undef pt_all_user_regs
|
||||
#endif
|
||||
--- strace-4.8/util.c.orig 2013-12-06 16:29:44.382349431 +0000
|
||||
+++ strace-4.8/util.c 2013-12-06 16:31:04.267634082 +0000
|
||||
@@ -55,7 +55,7 @@
|
||||
# ifdef HAVE_STRUCT_PT_ALL_USER_REGS
|
||||
# define pt_all_user_regs XXX_pt_all_user_regs
|
||||
# endif
|
||||
-# include <linux/ptrace.h>
|
||||
+# include <asm/ptrace.h>
|
||||
# undef ia64_fpreg
|
||||
# undef pt_all_user_regs
|
||||
#endif
|
24
strace.spec
24
strace.spec
@ -1,16 +1,11 @@
|
||||
Summary: Tracks and displays system calls associated with a running process
|
||||
Name: strace
|
||||
Version: 4.8
|
||||
Release: 5%{?dist}
|
||||
Version: 4.9
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Development/Debuggers
|
||||
|
||||
URL: http://sourceforge.net/projects/strace/
|
||||
Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
|
||||
Patch0: strace-fix-ftbfs.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1122323
|
||||
# http://sourceforge.net/p/strace/code/ci/9afc2ee682d2f9fd3ad938756c841d7f0eed5f21/
|
||||
Patch1: strace-4.8-ppc64.patch
|
||||
|
||||
BuildRequires: libacl-devel, libaio-devel, time
|
||||
|
||||
@ -47,8 +42,6 @@ The `strace' program in the `strace' package is for 32-bit processes.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .ftbfs
|
||||
%patch1 -p1 -b .ppc64
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -72,7 +65,7 @@ rm -f %{buildroot}%{_bindir}/strace-graph
|
||||
%endif
|
||||
|
||||
%check
|
||||
make check
|
||||
make -k check VERBOSE=1
|
||||
|
||||
%files
|
||||
%doc CREDITS ChangeLog ChangeLog-CVS COPYING NEWS README
|
||||
@ -86,6 +79,13 @@ make check
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Fri Aug 15 2014 Dmitry V. Levin <ldv@altlinux.org> - 4.9-1
|
||||
- New upstream release:
|
||||
+ fixed build when <sys/ptrace.h> and <linux/ptrace.h> conflict (#993384);
|
||||
+ updated CLOCK_* constants (#1088455);
|
||||
+ enabled ppc64le support (#1122323);
|
||||
+ fixed attach to a process on ppc64le (#1129569).
|
||||
|
||||
* Fri Jul 25 2014 Dan Horák <dan[at]danny.cz> - 4.8-5
|
||||
- update for ppc64
|
||||
|
||||
@ -312,7 +312,7 @@ make check
|
||||
* Thu Jul 17 2003 Roland McGrath <roland@redhat.com> 4.4.99-1
|
||||
- new upstream version, groks more new system calls, PF_INET6 sockets
|
||||
|
||||
* Mon Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
|
||||
* Tue Jun 10 2003 Roland McGrath <roland@redhat.com> 4.4.98-1
|
||||
- new upstream version, more fixes (#90754, #91085)
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
@ -405,7 +405,7 @@ make check
|
||||
* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
|
||||
- update to CVS, reintegrate ia64 support
|
||||
|
||||
* Sat Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
|
||||
* Fri Dec 8 2000 Bernhard Rosenkraenzer <bero@redhat.com>
|
||||
- Get S/390 support into the normal package
|
||||
|
||||
* Sat Nov 18 2000 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
|
Loading…
Reference in New Issue
Block a user