- update for ppc64

This commit is contained in:
Dan Horák 2014-07-25 16:21:38 +02:00
parent 76c83f2ba1
commit fe0f47b260
2 changed files with 74 additions and 1 deletions

66
strace-4.8-ppc64.patch Normal file
View File

@ -0,0 +1,66 @@
commit 9afc2ee682d2f9fd3ad938756c841d7f0eed5f21
Author: Anton Blanchard <anton@samba.org>
Date: Thu Jul 11 12:03:57 2013 +1000
powerpc: enhance 32/64bit detection
We were using uname to determine if userspace was 32 or 64bit.
This fails when we have a 64bit kernel and a 32bit userspace.
* configure.ac (powerpc*): Similar to x86, use a runtime test
to determine if we are 32 or 64bit.
Signed-off-by: Anton Blanchard <anton@samba.org>
diff --git a/configure.ac b/configure.ac
index 03e49fe..b3b62e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -54,7 +54,11 @@ alpha*)
powerpc*)
arch=powerpc
AC_DEFINE([POWERPC], 1, [Define for the PowerPC architecture.])
- if test $host_cpu = powerpc64; then
+ AC_TRY_COMPILE(
+[#ifndef __LP64__
+# error 32 bit
+#endif], [], ppc_bits=64, ppc_bits=32)
+ if test "$ppc_bits" = "64"; then
AC_DEFINE([POWERPC64], 1, [Define for the PowerPC64 architecture.])
fi
;;
diff -up strace-4.8/configure.ppc64 strace-4.8/configure
--- strace-4.8/configure.ppc64 2013-06-05 02:02:43.000000000 +0200
+++ strace-4.8/configure 2014-07-25 16:16:01.000000000 +0200
@@ -4660,10 +4660,29 @@ powerpc*)
$as_echo "#define POWERPC 1" >>confdefs.h
- if test $host_cpu = powerpc64; then
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+/* end confdefs.h. */
+#ifndef __LP64__
+# error 32 bit
+#endif
+int
+main ()
+{
-$as_echo "#define POWERPC64 1" >>confdefs.h
+ ;
+ return 0;
+}
+_ACEOF
+if ac_fn_c_try_compile "$LINENO"; then :
+ ppc_bits=64
+else
+ ppc_bits=32
+fi
+rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
+ if test "$ppc_bits" = "64"; then
+$as_echo "#define POWERPC64 1" >>confdefs.h
+
fi
;;
arm*)

View File

@ -1,13 +1,16 @@
Summary: Tracks and displays system calls associated with a running process
Name: strace
Version: 4.8
Release: 4%{?dist}
Release: 5%{?dist}
License: BSD
Group: Development/Debuggers
URL: http://sourceforge.net/projects/strace/
Source: http://downloads.sourceforge.net/strace/%{name}-%{version}.tar.xz
Patch0: strace-fix-ftbfs.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=1122323
# http://sourceforge.net/p/strace/code/ci/9afc2ee682d2f9fd3ad938756c841d7f0eed5f21/
Patch1: strace-4.8-ppc64.patch
BuildRequires: libacl-devel, libaio-devel, time
@ -45,6 +48,7 @@ The `strace' program in the `strace' package is for 32-bit processes.
%prep
%setup -q
%patch0 -p1 -b .ftbfs
%patch1 -p1 -b .ppc64
%build
%configure
@ -82,6 +86,9 @@ make check
%endif
%changelog
* Fri Jul 25 2014 Dan Horák <dan[at]danny.cz> - 4.8-5
- update for ppc64
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.8-4
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild