parent
ab1654d09a
commit
e63577b075
26
star-1.5.3-pax-X-option.patch
Normal file
26
star-1.5.3-pax-X-option.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From 68f6e16d7d2c8a6c91cd430b12a1a0c7b15672b4 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Pavel Raiskup <praiskup@redhat.com>
|
||||||
|
Date: Wed, 17 Dec 2014 12:57:37 +0100
|
||||||
|
Subject: [PATCH] pax: don't segfault with -X option
|
||||||
|
|
||||||
|
Pass a valid address of nomount variable into getallargs().
|
||||||
|
---
|
||||||
|
star/pax.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/star/pax.c b/star/pax.c
|
||||||
|
index 9abe3f8..c627a46 100644
|
||||||
|
--- a/star/pax.c
|
||||||
|
+++ b/star/pax.c
|
||||||
|
@@ -166,7 +166,7 @@ gargs(ac, av)
|
||||||
|
gethdr, &chdrtype, /* -x */
|
||||||
|
gethdr, &chdrtype, /* artype= */
|
||||||
|
#endif /* __old__lint */
|
||||||
|
- nomount) < 0) {
|
||||||
|
+ &nomount) < 0) {
|
||||||
|
errmsgno(EX_BAD, "Bad Option: %s.\n", av[0]);
|
||||||
|
susage(EX_BAD);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
10
star.spec
10
star.spec
@ -7,7 +7,7 @@
|
|||||||
Summary: An archiving tool with ACL support
|
Summary: An archiving tool with ACL support
|
||||||
Name: star
|
Name: star
|
||||||
Version: 1.5.3
|
Version: 1.5.3
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: CDDL
|
License: CDDL
|
||||||
Group: Applications/Archiving
|
Group: Applications/Archiving
|
||||||
URL: http://freecode.com/projects/star
|
URL: http://freecode.com/projects/star
|
||||||
@ -44,6 +44,10 @@ Patch9: star-1.5.2-use-ssh-by-default.patch
|
|||||||
# Fix broken star.mk in 1.5.3 (included from all.mk)
|
# Fix broken star.mk in 1.5.3 (included from all.mk)
|
||||||
Patch10: star-1.5.3-star-mk.patch
|
Patch10: star-1.5.3-star-mk.patch
|
||||||
|
|
||||||
|
# Fix segfault for 'pax -X' (rhbz#1175009)
|
||||||
|
# ~> downstream
|
||||||
|
Patch11: star-1.5.3-pax-X-option.patch
|
||||||
|
|
||||||
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel
|
BuildRequires: libattr-devel libacl-devel libtool libselinux-devel
|
||||||
BuildRequires: e2fsprogs-devel
|
BuildRequires: e2fsprogs-devel
|
||||||
|
|
||||||
@ -105,6 +109,7 @@ restoring files from a backup), and tar (an archiving program).
|
|||||||
%patch8 -p1 -b .rmt-access-rules
|
%patch8 -p1 -b .rmt-access-rules
|
||||||
%patch9 -p1 -b .ssh-by-default
|
%patch9 -p1 -b .ssh-by-default
|
||||||
%patch10 -p1 -b .bug-config-1.5.3
|
%patch10 -p1 -b .bug-config-1.5.3
|
||||||
|
%patch11 -p1 -b .pax-X
|
||||||
|
|
||||||
# disable single "fat" binary
|
# disable single "fat" binary
|
||||||
cp -a star/all.mk star/Makefile
|
cp -a star/all.mk star/Makefile
|
||||||
@ -227,6 +232,9 @@ fi
|
|||||||
%{_sysconfdir}/rmt
|
%{_sysconfdir}/rmt
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Dec 17 2014 Pavel Raiskup <praiskup@redhat.com> - 1.5.3-4
|
||||||
|
- fix segfault for pax -X (#1175009)
|
||||||
|
|
||||||
* Tue Sep 16 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.3-3
|
* Tue Sep 16 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.3-3
|
||||||
- Re-enable profiling on aarch64
|
- Re-enable profiling on aarch64
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user