Re-enable profiling on aarch64
This commit is contained in:
parent
193f4d1f9e
commit
ab1654d09a
@ -1,53 +0,0 @@
|
||||
diff --git a/lib/libschily_p.mk b/lib/libschily_p.mk
|
||||
index 8d9cec6..9bfc9b2 100644
|
||||
--- a/lib/libschily_p.mk
|
||||
+++ b/lib/libschily_p.mk
|
||||
@@ -14,7 +14,7 @@ TARGETLIB= schily
|
||||
CPPOPTS += -Istdio
|
||||
CPPOPTS += -DUSE_SCANSTACK # Try to scan stack frames
|
||||
CPPOPTS += -DPORT_ONLY # Add missing funcs line snprintf for porting
|
||||
-COPTS += $(COPTGPROF)
|
||||
+# COPTS += $(COPTGPROF)
|
||||
include Targets
|
||||
LIBS=
|
||||
|
||||
diff --git a/libdeflt/libdeflt_p.mk b/libdeflt/libdeflt_p.mk
|
||||
index 477deb2..8542bbc 100644
|
||||
--- a/libdeflt/libdeflt_p.mk
|
||||
+++ b/libdeflt/libdeflt_p.mk
|
||||
@@ -12,7 +12,7 @@ SUBINSDIR= /profiled
|
||||
INSDIR= lib
|
||||
TARGETLIB= deflt
|
||||
#CPPOPTS += -Ispecincl
|
||||
-COPTS += $(COPTGPROF)
|
||||
+# COPTS += $(COPTGPROF)
|
||||
include Targets
|
||||
LIBS=
|
||||
|
||||
diff --git a/libfind/libfind_p.mk b/libfind/libfind_p.mk
|
||||
index f4b2a56..f61e507 100644
|
||||
--- a/libfind/libfind_p.mk
|
||||
+++ b/libfind/libfind_p.mk
|
||||
@@ -11,7 +11,7 @@ SUBINSDIR= /profiled
|
||||
#VPATH= .:stdio:$(ARCHDIR)
|
||||
INSDIR= lib
|
||||
TARGETLIB= find
|
||||
-COPTS += $(COPTGPROF)
|
||||
+#COPTS += $(COPTGPROF)
|
||||
#CPPOPTS += -Istdio
|
||||
#CPPOPTS += -DUSE_SCANSTACK
|
||||
|
||||
diff --git a/librmt/librmt_p.mk b/librmt/librmt_p.mk
|
||||
index f16fd84..565b28a 100644
|
||||
--- a/librmt/librmt_p.mk
|
||||
+++ b/librmt/librmt_p.mk
|
||||
@@ -14,7 +14,7 @@ TARGETLIB= rmt
|
||||
CPPOPTS += -DUSE_REMOTE
|
||||
CPPOPTS += -DUSE_RCMD_RSH
|
||||
CPPOPTS += -DUSE_LARGEFILES
|
||||
-COPTS += $(COPTGPROF)
|
||||
+#COPTS += $(COPTGPROF)
|
||||
include Targets
|
||||
LIBS=
|
||||
|
||||
|
@ -7,7 +7,7 @@
|
||||
Summary: An archiving tool with ACL support
|
||||
Name: star
|
||||
Version: 1.5.3
|
||||
Release: 2%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: CDDL
|
||||
Group: Applications/Archiving
|
||||
URL: http://freecode.com/projects/star
|
||||
@ -31,9 +31,6 @@ Patch5: star-1.5.1-selinux-segfault.patch
|
||||
# note that the H=crc format uses Sum32 algorithm, not CRC
|
||||
Patch6: star-1.5.1-crc.patch
|
||||
|
||||
# Disable profiling on aarch64 as it's not currently supported upstream
|
||||
Patch7: star-aarch64.patch
|
||||
|
||||
# Allow rmt to access all files.
|
||||
# ~> downstream
|
||||
# ~> #968980
|
||||
@ -105,7 +102,6 @@ restoring files from a backup), and tar (an archiving program).
|
||||
%patch4 -p1 -b .references
|
||||
%patch5 -p1 -b .selinux-segfault
|
||||
%patch6 -p1 -b .crc
|
||||
%patch7 -p1 -b .aarch64
|
||||
%patch8 -p1 -b .rmt-access-rules
|
||||
%patch9 -p1 -b .ssh-by-default
|
||||
%patch10 -p1 -b .bug-config-1.5.3
|
||||
@ -231,6 +227,9 @@ fi
|
||||
%{_sysconfdir}/rmt
|
||||
|
||||
%changelog
|
||||
* Tue Sep 16 2014 Peter Robinson <pbrobinson@fedoraproject.org> 1.5.3-3
|
||||
- Re-enable profiling on aarch64
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user