- fix configure detection of netfilter kernel headers (#435499), patch by
aoliva@redhat.com - add support for negotiate authentication (#445337)
This commit is contained in:
parent
f01866226e
commit
e844aa549d
56
squid-3.0.STABLE5-configure_netfilter.patch
Normal file
56
squid-3.0.STABLE5-configure_netfilter.patch
Normal file
@ -0,0 +1,56 @@
|
||||
diff -up squid-3.0.STABLE5/configure.config_netfilter squid-3.0.STABLE5/configure
|
||||
--- squid-3.0.STABLE5/configure.config_netfilter 2008-03-04 09:35:36.000000000 -0300
|
||||
+++ squid-3.0.STABLE5/configure 2008-05-05 06:50:56.000000000 -0300
|
||||
@@ -24512,6 +24512,10 @@ cat >>conftest.$ac_ext <<_ACEOF
|
||||
#if HAVE_LIMITS_H
|
||||
#include <limits.h>
|
||||
#endif
|
||||
+#if HAVE_NETINET_IN_H
|
||||
+# include <netinet/in.h>
|
||||
+#endif
|
||||
+#include <linux/types.h>
|
||||
|
||||
|
||||
#include <$ac_header>
|
||||
diff -up squid-3.0.STABLE5/configure.in.config_netfilter squid-3.0.STABLE5/configure.in
|
||||
--- squid-3.0.STABLE5/configure.in.config_netfilter 2008-03-04 09:35:36.000000000 -0300
|
||||
+++ squid-3.0.STABLE5/configure.in 2008-05-05 06:50:56.000000000 -0300
|
||||
@@ -1931,6 +1931,10 @@ SQUID_DEFAULT_INCLUDES
|
||||
#if HAVE_LIMITS_H
|
||||
#include <limits.h>
|
||||
#endif
|
||||
+#if HAVE_NETINET_IN_H
|
||||
+# include <netinet/in.h>
|
||||
+#endif
|
||||
+#include <linux/types.h>
|
||||
)
|
||||
|
||||
AC_CHECK_HEADERS(net/if.h \
|
||||
diff -up squid-3.0.STABLE5/src/forward.cc.config_netfilter squid-3.0.STABLE5/src/forward.cc
|
||||
--- squid-3.0.STABLE5/src/forward.cc.config_netfilter 2008-02-27 07:42:23.000000000 -0300
|
||||
+++ squid-3.0.STABLE5/src/forward.cc 2008-05-05 06:54:02.000000000 -0300
|
||||
@@ -50,6 +50,10 @@
|
||||
#include "Store.h"
|
||||
|
||||
#if LINUX_TPROXY
|
||||
+#if HAVE_NETINET_IN_H
|
||||
+# include <netinet/in.h>
|
||||
+#endif
|
||||
+#include <linux/types.h>
|
||||
#include <linux/netfilter_ipv4/ip_tproxy.h>
|
||||
#endif
|
||||
|
||||
diff -up squid-3.0.STABLE5/src/IPInterception.cc.config_netfilter squid-3.0.STABLE5/src/IPInterception.cc
|
||||
--- squid-3.0.STABLE5/src/IPInterception.cc.config_netfilter 2007-11-07 08:20:47.000000000 -0200
|
||||
+++ squid-3.0.STABLE5/src/IPInterception.cc 2008-05-05 06:53:56.000000000 -0300
|
||||
@@ -85,6 +85,10 @@
|
||||
#endif
|
||||
|
||||
#if LINUX_NETFILTER
|
||||
+#if HAVE_NETINET_IN_H
|
||||
+# include <netinet/in.h>
|
||||
+#endif
|
||||
+#include <linux/types.h>
|
||||
#include <linux/netfilter_ipv4.h>
|
||||
#endif
|
||||
|
14
squid.spec
14
squid.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: squid
|
||||
Version: 3.0.STABLE5
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: The Squid proxy caching server
|
||||
Epoch: 7
|
||||
License: GPLv2+
|
||||
@ -32,6 +32,7 @@ Patch203: squid-3.0.STABLE1-build.patch
|
||||
Patch204: squid-3.0.STABLE1-perlpath.patch
|
||||
Patch205: squid-3.0.STABLE1-smb-path.patch
|
||||
Patch206: squid-3.0.STABLE2-fix_warnings.patch
|
||||
Patch207: squid-3.0.STABLE5-configure_netfilter.patch
|
||||
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Requires: bash >= 2.0
|
||||
@ -63,6 +64,7 @@ lookup program (dnsserver), a program for retrieving FTP data
|
||||
%patch204 -p1 -b .perlpath
|
||||
%patch205 -p1 -b .smb-path
|
||||
%patch206 -p1 -b .fix_warnings
|
||||
%patch207 -p1 -b .configure_netfilter
|
||||
|
||||
%build
|
||||
export CXXFLAGS="-fPIE %{optflags}" ; export CFLAGS="-fPIE -Os -g -pipe -fsigned-char %{optflags}" ; export LDFLAGS="-pie" ;
|
||||
@ -75,8 +77,9 @@ export CXXFLAGS="-fPIE %{optflags}" ; export CFLAGS="-fPIE -Os -g -pipe -fsigned
|
||||
--sysconfdir=/etc/squid \
|
||||
--disable-dependency-tracking \
|
||||
--enable-arp-acl \
|
||||
--enable-auth="basic,digest,ntlm" \
|
||||
--enable-auth="basic,digest,ntlm,negotiate" \
|
||||
--enable-basic-auth-helpers="LDAP,MSNT,NCSA,PAM,SMB,YP,getpwnam,multi-domain-NTLM,SASL" \
|
||||
--enable-negotiate-auth-helpers="squid_kerb_auth" \
|
||||
--enable-cache-digests \
|
||||
--enable-cachemgr-hostname=localhost \
|
||||
--enable-delay-pools \
|
||||
@ -333,7 +336,12 @@ fi
|
||||
chgrp squid /var/cache/samba/winbindd_privileged >/dev/null 2>&1 || :
|
||||
|
||||
%changelog
|
||||
* Fri May 12 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE5-1
|
||||
* Fri May 09 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE5-2
|
||||
- fix configure detection of netfilter kernel headers (#435499),
|
||||
patch by aoliva@redhat.com
|
||||
- add support for negotiate authentication (#445337)
|
||||
|
||||
* Fri May 02 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE5-1
|
||||
- upgrade to latest upstream
|
||||
|
||||
* Tue Apr 08 2008 Martin Nagy <mnagy@redhat.com> - 7:3.0.STABLE4-1
|
||||
|
Loading…
Reference in New Issue
Block a user