e844aa549d
aoliva@redhat.com - add support for negotiate authentication (#445337)
57 lines
1.8 KiB
Diff
57 lines
1.8 KiB
Diff
diff -up squid-3.0.STABLE5/configure.config_netfilter squid-3.0.STABLE5/configure
|
|
--- squid-3.0.STABLE5/configure.config_netfilter 2008-03-04 09:35:36.000000000 -0300
|
|
+++ squid-3.0.STABLE5/configure 2008-05-05 06:50:56.000000000 -0300
|
|
@@ -24512,6 +24512,10 @@ cat >>conftest.$ac_ext <<_ACEOF
|
|
#if HAVE_LIMITS_H
|
|
#include <limits.h>
|
|
#endif
|
|
+#if HAVE_NETINET_IN_H
|
|
+# include <netinet/in.h>
|
|
+#endif
|
|
+#include <linux/types.h>
|
|
|
|
|
|
#include <$ac_header>
|
|
diff -up squid-3.0.STABLE5/configure.in.config_netfilter squid-3.0.STABLE5/configure.in
|
|
--- squid-3.0.STABLE5/configure.in.config_netfilter 2008-03-04 09:35:36.000000000 -0300
|
|
+++ squid-3.0.STABLE5/configure.in 2008-05-05 06:50:56.000000000 -0300
|
|
@@ -1931,6 +1931,10 @@ SQUID_DEFAULT_INCLUDES
|
|
#if HAVE_LIMITS_H
|
|
#include <limits.h>
|
|
#endif
|
|
+#if HAVE_NETINET_IN_H
|
|
+# include <netinet/in.h>
|
|
+#endif
|
|
+#include <linux/types.h>
|
|
)
|
|
|
|
AC_CHECK_HEADERS(net/if.h \
|
|
diff -up squid-3.0.STABLE5/src/forward.cc.config_netfilter squid-3.0.STABLE5/src/forward.cc
|
|
--- squid-3.0.STABLE5/src/forward.cc.config_netfilter 2008-02-27 07:42:23.000000000 -0300
|
|
+++ squid-3.0.STABLE5/src/forward.cc 2008-05-05 06:54:02.000000000 -0300
|
|
@@ -50,6 +50,10 @@
|
|
#include "Store.h"
|
|
|
|
#if LINUX_TPROXY
|
|
+#if HAVE_NETINET_IN_H
|
|
+# include <netinet/in.h>
|
|
+#endif
|
|
+#include <linux/types.h>
|
|
#include <linux/netfilter_ipv4/ip_tproxy.h>
|
|
#endif
|
|
|
|
diff -up squid-3.0.STABLE5/src/IPInterception.cc.config_netfilter squid-3.0.STABLE5/src/IPInterception.cc
|
|
--- squid-3.0.STABLE5/src/IPInterception.cc.config_netfilter 2007-11-07 08:20:47.000000000 -0200
|
|
+++ squid-3.0.STABLE5/src/IPInterception.cc 2008-05-05 06:53:56.000000000 -0300
|
|
@@ -85,6 +85,10 @@
|
|
#endif
|
|
|
|
#if LINUX_NETFILTER
|
|
+#if HAVE_NETINET_IN_H
|
|
+# include <netinet/in.h>
|
|
+#endif
|
|
+#include <linux/types.h>
|
|
#include <linux/netfilter_ipv4.h>
|
|
#endif
|
|
|