try and fix shared spirv-tools libraries

This commit is contained in:
Dave Airlie 2020-08-04 14:12:56 +10:00
parent 4aba5909c7
commit a56667ff70
2 changed files with 41 additions and 3 deletions

36
fix-shared-libs.patch Normal file
View File

@ -0,0 +1,36 @@
diff -up SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/link/CMakeLists.txt.dma SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/link/CMakeLists.txt
--- SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/link/CMakeLists.txt.dma 2020-08-04 14:12:02.354651856 +1000
+++ SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/link/CMakeLists.txt 2020-08-04 14:12:11.728900944 +1000
@@ -11,7 +11,7 @@
# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
# See the License for the specific language governing permissions and
# limitations under the License.
-add_library(SPIRV-Tools-link STATIC
+add_library(SPIRV-Tools-link
linker.cpp
)
diff -up SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/opt/CMakeLists.txt.dma SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/opt/CMakeLists.txt
--- SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/opt/CMakeLists.txt.dma 2020-08-04 01:45:24.000000000 +1000
+++ SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/opt/CMakeLists.txt 2020-08-04 14:11:54.629446580 +1000
@@ -233,7 +233,7 @@ endif()
spvtools_pch(SPIRV_TOOLS_OPT_SOURCES pch_source_opt)
-add_library(SPIRV-Tools-opt STATIC ${SPIRV_TOOLS_OPT_SOURCES})
+add_library(SPIRV-Tools-opt ${SPIRV_TOOLS_OPT_SOURCES})
spvtools_default_compile_options(SPIRV-Tools-opt)
target_include_directories(SPIRV-Tools-opt
diff -up SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/reduce/CMakeLists.txt.dma SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/reduce/CMakeLists.txt
--- SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/reduce/CMakeLists.txt.dma 2020-08-04 01:45:24.000000000 +1000
+++ SPIRV-Tools-92a71657fcbae77caf79181f655fabe8be7e0d84/source/reduce/CMakeLists.txt 2020-08-04 14:11:54.630446606 +1000
@@ -77,7 +77,7 @@ endif()
spvtools_pch(SPIRV_TOOLS_REDUCE_SOURCES pch_source_reduce)
-add_library(SPIRV-Tools-reduce STATIC ${SPIRV_TOOLS_REDUCE_SOURCES})
+add_library(SPIRV-Tools-reduce ${SPIRV_TOOLS_REDUCE_SOURCES})
spvtools_default_compile_options(SPIRV-Tools-reduce)
target_include_directories(SPIRV-Tools-reduce

View File

@ -6,14 +6,16 @@
%global gitrel .%{commit_date}.git%{shortcommit}
Name: spirv-tools
Version: 2019.5
Release: 4%{?gitrel}%{?dist}
Version: 2020.5
Release: 1%{?gitrel}%{?dist}
Summary: API and commands for processing SPIR-V modules
License: ASL 2.0
URL: https://github.com/KhronosGroup/SPIRV-Tools
Source0: %url/archive/%{commit}.tar.gz#/%{name}-%{commit}.tar.gz
Patch9: fix-shared-libs.patch
BuildRequires: cmake3
BuildRequires: gcc-c++
BuildRequires: ninja-build
@ -86,7 +88,7 @@ Development files for %{name}
%{_libdir}/pkgconfig/SPIRV-Tools.pc
%changelog
* Tue Aug 04 2020 Dave Airlie <airlied@redhat.com> - 2019.5-4.20200803.git92a71657
* Tue Aug 04 2020 Dave Airlie <airlied@redhat.com> - 2029.5-1.20200803.git92a71657
- update to latest spirv-tools
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2019.5-3.20200421.git67f4838