Update for vulkan 1.1.73.0
This commit is contained in:
parent
0ca9aaf4d6
commit
4d6e901809
@ -1,38 +0,0 @@
|
|||||||
From 4e4a254bc85ea41af93a048f1713ef27e04c01ab Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?J=C3=B3zef=20Kucia?= <joseph.kucia@gmail.com>
|
|
||||||
Date: Fri, 9 Feb 2018 12:30:08 +0100
|
|
||||||
Subject: [PATCH] Do not hardcode libdir and includedir in pkg config files
|
|
||||||
|
|
||||||
---
|
|
||||||
CMakeLists.txt | 4 ++++
|
|
||||||
cmake/SPIRV-Tools-shared.pc.in | 4 ++--
|
|
||||||
cmake/SPIRV-Tools.pc.in | 4 ++--
|
|
||||||
3 files changed, 8 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
||||||
index 011baf9b0..a2fc21620 100644
|
|
||||||
--- a/CMakeLists.txt
|
|
||||||
+++ b/CMakeLists.txt
|
|
||||||
@@ -234,6 +234,8 @@ add_custom_target(spirv-tools-pkg-config ALL
|
|
||||||
-DTEMPLATE_FILE=${CMAKE_CURRENT_SOURCE_DIR}/cmake/SPIRV-Tools.pc.in
|
|
||||||
-DOUT_FILE=${CMAKE_CURRENT_BINARY_DIR}/SPIRV-Tools.pc
|
|
||||||
-DCMAKE_INSTALL_PREFIX=${CMAKE_INSTALL_PREFIX}
|
|
||||||
+ -DCMAKE_INSTALL_LIBDIR=${CMAKE_INSTALL_LIBDIR}
|
|
||||||
+ -DCMAKE_INSTALL_INCLUDEDIR=${CMAKE_INSTALL_INCLUDEDIR}
|
|
||||||
-DSPIRV_LIBRARIES=${SPIRV_LIBRARIES}
|
|
||||||
-P ${CMAKE_CURRENT_SOURCE_DIR}/cmake/write_pkg_config.cmake
|
|
||||||
DEPENDS "CHANGES" "cmake/SPIRV-Tools.pc.in" "cmake/write_pkg_config.cmake")
|
|
||||||
diff --git a/cmake/SPIRV-Tools-shared.pc.in b/cmake/SPIRV-Tools-shared.pc.in
|
|
||||||
index a652d5e49..2984dc57f 100644
|
|
||||||
--- a/cmake/SPIRV-Tools.pc.in
|
|
||||||
+++ b/cmake/SPIRV-Tools.pc.in
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
prefix=@CMAKE_INSTALL_PREFIX@
|
|
||||||
exec_prefix=${prefix}
|
|
||||||
-libdir=${prefix}/lib64
|
|
||||||
-includedir=${prefix}/include
|
|
||||||
+libdir=${prefix}/@CMAKE_INSTALL_LIBDIR@
|
|
||||||
+includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
|
|
||||||
|
|
||||||
Name: SPIRV-Tools
|
|
||||||
Description: Tools for SPIR-V
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (spirv-tools-9e19fc0f31ceaf1f6bc907dbf17dcfded85f2ce8.tar.gz) = e509667c4db1dec90d550bacad983d04b55dcd88b3eed722efce7df7cfe028ba5bf346b4fdbd71e00ad299cb0e6d7bb51e7cf9da9df87ef03c99ff0a410b5872
|
SHA512 (spirv-tools-26a698c34788bb69123a1f3789970a16cf4d9641.tar.gz) = 8637b3131e80af1f865cb3c985e9d8b3a423dc86130790d22c2ec702882dd3966a06d7b0cc2f89f99eca2cb748427368857f1f283cb2d87b66ae590eb61c3957
|
||||||
|
@ -1,18 +1,16 @@
|
|||||||
%global commit 9e19fc0f31ceaf1f6bc907dbf17dcfded85f2ce8
|
%global commit 26a698c34788bb69123a1f3789970a16cf4d9641
|
||||||
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
%global shortcommit %(c=%{commit}; echo ${c:0:7})
|
||||||
%global commit_date 20180205
|
%global commit_date 20180407
|
||||||
%global gitrel .%{commit_date}.git%{shortcommit}
|
%global gitrel .%{commit_date}.git%{shortcommit}
|
||||||
|
|
||||||
Name: spirv-tools
|
Name: spirv-tools
|
||||||
Version: 2018.1
|
Version: 2018.1
|
||||||
Release: 0.2%{?gitrel}%{?dist}
|
Release: 0.3%{?gitrel}%{?dist}
|
||||||
Summary: API and commands for processing SPIR-V modules
|
Summary: API and commands for processing SPIR-V modules
|
||||||
|
|
||||||
License: ASL 2.0
|
License: ASL 2.0
|
||||||
URL: https://github.com/KhronosGroup/SPIRV-Tools
|
URL: https://github.com/KhronosGroup/SPIRV-Tools
|
||||||
Source0: %url/archive/%{commit}.tar.gz#/%{name}-%{commit}.tar.gz
|
Source0: %url/archive/%{commit}.tar.gz#/%{name}-%{commit}.tar.gz
|
||||||
# Based on https://github.com/KhronosGroup/SPIRV-Tools/commit/4e4a254bc85ea41af93a048f1713ef27e04c01ab
|
|
||||||
Patch0: fix_pkconfig_pc_file.patch
|
|
||||||
|
|
||||||
BuildRequires: cmake3
|
BuildRequires: cmake3
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -49,7 +47,6 @@ pushd %_target_platform
|
|||||||
%cmake3 -DCMAKE_BUILD_TYPE=Release \
|
%cmake3 -DCMAKE_BUILD_TYPE=Release \
|
||||||
-DPYTHON_EXECUTABLE:FILEPATH=%{_bindir}/python%{python2_version} \
|
-DPYTHON_EXECUTABLE:FILEPATH=%{_bindir}/python%{python2_version} \
|
||||||
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
|
-DCMAKE_INSTALL_LIBDIR=%{_lib} \
|
||||||
-DSPIRV_WERROR=OFF \
|
|
||||||
-DSPIRV-Headers_SOURCE_DIR=%{_prefix} \
|
-DSPIRV-Headers_SOURCE_DIR=%{_prefix} \
|
||||||
-GNinja ..
|
-GNinja ..
|
||||||
%ninja_build
|
%ninja_build
|
||||||
@ -75,13 +72,18 @@ popd
|
|||||||
%files libs
|
%files libs
|
||||||
%{_libdir}/libSPIRV-Tools-link.so
|
%{_libdir}/libSPIRV-Tools-link.so
|
||||||
%{_libdir}/libSPIRV-Tools-opt.so
|
%{_libdir}/libSPIRV-Tools-opt.so
|
||||||
|
%{_libdir}/libSPIRV-Tools-shared.so
|
||||||
%{_libdir}/libSPIRV-Tools.so
|
%{_libdir}/libSPIRV-Tools.so
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/spirv-tools/
|
%{_includedir}/spirv-tools/
|
||||||
|
%{_libdir}/pkgconfig/SPIRV-Tools-shared.pc
|
||||||
%{_libdir}/pkgconfig/SPIRV-Tools.pc
|
%{_libdir}/pkgconfig/SPIRV-Tools.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Apr 24 2018 Leigh Scott <leigh123linux@googlemail.com> - 2018.1-0.3.20180407.git26a698c
|
||||||
|
- Update for vulkan 1.1.73.0
|
||||||
|
|
||||||
* Wed Feb 14 2018 Leigh Scott <leigh123linux@googlemail.com> - 2018.1-0.2.20180205.git9e19fc0
|
* Wed Feb 14 2018 Leigh Scott <leigh123linux@googlemail.com> - 2018.1-0.2.20180205.git9e19fc0
|
||||||
- Add isa to the provides
|
- Add isa to the provides
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user