Fix FTBFS
This commit is contained in:
parent
85caa35600
commit
2379d13954
44
0001-build-egl-remove-libdrm-drm_fourcc.h.patch
Normal file
44
0001-build-egl-remove-libdrm-drm_fourcc.h.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
From 308df96bef921c8acc61b645a1744b65e2104e6e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Victor Toso <me@victortoso.com>
|
||||||
|
Date: Thu, 6 Feb 2020 14:21:10 +0100
|
||||||
|
Subject: [PATCH spice-gtk] build: egl: remove libdrm/drm_fourcc.h
|
||||||
|
|
||||||
|
Same result but removing the single directly usage of libdrm include
|
||||||
|
which is not being checked. The header epoxy/egl_generated.h contains
|
||||||
|
the macro EGL_LINUX_DRM_FOURCC_EXT that we use in spice-widget-egl.c
|
||||||
|
and that is included in epoxy/egl.h already.
|
||||||
|
|
||||||
|
Signed-off-by: Victor Toso <victortoso@redhat.com>
|
||||||
|
Acked-by: Frediano Ziglio <fziglio@redhat.com>
|
||||||
|
---
|
||||||
|
meson.build | 1 +
|
||||||
|
src/spice-widget-egl.c | 1 -
|
||||||
|
2 files changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 171a3f6..e7df9c4 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -63,6 +63,7 @@ foreach header : headers
|
||||||
|
endif
|
||||||
|
endforeach
|
||||||
|
|
||||||
|
+# FIXME: Add a config option to validate spice-widget-egl being built or not
|
||||||
|
spice_gtk_has_egl = compiler.has_header('epoxy/egl.h')
|
||||||
|
if spice_gtk_has_egl
|
||||||
|
spice_gtk_config_data.set('HAVE_EPOXY_EGL_H', '1')
|
||||||
|
diff --git a/src/spice-widget-egl.c b/src/spice-widget-egl.c
|
||||||
|
index f5e24a0..06af97a 100644
|
||||||
|
--- a/src/spice-widget-egl.c
|
||||||
|
+++ b/src/spice-widget-egl.c
|
||||||
|
@@ -26,7 +26,6 @@
|
||||||
|
#include "spice-widget.h"
|
||||||
|
#include "spice-widget-priv.h"
|
||||||
|
#include "spice-gtk-session-priv.h"
|
||||||
|
-#include <libdrm/drm_fourcc.h>
|
||||||
|
|
||||||
|
#ifdef GDK_WINDOWING_X11
|
||||||
|
#include <gdk/gdkx.h>
|
||||||
|
--
|
||||||
|
2.25.0.rc2.1.g09a9a1a997
|
||||||
|
|
29
0001-meson-link-with-lm.patch
Normal file
29
0001-meson-link-with-lm.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
From fc4400033ea6b8d0731b29d12d66441da70f4e4a Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
||||||
|
Date: Thu, 30 Jan 2020 12:07:07 -0300
|
||||||
|
Subject: [PATCH spice-gtk] meson: link with -lm
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
||||||
|
---
|
||||||
|
meson.build | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/meson.build b/meson.build
|
||||||
|
index 8c6288f..ff7c773 100644
|
||||||
|
--- a/meson.build
|
||||||
|
+++ b/meson.build
|
||||||
|
@@ -111,7 +111,7 @@ foreach dep : deps
|
||||||
|
spice_glib_deps += dependency(dep)
|
||||||
|
endforeach
|
||||||
|
|
||||||
|
-deps = []
|
||||||
|
+deps = ['m']
|
||||||
|
if host_machine.system() == 'windows'
|
||||||
|
deps += ['libws2_32', 'libgdi32']
|
||||||
|
endif
|
||||||
|
--
|
||||||
|
2.25.0.rc2.1.g09a9a1a997
|
||||||
|
|
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: spice-gtk
|
Name: spice-gtk
|
||||||
Version: 0.37
|
Version: 0.37
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Summary: A GTK+ widget for SPICE clients
|
Summary: A GTK+ widget for SPICE clients
|
||||||
|
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
@ -31,6 +31,9 @@ Patch0005: 0004-clipboard-do-not-delay-release-if-agent-has-no-relea.patch
|
|||||||
Patch0006: 0005-clipboard-pre-condition-on-selection-value-256.patch
|
Patch0006: 0005-clipboard-pre-condition-on-selection-value-256.patch
|
||||||
Patch0007: 0006-clipboard-implement-CAP_CLIPBOARD_GRAB_SERIAL.patch
|
Patch0007: 0006-clipboard-implement-CAP_CLIPBOARD_GRAB_SERIAL.patch
|
||||||
|
|
||||||
|
Patch0008: 0001-build-egl-remove-libdrm-drm_fourcc.h.patch
|
||||||
|
Patch0009: 0001-meson-link-with-lm.patch
|
||||||
|
|
||||||
BuildRequires: git-core
|
BuildRequires: git-core
|
||||||
BuildRequires: meson
|
BuildRequires: meson
|
||||||
BuildRequires: intltool
|
BuildRequires: intltool
|
||||||
@ -211,6 +214,9 @@ gpgv2 --quiet --keyring %{SOURCE2} %{SOURCE1} %{SOURCE0}
|
|||||||
%{_bindir}/spicy-stats
|
%{_bindir}/spicy-stats
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 25 2020 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.37-6
|
||||||
|
- Fix FTBFS https://bugzilla.redhat.com/show_bug.cgi?id=1800106
|
||||||
|
|
||||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.37-5
|
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.37-5
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user