spice-gtk/0001-build-egl-remove-libdrm-drm_fourcc.h.patch
Marc-André Lureau 2379d13954 Fix FTBFS
2020-02-25 15:52:18 +01:00

45 lines
1.4 KiB
Diff

From 308df96bef921c8acc61b645a1744b65e2104e6e Mon Sep 17 00:00:00 2001
From: Victor Toso <me@victortoso.com>
Date: Thu, 6 Feb 2020 14:21:10 +0100
Subject: [PATCH spice-gtk] build: egl: remove libdrm/drm_fourcc.h
Same result but removing the single directly usage of libdrm include
which is not being checked. The header epoxy/egl_generated.h contains
the macro EGL_LINUX_DRM_FOURCC_EXT that we use in spice-widget-egl.c
and that is included in epoxy/egl.h already.
Signed-off-by: Victor Toso <victortoso@redhat.com>
Acked-by: Frediano Ziglio <fziglio@redhat.com>
---
meson.build | 1 +
src/spice-widget-egl.c | 1 -
2 files changed, 1 insertion(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 171a3f6..e7df9c4 100644
--- a/meson.build
+++ b/meson.build
@@ -63,6 +63,7 @@ foreach header : headers
endif
endforeach
+# FIXME: Add a config option to validate spice-widget-egl being built or not
spice_gtk_has_egl = compiler.has_header('epoxy/egl.h')
if spice_gtk_has_egl
spice_gtk_config_data.set('HAVE_EPOXY_EGL_H', '1')
diff --git a/src/spice-widget-egl.c b/src/spice-widget-egl.c
index f5e24a0..06af97a 100644
--- a/src/spice-widget-egl.c
+++ b/src/spice-widget-egl.c
@@ -26,7 +26,6 @@
#include "spice-widget.h"
#include "spice-widget-priv.h"
#include "spice-gtk-session-priv.h"
-#include <libdrm/drm_fourcc.h>
#ifdef GDK_WINDOWING_X11
#include <gdk/gdkx.h>
--
2.25.0.rc2.1.g09a9a1a997