soundtouch/soname.patch
2021-08-29 22:52:46 +01:00

17 lines
529 B
Diff

--- ./CMakeLists.txt.orig 2021-08-29 18:54:40.050485890 +0100
+++ ./CMakeLists.txt 2021-08-29 22:44:06.499150248 +0100
@@ -35,6 +35,13 @@ target_include_directories(SoundTouch PU
$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
)
+if(BUILD_SHARED_LIBS)
+set_target_properties(SoundTouch PROPERTIES
+ VERSION ${CMAKE_PROJECT_VERSION}
+ SOVERSION ${PROJECT_VERSION_MAJOR}
+)
+endif()
+
target_compile_definitions(SoundTouch PRIVATE ${COMPILE_DEFINITIONS})
target_compile_options(SoundTouch PRIVATE ${COMPILE_OPTIONS})