Update to 2.3.0 (#1998849)

This commit is contained in:
Sérgio M. Basto 2021-08-29 22:42:53 +01:00
parent 5e66054f60
commit b7c49ac115
4 changed files with 28 additions and 28 deletions

1
.gitignore vendored
View File

@ -4,3 +4,4 @@ soundtouch-1.4.0.tar.gz
/soundtouch-2.1.0.tar.gz
/soundtouch-2.1.1.tar.gz
/soundtouch-2.1.2.tar.gz
/soundtouch-2.3.0.tar.gz

16
soname.patch Normal file
View File

@ -0,0 +1,16 @@
--- ./CMakeLists.txt.orig 2021-08-29 18:54:40.050485890 +0100
+++ ./CMakeLists.txt 2021-08-29 22:44:06.499150248 +0100
@@ -35,6 +35,13 @@ target_include_directories(SoundTouch PU
$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
)
+if(BUILD_SHARED_LIBS)
+set_target_properties(SoundTouch PROPERTIES
+ VERSION ${CMAKE_PROJECT_VERSION}
+ SOVERSION ${PROJECT_VERSION_MAJOR}
+)
+endif()
+
target_compile_definitions(SoundTouch PRIVATE ${COMPILE_DEFINITIONS})
target_compile_options(SoundTouch PRIVATE ${COMPILE_OPTIONS})

View File

@ -1,13 +1,13 @@
Name: soundtouch
Version: 2.1.2
Version: 2.3.0
Release: 1%{?dist}
Summary: Audio Processing library for changing Tempo, Pitch and Playback Rates
License: LGPLv2+
URL: http://www.surina.net/soundtouch/
Source0: https://gitlab.com/soundtouch/soundtouch/-/archive/%{version}/%{name}-%{version}.tar.gz
BuildRequires: make
Patch0: soname.patch
BuildRequires: gcc-c++
BuildRequires: autoconf automake libtool
BuildRequires: cmake
%description
SoundTouch is a LGPL-licensed open-source audio processing library for
@ -32,32 +32,15 @@ Libraries, include files, etc you can use to develop soundtouch applications.
%prep
%autosetup -p1
# Remove -O3 because we have our default optimizations.
sed -i 's|-O3||' source/SoundTouch/Makefile.*
sed -i 's|-O3||' source/SoundStretch/Makefile.*
autoreconf -iv
# set correct version for .so build
%define ltversion %(echo %{version} | tr '.' ':')
sed -i 's/-rpath $(libdir)/-rpath $(libdir) -version-number %{ltversion}/' \
source/SoundTouch/Makefile.in
# cleanup a bit
sed -i 's|\r||g' README.html source/SoundTouch/RateTransposer.cpp
%build
%configure --disable-dependency-tracking --disable-static --enable-shared
# Don't use rpath!
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
%make_build
%cmake
%cmake_build
%install
%make_install
rm %{buildroot}%{_libdir}/*.la
# remove redundant installed docs
rm -rf %{buildroot}%{_docdir}/%{name}
%cmake_install
# pkgconfig compat links for compat with older (API compatible) releases
# dunno why upstream keeps changing the pkgconfig name
@ -72,9 +55,6 @@ ln -s soundtouch.pc %{buildroot}%{_libdir}/pkgconfig/soundtouch-1.0.pc
# > %{buildroot}%{_includedir}/soundtouch/soundtouch_config.h
%ldconfig_scriptlets
%files
%doc README.html
%license COPYING.TXT
@ -85,10 +65,13 @@ ln -s soundtouch.pc %{buildroot}%{_libdir}/pkgconfig/soundtouch-1.0.pc
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/%{name}
%{_datadir}/aclocal/%{name}.m4
%{_libdir}/cmake/SoundTouch
%changelog
* Sun Aug 29 2021 Sérgio Basto <sergio@serjux.com> - 2.3.0-1
- Update to 2.3.0 (#1998849)
* Sun Aug 29 2021 Uwe Klotz <uwe.klotz@gmail.com> - 2.1.2-1
- Update to new upstream version 2.1.2
Bump version to 2.1.2 to correct incorrect version info in configure.ac

View File

@ -1 +1 @@
SHA512 (soundtouch-2.1.2.tar.gz) = 7c2f864ae7576952a35c4492ebf41fb0188aab85040e07baa8da422555257becbc364efffddf0b84b9f17fdcdad48d980e4355e13b5ce425a62b69de63d1810f
SHA512 (soundtouch-2.3.0.tar.gz) = 55cc1cad3886ce4557859e415fefcc4c3d81d0898a4ff5f795a44c37723c48af18f9a1a910199bcf4bb5005e306aee8a0239676613e23146324d839797495a12