Update to new upstream version 2.3.1

This commit is contained in:
Uwe Klotz 2021-09-09 14:29:12 +02:00
parent 94bd6dc031
commit 53469022f1
4 changed files with 12 additions and 56 deletions

View File

@ -1,13 +0,0 @@
diff --git a/configure.ac b/configure.ac
index c15e348..06ac3e7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,7 +33,7 @@ AC_LANG(C++)
# Compiler flags. Apply -ffast-math to allow gcc autovectorization
# generate effective SIMD code.
-CXXFLAGS="-O3 -ffast-math"
+CXXFLAGS+=" -O3 -ffast-math"
# Set AR_FLAGS to avoid build warning "ar: `u' modifier ignored since `D' is the default (see `U')"
AR_FLAGS='cr'

View File

@ -1,16 +0,0 @@
--- ./CMakeLists.txt.orig 2021-08-29 18:54:40.050485890 +0100
+++ ./CMakeLists.txt 2021-08-29 22:44:06.499150248 +0100
@@ -35,6 +35,13 @@ target_include_directories(SoundTouch PU
$<INSTALL_INTERFACE:${CMAKE_INSTALL_INCLUDEDIR}>
)
+if(BUILD_SHARED_LIBS)
+set_target_properties(SoundTouch PROPERTIES
+ VERSION ${CMAKE_PROJECT_VERSION}
+ SOVERSION ${PROJECT_VERSION_MAJOR}
+)
+endif()
+
target_compile_definitions(SoundTouch PRIVATE ${COMPILE_DEFINITIONS})
target_compile_options(SoundTouch PRIVATE ${COMPILE_OPTIONS})

View File

@ -1,14 +1,12 @@
Name: soundtouch
Version: 2.3.0
Release: 2%{?dist}
Version: 2.3.1
Release: 1%{?dist}
Summary: Audio Processing library for changing Tempo, Pitch and Playback Rates
License: LGPLv2+
URL: http://www.surina.net/soundtouch/
Source0: https://gitlab.com/soundtouch/soundtouch/-/archive/%{version}/%{name}-%{version}.tar.gz
BuildRequires: make
BuildRequires: gcc-c++
BuildRequires: autoconf automake libtool
Patch0: configure.ac.patch
BuildRequires: cmake
%description
SoundTouch is a LGPL-licensed open-source audio processing library for
@ -33,32 +31,15 @@ Libraries, include files, etc you can use to develop soundtouch applications.
%prep
%autosetup -p1
autoreconf -iv
# Remove -O3 because we have our default optimizations.
sed -i 's|-O3||' source/SoundTouch/Makefile.*
sed -i 's|-O3||' source/SoundStretch/Makefile.*
# set correct version for .so build
%define ltversion %(echo %{version} | tr '.' ':')
sed -i 's/-rpath $(libdir)/-rpath $(libdir) -version-number %{ltversion}/' \
source/SoundTouch/Makefile.in
# cleanup a bit
sed -i 's|\r||g' README.html source/SoundTouch/RateTransposer.cpp
%build
%configure --disable-dependency-tracking --disable-static --enable-shared
# Don't use rpath!
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
%make_build
%cmake
%cmake_build
%install
%make_install
rm %{buildroot}%{_libdir}/*.la
# remove redundant installed docs
rm -rf %{buildroot}%{_docdir}/%{name}
%cmake_install
# pkgconfig compat links for compat with older (API compatible) releases
# dunno why upstream keeps changing the pkgconfig name
@ -83,10 +64,14 @@ ln -s soundtouch.pc %{buildroot}%{_libdir}/pkgconfig/soundtouch-1.0.pc
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/%{name}
%{_datadir}/aclocal/%{name}.m4
%{_libdir}/cmake/SoundTouch
%changelog
* Thu Sep 09 2021 Uwe Klotz <uwe.klotz@gmail.com> - 2.3.1-1
- Update to new upstream version 2.3.1
Switch build from autotools to CMake
* Tue Aug 31 2021 Sérgio Basto <sergio@serjux.com> - 2.3.0-2
- Continuing to use the autotools build instead of new CMake
https://gitlab.com/soundtouch/soundtouch/-/issues/45

View File

@ -1 +1 @@
SHA512 (soundtouch-2.3.0.tar.gz) = 55cc1cad3886ce4557859e415fefcc4c3d81d0898a4ff5f795a44c37723c48af18f9a1a910199bcf4bb5005e306aee8a0239676613e23146324d839797495a12
SHA512 (soundtouch-2.3.1.tar.gz) = 1eea5c06dc5af633b5c16902c6a951593190daf75bd6aa12e00c745080f9363e9c45ab52ddc434bd905e4195b306cc38c9143e813430c15c19a275ae1a82df24