* Mon Jan 08 2018 Lukas Vrabec <lvrabec@redhat.com> - 3.13.1-310
- Use python3 package in BuildRequires to ensure python version 3 will be used for compiling SELinux policy
This commit is contained in:
parent
af863d8251
commit
b9923641ff
2
Makefile
2
Makefile
@ -71,7 +71,7 @@ AWK ?= gawk
|
|||||||
GREP ?= egrep
|
GREP ?= egrep
|
||||||
INSTALL ?= install
|
INSTALL ?= install
|
||||||
M4 ?= m4
|
M4 ?= m4
|
||||||
PYTHON ?= python
|
PYTHON ?= python3
|
||||||
SED ?= sed
|
SED ?= sed
|
||||||
SORT ?= LC_ALL=C sort
|
SORT ?= LC_ALL=C sort
|
||||||
|
|
||||||
|
Binary file not shown.
@ -9,7 +9,7 @@ index 360bd0388..e794aa369 100644
|
|||||||
+ url = https://github.com/fedora-selinux/selinux-policy-contrib
|
+ url = https://github.com/fedora-selinux/selinux-policy-contrib
|
||||||
+ branch = rawhide
|
+ branch = rawhide
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index ec7b5cba8..673db6491 100644
|
index ec7b5cba8..bc4073eef 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -61,6 +61,7 @@ SEMODULE ?= $(tc_usrsbindir)/semodule
|
@@ -61,6 +61,7 @@ SEMODULE ?= $(tc_usrsbindir)/semodule
|
||||||
@ -20,6 +20,15 @@ index ec7b5cba8..673db6491 100644
|
|||||||
LOADPOLICY ?= $(tc_usrsbindir)/load_policy
|
LOADPOLICY ?= $(tc_usrsbindir)/load_policy
|
||||||
SETFILES ?= $(tc_sbindir)/setfiles
|
SETFILES ?= $(tc_sbindir)/setfiles
|
||||||
XMLLINT ?= $(BINDIR)/xmllint
|
XMLLINT ?= $(BINDIR)/xmllint
|
||||||
|
@@ -71,7 +72,7 @@ AWK ?= gawk
|
||||||
|
GREP ?= egrep
|
||||||
|
INSTALL ?= install
|
||||||
|
M4 ?= m4
|
||||||
|
-PYTHON ?= python
|
||||||
|
+PYTHON ?= python3
|
||||||
|
SED ?= sed
|
||||||
|
SORT ?= LC_ALL=C sort
|
||||||
|
UMASK ?= umask
|
||||||
@@ -250,7 +251,7 @@ seusers := $(appconf)/seusers
|
@@ -250,7 +251,7 @@ seusers := $(appconf)/seusers
|
||||||
appdir := $(contextpath)
|
appdir := $(contextpath)
|
||||||
user_default_contexts := $(wildcard config/appconfig-$(TYPE)/*_default_contexts)
|
user_default_contexts := $(wildcard config/appconfig-$(TYPE)/*_default_contexts)
|
||||||
@ -926,6 +935,16 @@ index 3a45f236b..ee7d7b392 100644
|
|||||||
|
|
||||||
constrain socket_class_set { create relabelto relabelfrom }
|
constrain socket_class_set { create relabelto relabelfrom }
|
||||||
(
|
(
|
||||||
|
diff --git a/policy/flask/Makefile b/policy/flask/Makefile
|
||||||
|
index 17dc1747c..524944471 100644
|
||||||
|
--- a/policy/flask/Makefile
|
||||||
|
+++ b/policy/flask/Makefile
|
||||||
|
@@ -1,4 +1,4 @@
|
||||||
|
-PYTHON ?= python
|
||||||
|
+PYTHON ?= python3
|
||||||
|
|
||||||
|
# flask needs to know where to export the libselinux headers.
|
||||||
|
LIBSELINUX_D ?= ../../libselinux
|
||||||
diff --git a/policy/flask/access_vectors b/policy/flask/access_vectors
|
diff --git a/policy/flask/access_vectors b/policy/flask/access_vectors
|
||||||
index a94b16980..1c258d804 100644
|
index a94b16980..1c258d804 100644
|
||||||
--- a/policy/flask/access_vectors
|
--- a/policy/flask/access_vectors
|
||||||
@ -61727,9 +61746,18 @@ index c4ebc7e43..30d6d7a71 100644
|
|||||||
-')
|
-')
|
||||||
+gen_user(root, user, unconfined_r sysadm_r staff_r ifdef(`enable_mls',`secadm_r auditadm_r') system_r, s0, s0 - mls_systemhigh, mcs_allcats)
|
+gen_user(root, user, unconfined_r sysadm_r staff_r ifdef(`enable_mls',`secadm_r auditadm_r') system_r, s0, s0 - mls_systemhigh, mcs_allcats)
|
||||||
diff --git a/support/Makefile.devel b/support/Makefile.devel
|
diff --git a/support/Makefile.devel b/support/Makefile.devel
|
||||||
index b96e9b3d1..ff7340fdb 100644
|
index b96e9b3d1..510ab8889 100644
|
||||||
--- a/support/Makefile.devel
|
--- a/support/Makefile.devel
|
||||||
+++ b/support/Makefile.devel
|
+++ b/support/Makefile.devel
|
||||||
|
@@ -5,7 +5,7 @@ INSTALL ?= install
|
||||||
|
M4 ?= m4
|
||||||
|
SED ?= sed
|
||||||
|
EINFO ?= echo
|
||||||
|
-PYTHON ?= python
|
||||||
|
+PYTHON ?= python3
|
||||||
|
CUT ?= cut
|
||||||
|
|
||||||
|
NAME ?= $(shell $(AWK) -F= '/^SELINUXTYPE/{ print $$2 }' /etc/selinux/config)
|
||||||
@@ -26,7 +26,6 @@ XMLLINT := $(BINDIR)/xmllint
|
@@ -26,7 +26,6 @@ XMLLINT := $(BINDIR)/xmllint
|
||||||
# set default build options if missing
|
# set default build options if missing
|
||||||
TYPE ?= standard
|
TYPE ?= standard
|
||||||
|
@ -19,7 +19,7 @@
|
|||||||
Summary: SELinux policy configuration
|
Summary: SELinux policy configuration
|
||||||
Name: selinux-policy
|
Name: selinux-policy
|
||||||
Version: 3.13.1
|
Version: 3.13.1
|
||||||
Release: 309%{?dist}
|
Release: 310%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: serefpolicy-%{version}.tgz
|
Source: serefpolicy-%{version}.tgz
|
||||||
@ -67,7 +67,7 @@ Source102: rpm.macros
|
|||||||
Url: http://github.com/TresysTechnology/refpolicy/wiki
|
Url: http://github.com/TresysTechnology/refpolicy/wiki
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
BuildRequires: python gawk checkpolicy >= %{CHECKPOLICYVER} m4 policycoreutils-devel >= %{POLICYCOREUTILSVER} bzip2
|
BuildRequires: python3 gawk checkpolicy >= %{CHECKPOLICYVER} m4 policycoreutils-devel >= %{POLICYCOREUTILSVER} bzip2
|
||||||
Requires(pre): policycoreutils >= %{POLICYCOREUTILSVER}
|
Requires(pre): policycoreutils >= %{POLICYCOREUTILSVER}
|
||||||
Requires(post): /bin/awk /usr/bin/sha512sum
|
Requires(post): /bin/awk /usr/bin/sha512sum
|
||||||
Requires: rpm-plugin-selinux
|
Requires: rpm-plugin-selinux
|
||||||
@ -717,6 +717,9 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 08 2018 Lukas Vrabec <lvrabec@redhat.com> - 3.13.1-310
|
||||||
|
- Use python3 package in BuildRequires to ensure python version 3 will be used for compiling SELinux policy
|
||||||
|
|
||||||
* Fri Jan 05 2018 Lukas Vrabec <lvrabec@redhat.com> - 3.13.1-309
|
* Fri Jan 05 2018 Lukas Vrabec <lvrabec@redhat.com> - 3.13.1-309
|
||||||
- auth_use_nsswitch() interface cannot be used for attributes fixing munin policy
|
- auth_use_nsswitch() interface cannot be used for attributes fixing munin policy
|
||||||
- Allow git_script_t to mmap git_user_content_t files BZ(1530937)
|
- Allow git_script_t to mmap git_user_content_t files BZ(1530937)
|
||||||
|
Loading…
Reference in New Issue
Block a user