comment out the sepolgen line
This commit is contained in:
parent
68129209ed
commit
aaa0ee57f3
@ -1,12 +1,12 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index b8486a0..72a53cc 100644
|
||||
index b8486a0..6153c8b 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -61,6 +61,7 @@ SEMODULE ?= $(tc_usrsbindir)/semodule
|
||||
SEMOD_PKG ?= $(tc_usrbindir)/semodule_package
|
||||
SEMOD_LNK ?= $(tc_usrbindir)/semodule_link
|
||||
SEMOD_EXP ?= $(tc_usrbindir)/semodule_expand
|
||||
+SEPOLGEN ?= $(tc_usrbindir)/sepolgen-ifgen
|
||||
+#SEPOLGEN ?= $(tc_usrbindir)/sepolgen-ifgen
|
||||
LOADPOLICY ?= $(tc_usrsbindir)/load_policy
|
||||
SETFILES ?= $(tc_sbindir)/setfiles
|
||||
XMLLINT ?= $(BINDIR)/xmllint
|
||||
@ -20,14 +20,14 @@ index b8486a0..72a53cc 100644
|
||||
|
||||
all_layers := $(shell find $(wildcard $(moddir)/*) -maxdepth 0 -type d)
|
||||
diff --git a/Rules.modular b/Rules.modular
|
||||
index 168a14f..c2bf491 100644
|
||||
index 168a14f..cc1f793 100644
|
||||
--- a/Rules.modular
|
||||
+++ b/Rules.modular
|
||||
@@ -207,6 +207,7 @@ validate: $(base_pkg) $(mod_pkgs)
|
||||
@echo "Validating policy linking."
|
||||
$(verbose) $(SEMOD_LNK) -o $(tmpdir)/test.lnk $^
|
||||
$(verbose) $(SEMOD_EXP) $(tmpdir)/test.lnk $(tmpdir)/policy.bin
|
||||
+ $(verbose) $(SEPOLGEN) -p $(tmpdir)/policy.bin -i $(poldir) -o $(tmpdir)/output
|
||||
+# $(verbose) $(SEPOLGEN) -p $(tmpdir)/policy.bin -i $(poldir) -o $(tmpdir)/output
|
||||
@echo "Success."
|
||||
|
||||
########################################
|
||||
|
@ -97,10 +97,10 @@ SELinux policy documentation package
|
||||
%doc %{_usr}/share/doc/%{name}-%{version}
|
||||
%attr(755,root,root) %{_usr}/share/selinux/devel/policyhelp
|
||||
|
||||
#%check
|
||||
#if /usr/sbin/selinuxenabled; then
|
||||
#/usr/bin/sepolgen-ifgen -i %{buildroot}%{_usr}/share/selinux/devel/include -o /dev/null
|
||||
#fi
|
||||
%check
|
||||
if /usr/sbin/selinuxenabled; then
|
||||
/usr/bin/sepolgen-ifgen -i %{buildroot}%{_usr}/share/selinux/devel/include -o /dev/null
|
||||
fi
|
||||
|
||||
%define makeCmds() \
|
||||
make UNK_PERMS=%5 NAME=%1 TYPE=%2 DISTRO=%{distro} UBAC=n DIRECT_INITRC=%3 MONOLITHIC=%{monolithic} POLY=%4 MLS_CATS=1024 MCS_CATS=1024 bare \
|
||||
|
Loading…
Reference in New Issue
Block a user