Uncomment SEPOLGEN in Makefile
This commit is contained in:
parent
81c96b1880
commit
509b0c2f0f
@ -1,12 +1,12 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index b8486a0..6153c8b 100644
|
||||
index b8486a0..72a53cc 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -61,6 +61,7 @@ SEMODULE ?= $(tc_usrsbindir)/semodule
|
||||
SEMOD_PKG ?= $(tc_usrbindir)/semodule_package
|
||||
SEMOD_LNK ?= $(tc_usrbindir)/semodule_link
|
||||
SEMOD_EXP ?= $(tc_usrbindir)/semodule_expand
|
||||
+#SEPOLGEN ?= $(tc_usrbindir)/sepolgen-ifgen
|
||||
+SEPOLGEN ?= $(tc_usrbindir)/sepolgen-ifgen
|
||||
LOADPOLICY ?= $(tc_usrsbindir)/load_policy
|
||||
SETFILES ?= $(tc_sbindir)/setfiles
|
||||
XMLLINT ?= $(BINDIR)/xmllint
|
||||
@ -20,14 +20,14 @@ index b8486a0..6153c8b 100644
|
||||
|
||||
all_layers := $(shell find $(wildcard $(moddir)/*) -maxdepth 0 -type d)
|
||||
diff --git a/Rules.modular b/Rules.modular
|
||||
index 168a14f..cc1f793 100644
|
||||
index 168a14f..c2bf491 100644
|
||||
--- a/Rules.modular
|
||||
+++ b/Rules.modular
|
||||
@@ -207,6 +207,7 @@ validate: $(base_pkg) $(mod_pkgs)
|
||||
@echo "Validating policy linking."
|
||||
$(verbose) $(SEMOD_LNK) -o $(tmpdir)/test.lnk $^
|
||||
$(verbose) $(SEMOD_EXP) $(tmpdir)/test.lnk $(tmpdir)/policy.bin
|
||||
+# $(verbose) $(SEPOLGEN) -p $(tmpdir)/policy.bin -i $(poldir) -o $(tmpdir)/output
|
||||
+ $(verbose) $(SEPOLGEN) -p $(tmpdir)/policy.bin -i $(poldir) -o $(tmpdir)/output
|
||||
@echo "Success."
|
||||
|
||||
########################################
|
||||
|
Loading…
Reference in New Issue
Block a user