- Fix Makefile for building policy modules

This commit is contained in:
Daniel J Walsh 2007-08-11 11:18:09 +00:00
parent 60a9ef60f0
commit 0354c22269
3 changed files with 13 additions and 10 deletions

View File

@ -10,15 +10,13 @@ ifeq ($(MLSENABLED),)
endif
ifeq ($(MLSENABLED),1)
MCSFLAG=-mcs
TYPE ?= mcs
endif
ifeq ($(NAME), mls)
NAME = strict
MCSFLAG = -mls
TYPE ?= mls
endif
TYPE ?= $(NAME)${MCSFLAG}
HEADERDIR := $(SHAREDIR)/devel/include
include $(HEADERDIR)/Makefile

View File

@ -9474,7 +9474,7 @@ diff --exclude-from=exclude -N -u -r nsaserefpolicy/policy/modules/system/librar
+/var/cache/ldconfig(/.*)? gen_context(system_u:object_r:ld_so_cache_t,s0)
diff --exclude-from=exclude -N -u -r nsaserefpolicy/policy/modules/system/libraries.te serefpolicy-3.0.5/policy/modules/system/libraries.te
--- nsaserefpolicy/policy/modules/system/libraries.te 2007-08-02 08:17:28.000000000 -0400
+++ serefpolicy-3.0.5/policy/modules/system/libraries.te 2007-08-07 10:11:06.000000000 -0400
+++ serefpolicy-3.0.5/policy/modules/system/libraries.te 2007-08-11 06:57:43.000000000 -0400
@@ -46,7 +46,7 @@
allow ldconfig_t self:capability sys_chroot;
@ -10693,7 +10693,7 @@ diff --exclude-from=exclude -N -u -r nsaserefpolicy/policy/modules/system/sysnet
########################################
diff --exclude-from=exclude -N -u -r nsaserefpolicy/policy/modules/system/sysnetwork.te serefpolicy-3.0.5/policy/modules/system/sysnetwork.te
--- nsaserefpolicy/policy/modules/system/sysnetwork.te 2007-07-25 10:37:42.000000000 -0400
+++ serefpolicy-3.0.5/policy/modules/system/sysnetwork.te 2007-08-07 09:39:49.000000000 -0400
+++ serefpolicy-3.0.5/policy/modules/system/sysnetwork.te 2007-08-10 16:21:05.000000000 -0400
@@ -45,7 +45,7 @@
dontaudit dhcpc_t self:capability sys_tty_config;
# for access("/etc/bashrc", X_OK) on Red Hat
@ -10714,7 +10714,7 @@ diff --exclude-from=exclude -N -u -r nsaserefpolicy/policy/modules/system/sysnet
optional_policy(`
networkmanager_dbus_chat(dhcpc_t)
')
@@ -205,7 +209,11 @@
@@ -205,7 +209,13 @@
optional_policy(`
# dhclient sometimes starts ntpd
init_exec_script_files(dhcpc_t)
@ -10723,10 +10723,12 @@ diff --exclude-from=exclude -N -u -r nsaserefpolicy/policy/modules/system/sysnet
+optional_policy(`
ntp_domtrans(dhcpc_t)
+ ntp_domtrans_ntpdate(dhcpc_t)
+ ntp_manage_pid(dhcpc_t)
+ ntp_signal(dhcpc_t)
')
optional_policy(`
@@ -216,6 +224,7 @@
@@ -216,6 +226,7 @@
optional_policy(`
seutil_sigchld_newrole(dhcpc_t)
seutil_dontaudit_search_config(dhcpc_t)
@ -10734,7 +10736,7 @@ diff --exclude-from=exclude -N -u -r nsaserefpolicy/policy/modules/system/sysnet
')
optional_policy(`
@@ -280,6 +289,8 @@
@@ -280,6 +291,8 @@
fs_getattr_xattr_fs(ifconfig_t)
fs_search_auto_mountpoints(ifconfig_t)

View File

@ -17,7 +17,7 @@
Summary: SELinux policy configuration
Name: selinux-policy
Version: 3.0.5
Release: 5%{?dist}
Release: 6%{?dist}
License: GPL
Group: System Environment/Base
Source: serefpolicy-%{version}.tgz
@ -360,6 +360,9 @@ exit 0
%endif
%changelog
* Sat Aug 11 2007 Dan Walsh <dwalsh@redhat.com> 3.0.5-6
- Fix Makefile for building policy modules
* Fri Aug 10 2007 Dan Walsh <dwalsh@redhat.com> 3.0.5-5
- Fix dhcpc startup of service