Import rpm: c8s-stream-rhel8
This commit is contained in:
commit
f4eb9e0977
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/sat4j-2.3.5.tar.xz
|
48
0001-Fix-runtime-classpath-and-minimum-BREE.patch
Normal file
48
0001-Fix-runtime-classpath-and-minimum-BREE.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
From ad4a1884786434f200dc4a200b31b1d85aca11d3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mat Booth <mat.booth@redhat.com>
|
||||||
|
Date: Thu, 18 Jun 2020 15:23:18 +0100
|
||||||
|
Subject: [PATCH] Fix runtime classpath and minimum BREE
|
||||||
|
|
||||||
|
---
|
||||||
|
build.xml | 2 +-
|
||||||
|
org.sat4j.core/META-INF/MANIFEST.MF | 2 +-
|
||||||
|
org.sat4j.pb/META-INF/MANIFEST.MF | 3 +--
|
||||||
|
3 files changed, 3 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build.xml b/build.xml
|
||||||
|
index 624f511..122ad12 100644
|
||||||
|
--- a/build.xml
|
||||||
|
+++ b/build.xml
|
||||||
|
@@ -324,7 +324,7 @@
|
||||||
|
<javac
|
||||||
|
srcdir="${src}"
|
||||||
|
destdir="${build}"
|
||||||
|
- source="1.5"
|
||||||
|
+ source="${source}"
|
||||||
|
target="${target}"
|
||||||
|
debug="true"
|
||||||
|
includeantruntime="false">
|
||||||
|
diff --git a/org.sat4j.core/META-INF/MANIFEST.MF b/org.sat4j.core/META-INF/MANIFEST.MF
|
||||||
|
index e83a943..584326a 100644
|
||||||
|
--- a/org.sat4j.core/META-INF/MANIFEST.MF
|
||||||
|
+++ b/org.sat4j.core/META-INF/MANIFEST.MF
|
||||||
|
@@ -29,4 +29,4 @@ Specification-Vendor: Daniel Le Berre
|
||||||
|
Implementation-Title: SAT4J
|
||||||
|
Implementation-Version: 9.9.9.token
|
||||||
|
Implementation-Vendor: CRIL CNRS UMR 8188 - Universite d'Artois
|
||||||
|
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
|
||||||
|
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
|
||||||
|
diff --git a/org.sat4j.pb/META-INF/MANIFEST.MF b/org.sat4j.pb/META-INF/MANIFEST.MF
|
||||||
|
index f5ef127..10fe459 100644
|
||||||
|
--- a/org.sat4j.pb/META-INF/MANIFEST.MF
|
||||||
|
+++ b/org.sat4j.pb/META-INF/MANIFEST.MF
|
||||||
|
@@ -21,5 +21,4 @@ Specification-Vendor: Daniel Le Berre
|
||||||
|
Implementation-Title: SAT4J
|
||||||
|
Implementation-Version: 9.9.9.token
|
||||||
|
Implementation-Vendor: CRIL CNRS UMR 8188 - Universite d'Artois
|
||||||
|
-Class-Path: org.sat4j.core.jar
|
||||||
|
-Bundle-RequiredExecutionEnvironment: J2SE-1.5
|
||||||
|
+Bundle-RequiredExecutionEnvironment: JavaSE-1.8
|
||||||
|
--
|
||||||
|
2.26.2
|
||||||
|
|
16
sat4j-fetch.sh
Executable file
16
sat4j-fetch.sh
Executable file
@ -0,0 +1,16 @@
|
|||||||
|
#!/bin/sh
|
||||||
|
name=sat4j
|
||||||
|
tag=org.ow2.sat4j.pom-2.3.5
|
||||||
|
version=2.3.5
|
||||||
|
tar_name=$name-$version
|
||||||
|
|
||||||
|
rm -fr $tar_name && mkdir $tar_name
|
||||||
|
pushd $tar_name
|
||||||
|
|
||||||
|
# Fetch plugins
|
||||||
|
svn co svn://svn.forge.objectweb.org/svnroot/sat4j/maven/tags/$tag .
|
||||||
|
find . -name *.jar -delete
|
||||||
|
|
||||||
|
popd
|
||||||
|
# create archive
|
||||||
|
tar -caf $tar_name.tar.xz $tar_name
|
185
sat4j.spec
Normal file
185
sat4j.spec
Normal file
@ -0,0 +1,185 @@
|
|||||||
|
# should be consistent across one release
|
||||||
|
%global build_date 20130405
|
||||||
|
|
||||||
|
Name: sat4j
|
||||||
|
Version: 2.3.5
|
||||||
|
Release: 19%{?dist}
|
||||||
|
Summary: A library of SAT solvers written in Java
|
||||||
|
|
||||||
|
License: EPL-1.0 or LGPLv2
|
||||||
|
URL: http://www.sat4j.org/
|
||||||
|
# Created by sh sat4j-fetch.sh
|
||||||
|
Source0: sat4j-%{version}.tar.xz
|
||||||
|
Source1: sat4j-fetch.sh
|
||||||
|
|
||||||
|
Patch0: 0001-Fix-runtime-classpath-and-minimum-BREE.patch
|
||||||
|
|
||||||
|
BuildRequires: ant
|
||||||
|
BuildRequires: javapackages-local
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
The aim of the SAT4J library is to provide an efficient library of SAT
|
||||||
|
solvers in Java. The SAT4J library targets first users of SAT "black
|
||||||
|
boxes", those willing to embed SAT technologies into their application
|
||||||
|
without worrying about the details.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n sat4j-%{version}
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
%build
|
||||||
|
export ANT_OPTS="-Dfile.encoding=iso-8859-1"
|
||||||
|
ant -Dbuild.compiler=modern -Drelease=%{version} \
|
||||||
|
-Dtarget=1.8 -Dsource=1.8 -DBUILD_DATE=%{build_date} p2
|
||||||
|
|
||||||
|
%mvn_artifact "org.ow2.sat4j:org.ow2.sat4j.core::%{version}" dist/%{version}/org.sat4j.core.jar
|
||||||
|
%mvn_artifact "org.ow2.sat4j:org.ow2.sat4j.pb::%{version}" dist/%{version}/org.sat4j.pb.jar
|
||||||
|
%mvn_file ":org.ow2.sat4j.core" org.sat4j.core
|
||||||
|
%mvn_file ":org.ow2.sat4j.pb" org.sat4j.pb
|
||||||
|
|
||||||
|
%install
|
||||||
|
%mvn_install
|
||||||
|
|
||||||
|
%files -f .mfiles
|
||||||
|
# No %%doc files as the about.html is in the jar
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 2.3.5-19
|
||||||
|
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||||
|
|
||||||
|
* Thu Jun 18 2020 Mat Booth <mat.booth@redhat.com> - 2.3.5-18
|
||||||
|
- Allow building on Java 11
|
||||||
|
|
||||||
|
* Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-17
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-16
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 11 2019 Mat Booth <mat.booth@redhat.com> - 2.3.5-15
|
||||||
|
- Fix license tag
|
||||||
|
|
||||||
|
* Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-14
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-13
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-12
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-11
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jun 20 2017 Mat Booth <mat.booth@redhat.com> - 2.3.5-10
|
||||||
|
- Install with xmvn
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-9
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Tue Jul 14 2015 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.3.5-7
|
||||||
|
- Add build-requires on javapackages-local
|
||||||
|
|
||||||
|
* Mon Jun 22 2015 Mat Booth <mat.booth@redhat.com> - 2.3.5-6
|
||||||
|
- Remove SCL macros and tidy spec
|
||||||
|
|
||||||
|
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.5-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.5-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 21 2014 Alexander Kurtakov <akurtako@redhat.com> 2.3.5-3
|
||||||
|
- Remove useless parts.
|
||||||
|
- Require java-headless.
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed May 29 2013 Krzysztof Daniel <kdaniel@redhat.com> 2.3.5-1
|
||||||
|
- Update to latest upstream.
|
||||||
|
|
||||||
|
* Fri May 10 2013 Krzysztof Daniel <kdaniel@redhat.com> 2.3.4-1
|
||||||
|
- Update to latest upstream.
|
||||||
|
|
||||||
|
* Wed Apr 17 2013 Krzysztof Daniel <kdaniel@redhat.com> 2.3.3-7
|
||||||
|
- Remove jars from source.
|
||||||
|
|
||||||
|
* Fri Apr 5 2013 Krzysztof Daniel <kdaniel@redhat.com> 2.3.0-6
|
||||||
|
- Update to 2.3.3
|
||||||
|
- Initial sclization.
|
||||||
|
|
||||||
|
* Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-5
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.0-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 25 2011 Andrew Overholt <overholt@redhat.com> 2.3.0-2
|
||||||
|
- Make 1.5-level bytecode. This enables bootstrapping of Eclipse
|
||||||
|
with OpenJDK 7.
|
||||||
|
|
||||||
|
* Mon Apr 04 2011 Chris Aniszczyk <zx@redhat.com> 2.3.0-1
|
||||||
|
- Update to 2.3.0.
|
||||||
|
|
||||||
|
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 8 2010 Alexander Kurtakov <akurtako@redhat.com> 2.2.0-1
|
||||||
|
- Update to 2.2.0.
|
||||||
|
|
||||||
|
* Tue Mar 30 2010 Andrew Overholt <overholt@redhat.com> 2.1.1-3
|
||||||
|
- Fix license tag
|
||||||
|
|
||||||
|
* Fri Mar 26 2010 Alexander Kurtakov <akurtako@redhat.com> 2.1.1-2
|
||||||
|
- Switch to lzma tarball.
|
||||||
|
- Remove classpath in manifest.
|
||||||
|
|
||||||
|
* Sun Mar 7 2010 Alexander Kurtakov <akurtako@redhat.com> 2.1.1-1
|
||||||
|
- Update to 2.1.1.
|
||||||
|
|
||||||
|
* Tue Aug 4 2009 Alexander Kurtakov <akurtako@redhat.com> 2.1.0-1
|
||||||
|
- Update to 2.1.0 final.
|
||||||
|
|
||||||
|
* Wed Apr 8 2009 Alexander Kurtakov <akurtako@redhat.com> 2.1.0-0.1.rc2
|
||||||
|
- Update to 2.1.0.RC2.
|
||||||
|
|
||||||
|
* Thu Feb 26 2009 Alexander Kurtakov <akurtako@redhat.com> 2.0.3-1
|
||||||
|
- Update to 2.0.3.
|
||||||
|
|
||||||
|
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.0-8
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Aug 28 2008 Andrew Overholt <overholt@redhat.com> 2.0.0-7
|
||||||
|
- eclipse_base is now libdir/eclipse
|
||||||
|
|
||||||
|
* Tue Jul 15 2008 Andrew Overholt <overholt@redhat.com> 2.0.0-6
|
||||||
|
- Build with OpenJDK (java.util.Scanner)
|
||||||
|
|
||||||
|
* Tue Jul 15 2008 Andrew Overholt <overholt@redhat.com> 2.0.0-5
|
||||||
|
- Use sed instead of dos2unix
|
||||||
|
|
||||||
|
* Mon Jul 14 2008 Andrew Overholt <overholt@redhat.com> 2.0.0-4
|
||||||
|
- Remove jmock JARs
|
||||||
|
- Don't run tests as part of build
|
||||||
|
|
||||||
|
* Mon Jul 14 2008 Andrew Overholt <overholt@redhat.com> 2.0.0-3
|
||||||
|
- Remove Class-Path from pb MANIFEST.MF
|
||||||
|
|
||||||
|
* Mon Jul 14 2008 Andrew Overholt <overholt@redhat.com> 2.0.0-2
|
||||||
|
- Add eclipse-pde BR for pdebuild script
|
||||||
|
|
||||||
|
* Fri Jun 27 2008 Andrew Overholt <overholt@redhat.com> 2.0.0-1
|
||||||
|
- 2.0.0
|
||||||
|
- Run tests
|
||||||
|
|
||||||
|
* Thu Mar 13 2008 Andrew Overholt <overholt@redhat.com> 2.0-0.1.RC5
|
||||||
|
- Initial version
|
Loading…
Reference in New Issue
Block a user