Fix libnetconf, libnetapi and msrpc DSSETUP call
Do better release numbers for subpackages. Guenther
This commit is contained in:
parent
d1aeb1520f
commit
f4feb7336e
@ -18,3 +18,64 @@ index 6de3e65..000eef1 100644
|
||||
LDFLAGS=@PIE_LDFLAGS@ @LDFLAGS@
|
||||
DYNEXP=@DYNEXP@
|
||||
|
||||
commit d9f4060c660da0ad671e061b123df71d109d51b9
|
||||
Author: Günther Deschner <gd@samba.org>
|
||||
Date: Thu Mar 6 00:51:20 2008 +0100
|
||||
|
||||
Fix lp_load with an empty registry and "config backend = registry". Michael, please check.
|
||||
|
||||
Guenther
|
||||
|
||||
diff --git a/source/param/loadparm.c b/source/param/loadparm.c
|
||||
index 5651a43..25aa48b 100644
|
||||
--- a/source/param/loadparm.c
|
||||
+++ b/source/param/loadparm.c
|
||||
@@ -3404,6 +3404,13 @@ static bool process_registry_globals(bool (*pfunc)(const char *, const char *))
|
||||
}
|
||||
}
|
||||
|
||||
+ if (!libnet_conf_share_exists(conf_ctx, GLOBAL_NAME)) {
|
||||
+ /* nothing to read from the registry yet but make sure lp_load
|
||||
+ * doesn't return false */
|
||||
+ ret = true;
|
||||
+ goto done;
|
||||
+ }
|
||||
+
|
||||
werr = libnet_conf_get_share(mem_ctx, conf_ctx, GLOBAL_NAME,
|
||||
&num_params, ¶m_names, ¶m_values);
|
||||
if (!W_ERROR_IS_OK(werr)) {
|
||||
commit 1bbbebb7767b8a25532e8be3dbd274c211e34bbd
|
||||
Author: Günther Deschner <gd@samba.org>
|
||||
Date: Wed Mar 5 15:21:43 2008 +0100
|
||||
|
||||
Give a better error message why NetServerSetInfo() may fail in the gui.
|
||||
|
||||
Guenther
|
||||
|
||||
diff --git a/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c b/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c
|
||||
index 73b14d4..a3719c7 100644
|
||||
--- a/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c
|
||||
+++ b/source/lib/netapi/examples/netdomjoin-gui/netdomjoin-gui.c
|
||||
@@ -154,7 +154,7 @@ static void callback_apply_description_change(GtkWidget *widget,
|
||||
GTK_MESSAGE_ERROR,
|
||||
GTK_BUTTONS_OK,
|
||||
"Failed to change computer description: %s.",
|
||||
- libnetapi_errstr(status));
|
||||
+ libnetapi_get_error_string(state->ctx, status));
|
||||
g_signal_connect_swapped(dialog, "response",
|
||||
G_CALLBACK(gtk_widget_destroy),
|
||||
dialog);
|
||||
diff --git a/source/lib/netapi/serverinfo.c b/source/lib/netapi/serverinfo.c
|
||||
index 5451295..d30e7d9 100644
|
||||
--- a/source/lib/netapi/serverinfo.c
|
||||
+++ b/source/lib/netapi/serverinfo.c
|
||||
@@ -185,6 +185,9 @@ static WERROR NetServerSetInfoLocal_1005(struct libnetapi_ctx *ctx,
|
||||
}
|
||||
|
||||
if (!lp_config_backend_is_registry()) {
|
||||
+ libnetapi_set_error_string(ctx,
|
||||
+ "Configuration manipulation requested but not "
|
||||
+ "supported by backend");
|
||||
return WERR_NOT_SUPPORTED;
|
||||
}
|
||||
|
||||
|
33
samba-3.2.0pre2-msrpc.diff
Normal file
33
samba-3.2.0pre2-msrpc.diff
Normal file
@ -0,0 +1,33 @@
|
||||
commit 5eb7b7a9db4bda40660df5ab67bfea99e75716f9
|
||||
Author: Günther Deschner <gd@samba.org>
|
||||
Date: Thu Mar 6 20:44:28 2008 +0100
|
||||
|
||||
Fix _dssetup_DsRoleGetPrimaryDomainInformation().
|
||||
|
||||
Guenther
|
||||
|
||||
diff --git a/source/rpc_server/srv_dssetup_nt.c b/source/rpc_server/srv_dssetup_nt.c
|
||||
index ea535a3..2b18e6b 100644
|
||||
--- a/source/rpc_server/srv_dssetup_nt.c
|
||||
+++ b/source/rpc_server/srv_dssetup_nt.c
|
||||
@@ -35,7 +35,7 @@ static WERROR fill_dsrole_dominfo_basic(TALLOC_CTX *ctx,
|
||||
struct dssetup_DsRolePrimaryDomInfoBasic **info)
|
||||
{
|
||||
struct dssetup_DsRolePrimaryDomInfoBasic *basic = NULL;
|
||||
- fstring dnsdomain;
|
||||
+ char *dnsdomain = NULL;
|
||||
|
||||
DEBUG(10,("fill_dsrole_dominfo_basic: enter\n"));
|
||||
|
||||
@@ -71,7 +71,10 @@ static WERROR fill_dsrole_dominfo_basic(TALLOC_CTX *ctx,
|
||||
/* fill in some additional fields if we are a member of an AD domain */
|
||||
|
||||
if (lp_security() == SEC_ADS) {
|
||||
- fstrcpy(dnsdomain, lp_realm());
|
||||
+ dnsdomain = talloc_strdup(ctx, lp_realm());
|
||||
+ if (!dnsdomain) {
|
||||
+ return WERR_NOMEM;
|
||||
+ }
|
||||
strlower_m(dnsdomain);
|
||||
basic->dns_domain = dnsdomain;
|
||||
|
19
samba.spec
19
samba.spec
@ -1,3 +1,4 @@
|
||||
%define main_release 7
|
||||
%define samba_version 3.2.0pre2
|
||||
%define tdb_version 1.1.1
|
||||
%define talloc_version 1.2.0
|
||||
@ -6,7 +7,7 @@ Summary: The Samba Suite of programs
|
||||
Name: samba
|
||||
Epoch: 0
|
||||
Version: 3.2.0
|
||||
Release: 1.pre2.6%{?dist}
|
||||
Release: 1.pre2.%{main_release}%{?dist}
|
||||
License: GPLv3+ and LGPLv3+
|
||||
Group: System Environment/Daemons
|
||||
URL: http://www.samba.org/
|
||||
@ -49,6 +50,7 @@ patch202: samba-3.2.0pre1-buildfix.patch
|
||||
Patch203: samba-3.2.0pre2-build_fixes.patch
|
||||
Patch204: samba-3.2.0pre2-libnetapi_fix.diff
|
||||
Patch205: samba-3.2.0pre2-cifs_spnego.diff
|
||||
Patch206: samba-3.2.0pre2-msrpc.diff
|
||||
|
||||
Requires(pre): samba-common = %{epoch}:%{version}-%{release}
|
||||
Requires: pam >= 0:0.64
|
||||
@ -177,6 +179,7 @@ develop programs that link against the SMB client library in the Samba suite.
|
||||
Summary: The TDB library and tools
|
||||
Group: Applications/System
|
||||
Version: %{tdb_version}
|
||||
Release: %{main_release}%{?dist}
|
||||
|
||||
%description -n libtdb
|
||||
The TDB library from the Samba suite.
|
||||
@ -186,7 +189,8 @@ The TDB library from the Samba suite.
|
||||
Summary: The TDB tools
|
||||
Group: Applications/System
|
||||
Version: %{tdb_version}
|
||||
Requires: libtdb = %{epoch}:%{tdb_version}-%{release}
|
||||
Release: %{main_release}%{?dist}
|
||||
Requires: libtdb = %{epoch}:%{tdb_version}-%{main_release}%{?dist}
|
||||
|
||||
%description -n tdb-tools
|
||||
Some TDB tools from the Samba suite.
|
||||
@ -196,7 +200,8 @@ Some TDB tools from the Samba suite.
|
||||
Summary: Developer tools for the TDB library
|
||||
Group: Development
|
||||
Version: %{tdb_version}
|
||||
Requires: libtdb = %{epoch}:%{tdb_version}-%{release}
|
||||
Release: %{main_release}%{?dist}
|
||||
Requires: libtdb = %{epoch}:%{tdb_version}-%{main_release}%{?dist}
|
||||
|
||||
%description -n libtdb-devel
|
||||
The libtdb-devel package contains the header files and libraries needed to
|
||||
@ -207,6 +212,7 @@ develop programs that link against the TDB library in the Samba suite.
|
||||
Summary: The talloc library
|
||||
Group: Applications/System
|
||||
Version: %{talloc_version}
|
||||
Release: %{main_release}%{?dist}
|
||||
|
||||
%description -n libtalloc
|
||||
The talloc library from the Samba suite.
|
||||
@ -216,7 +222,8 @@ The talloc library from the Samba suite.
|
||||
Summary: Developer tools for the talloc library
|
||||
Group: Development
|
||||
Version: %{talloc_version}
|
||||
Requires: libtalloc = %{epoch}:%{talloc_version}-%{release}
|
||||
Release: %{main_release}%{?dist}
|
||||
Requires: libtalloc = %{epoch}:%{talloc_version}-%{main_release}%{?dist}
|
||||
|
||||
%description -n libtalloc-devel
|
||||
The libtalloc-devel package contains the header files and libraries needed to
|
||||
@ -253,6 +260,7 @@ cp %{SOURCE11} packaging/Fedora/
|
||||
%patch203 -p1 -b .build_fixes
|
||||
%patch204 -p1 -b .libnetapi
|
||||
%patch205 -p1 -b .cifs_spnego
|
||||
%patch206 -p1 -b .msrpc
|
||||
|
||||
mv source/VERSION source/VERSION.orig
|
||||
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{release}\"/' < source/VERSION.orig > source/VERSION
|
||||
@ -848,6 +856,9 @@ exit 0
|
||||
%{_datadir}/pixmaps/samba/logo-small.png
|
||||
|
||||
%changelog
|
||||
* Mon Mar 10 2008 Guenther Deschner <gdeschner@redhat.com> - 3.2.0-1.pre2.7
|
||||
- Fix libnetconf, libnetapi and msrpc DSSETUP call
|
||||
|
||||
* Thu Mar 06 2008 Guenther Deschner <gdeschner@redhat.com> - 3.2.0-1.pre2.6
|
||||
- Create separate packages for samba-winbind and samba-winbind-devel
|
||||
- Add cifs.spnego helper
|
||||
|
Loading…
Reference in New Issue
Block a user