Update to Samba 4.8.0rc3
Guenther
This commit is contained in:
parent
a48a559626
commit
dd569a8121
2
.gitignore
vendored
2
.gitignore
vendored
@ -115,3 +115,5 @@ samba-3.6.0pre1.tar.gz
|
|||||||
/samba-4.8.0rc1.tar.asc
|
/samba-4.8.0rc1.tar.asc
|
||||||
/samba-4.8.0rc2.tar.xz
|
/samba-4.8.0rc2.tar.xz
|
||||||
/samba-4.8.0rc2.tar.asc
|
/samba-4.8.0rc2.tar.asc
|
||||||
|
/samba-4.8.0rc3.tar.xz
|
||||||
|
/samba-4.8.0rc3.tar.asc
|
||||||
|
@ -1,92 +0,0 @@
|
|||||||
From 4954b3692d550d0bbc92e482060a023fd14b4e83 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?G=C3=BCnther=20Deschner?= <gd@samba.org>
|
|
||||||
Date: Mon, 15 Jan 2018 21:56:22 +0100
|
|
||||||
Subject: [PATCH] python: fix the build with python3.
|
|
||||||
|
|
||||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=13221
|
|
||||||
|
|
||||||
Guenther
|
|
||||||
|
|
||||||
Signed-off-by: Guenther Deschner <gd@samba.org>
|
|
||||||
---
|
|
||||||
python/samba/emulate/traffic_packets.py | 2 +-
|
|
||||||
python/samba/forest_update.py | 4 ++--
|
|
||||||
python/samba/tests/blackbox/traffic_summary.py | 2 +-
|
|
||||||
python/samba/tests/samba_tool/visualize.py | 6 +++---
|
|
||||||
4 files changed, 7 insertions(+), 7 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/python/samba/emulate/traffic_packets.py b/python/samba/emulate/traffic_packets.py
|
|
||||||
index 1df21f99a35..185d1d57476 100644
|
|
||||||
--- a/python/samba/emulate/traffic_packets.py
|
|
||||||
+++ b/python/samba/emulate/traffic_packets.py
|
|
||||||
@@ -84,7 +84,7 @@ name_formats = [
|
|
||||||
|
|
||||||
|
|
||||||
def warning(message):
|
|
||||||
- print "\033[37;41;1m" "Warning: %s" "\033[00m" % (message)
|
|
||||||
+ print("\033[37;41;1m" "Warning: %s" "\033[00m" % (message))
|
|
||||||
|
|
||||||
###############################################################################
|
|
||||||
#
|
|
||||||
diff --git a/python/samba/forest_update.py b/python/samba/forest_update.py
|
|
||||||
index 9f6ddf6aac2..ba6f859a943 100644
|
|
||||||
--- a/python/samba/forest_update.py
|
|
||||||
+++ b/python/samba/forest_update.py
|
|
||||||
@@ -300,8 +300,8 @@ objectClass: container
|
|
||||||
"SCHEMA_DN":
|
|
||||||
str(self.schema_dn)})
|
|
||||||
if self.verbose:
|
|
||||||
- print "UPDATE (LDIF) ------ OPERATION %d" % op
|
|
||||||
- print sub_ldif
|
|
||||||
+ print("UPDATE (LDIF) ------ OPERATION %d" % op)
|
|
||||||
+ print(sub_ldif)
|
|
||||||
|
|
||||||
self.samdb.modify_ldif(sub_ldif)
|
|
||||||
if self.add_update_container:
|
|
||||||
diff --git a/python/samba/tests/blackbox/traffic_summary.py b/python/samba/tests/blackbox/traffic_summary.py
|
|
||||||
index b2bbc2cb075..99fe6b84e94 100644
|
|
||||||
--- a/python/samba/tests/blackbox/traffic_summary.py
|
|
||||||
+++ b/python/samba/tests/blackbox/traffic_summary.py
|
|
||||||
@@ -59,7 +59,7 @@ class TrafficSummaryTests(BlackboxTestCase):
|
|
||||||
|
|
||||||
with temp_file(self.tempdir) as output:
|
|
||||||
command = "%s %s >%s" % (SCRIPT, INPUT, output)
|
|
||||||
- print command
|
|
||||||
+ print(command)
|
|
||||||
self.check_run(command)
|
|
||||||
expected = open(EXPECTED_FN).readlines()
|
|
||||||
actual = open(output).readlines()
|
|
||||||
diff --git a/python/samba/tests/samba_tool/visualize.py b/python/samba/tests/samba_tool/visualize.py
|
|
||||||
index 292d4961f45..c00c6ea63b0 100644
|
|
||||||
--- a/python/samba/tests/samba_tool/visualize.py
|
|
||||||
+++ b/python/samba/tests/samba_tool/visualize.py
|
|
||||||
@@ -284,7 +284,7 @@ class SambaToolVisualizeLdif(SambaToolCmdTest):
|
|
||||||
self.tempdir,
|
|
||||||
self.lp, tag='disconnected')
|
|
||||||
dburl = 'tdb://' + dbfile
|
|
||||||
- print dbfile
|
|
||||||
+ print(dbfile)
|
|
||||||
result, output, err = self.runsubcmd("visualize", "ntdsconn",
|
|
||||||
'-H', dburl,
|
|
||||||
'--color=no', '-S')
|
|
||||||
@@ -314,7 +314,7 @@ class SambaToolVisualizeLdif(SambaToolCmdTest):
|
|
||||||
'-o', '-')
|
|
||||||
self.assertCmdSuccess(result, dot, err)
|
|
||||||
self.remove_files(dbfile)
|
|
||||||
- print dot
|
|
||||||
+ print(dot)
|
|
||||||
|
|
||||||
self.assertStringsEqual(EXPECTED_DOT_NTDSCONN_DISCONNECTED, dot,
|
|
||||||
strip=True)
|
|
||||||
@@ -338,7 +338,7 @@ class SambaToolVisualizeLdif(SambaToolCmdTest):
|
|
||||||
self.assertStringsEqual(EXPECTED_DOT_NTDSCONN_DISCONNECTED, dot)
|
|
||||||
|
|
||||||
self.remove_files(dbfile, dot_file)
|
|
||||||
- print dot
|
|
||||||
+ print(dot)
|
|
||||||
|
|
||||||
EXPECTED_DOT_MULTISITE_NO_KEY = r"""/* generated by samba */
|
|
||||||
digraph A_samba_tool_production {
|
|
||||||
--
|
|
||||||
2.14.3
|
|
||||||
|
|
10
samba.spec
10
samba.spec
@ -6,7 +6,7 @@
|
|||||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||||
%bcond_without clustering
|
%bcond_without clustering
|
||||||
|
|
||||||
%define main_release 3
|
%define main_release 4
|
||||||
|
|
||||||
%define samba_version 4.8.0
|
%define samba_version 4.8.0
|
||||||
%define talloc_version 2.1.11
|
%define talloc_version 2.1.11
|
||||||
@ -14,7 +14,7 @@
|
|||||||
%define tevent_version 0.9.35
|
%define tevent_version 0.9.35
|
||||||
%define ldb_version 1.3.1
|
%define ldb_version 1.3.1
|
||||||
# This should be rc1 or nil
|
# This should be rc1 or nil
|
||||||
%define pre_release rc2
|
%define pre_release rc3
|
||||||
|
|
||||||
%if "x%{?pre_release}" != "x"
|
%if "x%{?pre_release}" != "x"
|
||||||
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
||||||
@ -89,7 +89,7 @@
|
|||||||
|
|
||||||
Name: samba
|
Name: samba
|
||||||
Version: %{samba_version}
|
Version: %{samba_version}
|
||||||
Release: %{samba_release}.1
|
Release: %{samba_release}
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
@ -123,7 +123,6 @@ Source200: README.dc
|
|||||||
Source201: README.downgrade
|
Source201: README.downgrade
|
||||||
|
|
||||||
Patch1: samba-4.7.0-support-krb5-1.16.patch
|
Patch1: samba-4.7.0-support-krb5-1.16.patch
|
||||||
Patch2: samba-4.8.0-python.patch
|
|
||||||
Patch3: samba-4.8.0-ceph.patch
|
Patch3: samba-4.8.0-ceph.patch
|
||||||
|
|
||||||
Requires(pre): /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/groupadd
|
||||||
@ -3555,6 +3554,9 @@ rm -rf %{buildroot}
|
|||||||
%endif # with_clustering_support
|
%endif # with_clustering_support
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 12 2018 Guenther Deschner <gdeschner@redhat.com> - 4.8.0rc3-4
|
||||||
|
- Update to Samba 4.8.0rc3
|
||||||
|
|
||||||
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2:4.8.0-0.3.rc2.1
|
* Fri Feb 09 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2:4.8.0-0.3.rc2.1
|
||||||
- Escape macros in %%changelog
|
- Escape macros in %%changelog
|
||||||
|
|
||||||
|
4
sources
4
sources
@ -1,2 +1,2 @@
|
|||||||
SHA512 (samba-4.8.0rc2.tar.xz) = 9060c3277ea987ce3915c27f2c892ab2fbf9c16bf1f0f13cc10b08d047e63e514940474d1e883d3fb26aeb58b913c69624cb0db92704277267292ea1726b289b
|
SHA512 (samba-4.8.0rc3.tar.xz) = 41c1e1d991316f6b8b53a94129554f7831259ce02cbd21f558d580e6565c4ff27bc63d580f9c58f452ceeb533f5c9e62ec8b194addd94a3190f3c617e456a99e
|
||||||
SHA512 (samba-4.8.0rc2.tar.asc) = 953661f79ef3e1bef275d73b049e179f931e9741481648a64b6cd6e506642ecc6bf09925ee9d6974ff0b65832172eca5d42962e2e42688efeed225d5ec5c3f8c
|
SHA512 (samba-4.8.0rc3.tar.asc) = c4b89b367438ba85e862881aafcbca263c56e6ef9055239c084b229f9092f99b465acbab928f8c3a1cb4aabef3070346dc59eda11b6769b7408c58508597d583
|
||||||
|
Loading…
Reference in New Issue
Block a user