Update to Samba 4.1.4.
This commit is contained in:
parent
35c4943392
commit
d0c765fb3e
1
.gitignore
vendored
1
.gitignore
vendored
@ -34,3 +34,4 @@ samba-3.6.0pre1.tar.gz
|
||||
/samba-4.1.1.tar.xz
|
||||
/samba-4.1.2.tar.xz
|
||||
/samba-4.1.3.tar.xz
|
||||
/samba-4.1.4.tar.xz
|
||||
|
@ -1,53 +0,0 @@
|
||||
From d161c173088ce82ea11a914ce62c5b77af9f4f9f Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?G=C3=BCnther=20Deschner?= <gd@samba.org>
|
||||
Date: Wed, 6 Nov 2013 18:21:32 +0100
|
||||
Subject: [PATCH] s3-libnetjoin: use upper-case realm when composing default
|
||||
upn.
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
In case we are about to generate a keytab during the join make sure the default
|
||||
upn we create is usable with kinit -k.
|
||||
|
||||
Guenther
|
||||
|
||||
Signed-off-by: Günther Deschner <gd@samba.org>
|
||||
---
|
||||
source3/libnet/libnet_join.c | 17 ++++++++++++++++-
|
||||
1 file changed, 16 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source3/libnet/libnet_join.c b/source3/libnet/libnet_join.c
|
||||
index 2dcb920..b84fcd6 100644
|
||||
--- a/source3/libnet/libnet_join.c
|
||||
+++ b/source3/libnet/libnet_join.c
|
||||
@@ -449,10 +449,25 @@ static ADS_STATUS libnet_join_set_machine_upn(TALLOC_CTX *mem_ctx,
|
||||
}
|
||||
|
||||
if (!r->in.upn) {
|
||||
+ char *realm = r->out.dns_domain_name;
|
||||
+
|
||||
+ /* in case we are about to generate a keytab during the join
|
||||
+ * make sure the default upn we create is usable with kinit -k.
|
||||
+ * gd */
|
||||
+
|
||||
+ if (USE_KERBEROS_KEYTAB) {
|
||||
+ realm = talloc_strdup_upper(mem_ctx,
|
||||
+ r->out.dns_domain_name);
|
||||
+ }
|
||||
+
|
||||
+ if (!realm) {
|
||||
+ return ADS_ERROR(LDAP_NO_MEMORY);
|
||||
+ }
|
||||
+
|
||||
r->in.upn = talloc_asprintf(mem_ctx,
|
||||
"host/%s@%s",
|
||||
r->in.machine_name,
|
||||
- r->out.dns_domain_name);
|
||||
+ realm);
|
||||
if (!r->in.upn) {
|
||||
return ADS_ERROR(LDAP_NO_MEMORY);
|
||||
}
|
||||
--
|
||||
1.8.3.1
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,37 +0,0 @@
|
||||
From 967f9bd1f8a147c4b89ada3b6c7e1ce064c511bc Mon Sep 17 00:00:00 2001
|
||||
From: Jan Brummer <jan.brummer@tabos.org>
|
||||
Date: Mon, 9 Dec 2013 15:22:29 +0100
|
||||
Subject: [PATCH] s3-winbindd: Fix DEBUG statement in winbind_msg_offline().
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Guenther
|
||||
|
||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=10285
|
||||
|
||||
Reviewed-by: Günther Deschner <gd@samba.org>
|
||||
Reviewed-by: Andreas Schneider <asn@samba.org>
|
||||
|
||||
Autobuild-User(master): Günther Deschner <gd@samba.org>
|
||||
Autobuild-Date(master): Mon Dec 9 17:28:37 CET 2013 on sn-devel-104
|
||||
---
|
||||
source3/winbindd/winbindd_dual.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source3/winbindd/winbindd_dual.c b/source3/winbindd/winbindd_dual.c
|
||||
index 972924c..64af571 100644
|
||||
--- a/source3/winbindd/winbindd_dual.c
|
||||
+++ b/source3/winbindd/winbindd_dual.c
|
||||
@@ -626,7 +626,7 @@ void winbind_msg_offline(struct messaging_context *msg_ctx,
|
||||
we only set it online / offline for that domain. */
|
||||
|
||||
DEBUG(10,("winbind_msg_offline: sending message to pid %u for domain %s.\n",
|
||||
- (unsigned int)child->pid, domain->name ));
|
||||
+ (unsigned int)child->pid, child->domain->name ));
|
||||
|
||||
messaging_send_buf(msg_ctx, pid_to_procid(child->pid),
|
||||
MSG_WINBIND_OFFLINE,
|
||||
--
|
||||
1.8.3.1
|
||||
|
15
samba.spec
15
samba.spec
@ -1,9 +1,9 @@
|
||||
# Set --with testsuite or %bcond_without to run the Samba torture testsuite.
|
||||
%bcond_with testsuite
|
||||
|
||||
%define main_release 3
|
||||
%define main_release 1
|
||||
|
||||
%define samba_version 4.1.3
|
||||
%define samba_version 4.1.4
|
||||
%define talloc_version 2.0.8
|
||||
%define ntdb_version 0.9
|
||||
%define tdb_version 1.2.12
|
||||
@ -85,10 +85,6 @@ Source6: samba.pamd
|
||||
Source200: README.dc
|
||||
Source201: README.downgrade
|
||||
|
||||
Patch0: samba-4.1.0-upn.patch
|
||||
Patch1: samba-4.1.2-doc.patch
|
||||
Patch2: samba-4.1.3-winbind_debug.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
Requires(pre): /usr/sbin/groupadd
|
||||
@ -489,10 +485,6 @@ module necessary to communicate to the Winbind Daemon
|
||||
%prep
|
||||
%setup -q -n samba-%{version}%{pre_release}
|
||||
|
||||
%patch0 -p1 -b .samba-4.1.0-upn.patch
|
||||
%patch1 -p1 -b .samba-4.1.2-doc.patch
|
||||
%patch2 -p1 -b .samba-4.1.3-winbind_debug.patch
|
||||
|
||||
%build
|
||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||
%global _tevent_lib ,tevent,pytevent
|
||||
@ -1544,6 +1536,9 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man8/pam_winbind.8*
|
||||
|
||||
%changelog
|
||||
* Fri Feb 07 2014 - Andreas Schneider <asn@redhat.com> - 4.1.4-1
|
||||
- Update to Samba 4.1.4.
|
||||
|
||||
* Wed Jan 08 2014 - Andreas Schneider <asn@redhat.com> - 4.1.3-3
|
||||
- resolves: #1042845 - Do not build with libbsd.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user