Update to version 4.2.0rc2.
This commit is contained in:
parent
19bf1f6445
commit
ba46be83c0
1
.gitignore
vendored
1
.gitignore
vendored
@ -42,3 +42,4 @@ samba-3.6.0pre1.tar.gz
|
|||||||
/samba-4.1.11.tar.gz
|
/samba-4.1.11.tar.gz
|
||||||
/samba-4.1.11.tar.xz
|
/samba-4.1.11.tar.xz
|
||||||
/samba-4.1.12.tar.xz
|
/samba-4.1.12.tar.xz
|
||||||
|
/samba-4.2.0rc2.tar.xz
|
||||||
|
@ -1,82 +0,0 @@
|
|||||||
commit 6b1091dcd9a32977542692e78cfa2c930a691404
|
|
||||||
Author: Jeremy Allison <jra@samba.org>
|
|
||||||
AuthorDate: Wed Jul 16 12:41:55 2014 -0700
|
|
||||||
Commit: Karolin Seeger <kseeger@samba.org>
|
|
||||||
CommitDate: Sat Sep 27 20:58:13 2014 +0200
|
|
||||||
|
|
||||||
s3: winbindd: Old NT Domain code sets struct winbind_domain->alt_name to be NULL. Ensure this is safe with modern AD-DCs.
|
|
||||||
|
|
||||||
There are places in the code where we're not checking that alt_name is NULL
|
|
||||||
and then calling into the DC lookup code with a NULL name request. This can
|
|
||||||
happen in offline mode.
|
|
||||||
|
|
||||||
Fixes bug #10717 - Winbind crash on losing VPN connection
|
|
||||||
|
|
||||||
https://bugzilla.samba.org/show_bug.cgi?id=10717
|
|
||||||
|
|
||||||
Signed-off-by: Jeremy Allison <jra@samba.org>
|
|
||||||
Reviewed-by: Michael Adam <obnox@samba.org>
|
|
||||||
|
|
||||||
Autobuild-User(master): Michael Adam <obnox@samba.org>
|
|
||||||
Autobuild-Date(master): Mon Sep 15 23:29:00 CEST 2014 on sn-devel-104
|
|
||||||
|
|
||||||
(cherry picked from commit 92da0b243c18546275c4736507188eba425a0732)
|
|
||||||
---
|
|
||||||
source3/winbindd/winbindd_ads.c | 3 ++-
|
|
||||||
source3/winbindd/winbindd_cm.c | 8 ++++++--
|
|
||||||
2 files changed, 8 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/source3/winbindd/winbindd_ads.c b/source3/winbindd/winbindd_ads.c
|
|
||||||
index e47613e..fb0bc26 100644
|
|
||||||
--- a/source3/winbindd/winbindd_ads.c
|
|
||||||
+++ b/source3/winbindd/winbindd_ads.c
|
|
||||||
@@ -169,6 +169,7 @@ ADS_STATUS ads_idmap_cached_connection(ADS_STRUCT **adsp, const char *dom_name)
|
|
||||||
}
|
|
||||||
|
|
||||||
if (IS_DC) {
|
|
||||||
+ SMB_ASSERT(wb_dom->alt_name != NULL);
|
|
||||||
realm = SMB_STRDUP(wb_dom->alt_name);
|
|
||||||
} else {
|
|
||||||
struct winbindd_domain *our_domain = wb_dom;
|
|
||||||
@@ -224,7 +225,7 @@ static ADS_STRUCT *ads_cached_connection(struct winbindd_domain *domain)
|
|
||||||
}
|
|
||||||
|
|
||||||
if ( IS_DC ) {
|
|
||||||
-
|
|
||||||
+ SMB_ASSERT(domain->alt_name != NULL);
|
|
||||||
realm = SMB_STRDUP(domain->alt_name);
|
|
||||||
}
|
|
||||||
else {
|
|
||||||
diff --git a/source3/winbindd/winbindd_cm.c b/source3/winbindd/winbindd_cm.c
|
|
||||||
index 61917db..8bbc886 100644
|
|
||||||
--- a/source3/winbindd/winbindd_cm.c
|
|
||||||
+++ b/source3/winbindd/winbindd_cm.c
|
|
||||||
@@ -833,6 +833,10 @@ static NTSTATUS get_trust_creds(const struct winbindd_domain *domain,
|
|
||||||
return NT_STATUS_CANT_ACCESS_DOMAIN_INFO;
|
|
||||||
}
|
|
||||||
|
|
||||||
+ if (our_domain->alt_name == NULL) {
|
|
||||||
+ return NT_STATUS_INVALID_PARAMETER;
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
if (asprintf(machine_krb5_principal, "%s$@%s",
|
|
||||||
account_name, our_domain->alt_name) == -1)
|
|
||||||
{
|
|
||||||
@@ -1199,7 +1203,7 @@ static bool dcip_to_name(TALLOC_CTX *mem_ctx,
|
|
||||||
/* For active directory servers, try to get the ldap server name.
|
|
||||||
None of these failures should be considered critical for now */
|
|
||||||
|
|
||||||
- if (lp_security() == SEC_ADS) {
|
|
||||||
+ if ((lp_security() == SEC_ADS) && (domain->alt_name != NULL)) {
|
|
||||||
ADS_STRUCT *ads;
|
|
||||||
ADS_STATUS ads_status;
|
|
||||||
char addr[INET6_ADDRSTRLEN];
|
|
||||||
@@ -1327,7 +1331,7 @@ static bool get_dcs(TALLOC_CTX *mem_ctx, struct winbindd_domain *domain,
|
|
||||||
return True;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (sec == SEC_ADS) {
|
|
||||||
+ if ((sec == SEC_ADS) && (domain->alt_name != NULL)) {
|
|
||||||
char *sitename = NULL;
|
|
||||||
|
|
||||||
/* We need to make sure we know the local site before
|
|
60
samba.spec
60
samba.spec
@ -6,16 +6,16 @@
|
|||||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||||
%bcond_without clustering
|
%bcond_without clustering
|
||||||
|
|
||||||
%define main_release 5
|
%define main_release 1
|
||||||
|
|
||||||
%define samba_version 4.1.12
|
%define samba_version 4.2.0
|
||||||
%define talloc_version 2.0.8
|
%define talloc_version 2.1.1
|
||||||
%define ntdb_version 0.9
|
%define ntdb_version 1.0
|
||||||
%define tdb_version 1.2.12
|
%define tdb_version 1.3.1
|
||||||
%define tevent_version 0.9.18
|
%define tevent_version 0.9.22
|
||||||
%define ldb_version 1.1.16
|
%define ldb_version 1.1.17
|
||||||
# This should be rc1 or nil
|
# This should be rc1 or nil
|
||||||
%define pre_release %nil
|
%define pre_release rc2
|
||||||
|
|
||||||
%if "x%{?pre_release}" != "x"
|
%if "x%{?pre_release}" != "x"
|
||||||
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
||||||
@ -94,8 +94,6 @@ Source6: samba.pamd
|
|||||||
Source200: README.dc
|
Source200: README.dc
|
||||||
Source201: README.downgrade
|
Source201: README.downgrade
|
||||||
|
|
||||||
Patch0: samba-4.1.13-fix_winbind_segfault.patch
|
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
Requires(pre): /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/groupadd
|
||||||
@ -127,7 +125,6 @@ BuildRequires: cups-devel
|
|||||||
BuildRequires: docbook-style-xsl
|
BuildRequires: docbook-style-xsl
|
||||||
BuildRequires: e2fsprogs-devel
|
BuildRequires: e2fsprogs-devel
|
||||||
BuildRequires: gawk
|
BuildRequires: gawk
|
||||||
BuildRequires: iniparser-devel
|
|
||||||
BuildRequires: krb5-devel >= 1.10
|
BuildRequires: krb5-devel >= 1.10
|
||||||
BuildRequires: libacl-devel
|
BuildRequires: libacl-devel
|
||||||
BuildRequires: libaio-devel
|
BuildRequires: libaio-devel
|
||||||
@ -515,8 +512,6 @@ module necessary to communicate to the Winbind Daemon
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n samba-%{version}%{pre_release}
|
%setup -q -n samba-%{version}%{pre_release}
|
||||||
|
|
||||||
%patch0 -p1 -b .samba-4.1.13-fix_winbind_segfault.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||||
%global _tevent_lib ,tevent,pytevent
|
%global _tevent_lib ,tevent,pytevent
|
||||||
@ -569,7 +564,6 @@ LDFLAGS="-Wl,-z,relro,-z,now" \
|
|||||||
--with-pammodulesdir=%{_libdir}/security \
|
--with-pammodulesdir=%{_libdir}/security \
|
||||||
--with-lockdir=/var/lib/samba \
|
--with-lockdir=/var/lib/samba \
|
||||||
--with-cachedir=/var/lib/samba \
|
--with-cachedir=/var/lib/samba \
|
||||||
--with-perl-lib-install-dir=%{perl_vendorlib} \
|
|
||||||
--disable-gnutls \
|
--disable-gnutls \
|
||||||
--disable-rpath-install \
|
--disable-rpath-install \
|
||||||
--with-shared-modules=%{_samba4_modules} \
|
--with-shared-modules=%{_samba4_modules} \
|
||||||
@ -776,6 +770,7 @@ rm -rf %{buildroot}
|
|||||||
%{_bindir}/eventlogadm
|
%{_bindir}/eventlogadm
|
||||||
%{_sbindir}/nmbd
|
%{_sbindir}/nmbd
|
||||||
%{_sbindir}/smbd
|
%{_sbindir}/smbd
|
||||||
|
%{_libdir}/samba/libsamba-cluster-support.so
|
||||||
%dir %{_libdir}/samba/auth
|
%dir %{_libdir}/samba/auth
|
||||||
%{_libdir}/samba/auth/script.so
|
%{_libdir}/samba/auth/script.so
|
||||||
%{_libdir}/samba/auth/unix.so
|
%{_libdir}/samba/auth/unix.so
|
||||||
@ -799,6 +794,7 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/samba/vfs/extd_audit.so
|
%{_libdir}/samba/vfs/extd_audit.so
|
||||||
%{_libdir}/samba/vfs/fake_perms.so
|
%{_libdir}/samba/vfs/fake_perms.so
|
||||||
%{_libdir}/samba/vfs/fileid.so
|
%{_libdir}/samba/vfs/fileid.so
|
||||||
|
%{_libdir}/samba/vfs/fruit.so
|
||||||
%{_libdir}/samba/vfs/full_audit.so
|
%{_libdir}/samba/vfs/full_audit.so
|
||||||
%{_libdir}/samba/vfs/linux_xfs_sgid.so
|
%{_libdir}/samba/vfs/linux_xfs_sgid.so
|
||||||
%{_libdir}/samba/vfs/media_harmony.so
|
%{_libdir}/samba/vfs/media_harmony.so
|
||||||
@ -815,6 +811,7 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/samba/vfs/streams_xattr.so
|
%{_libdir}/samba/vfs/streams_xattr.so
|
||||||
%{_libdir}/samba/vfs/syncops.so
|
%{_libdir}/samba/vfs/syncops.so
|
||||||
%{_libdir}/samba/vfs/time_audit.so
|
%{_libdir}/samba/vfs/time_audit.so
|
||||||
|
%{_libdir}/samba/vfs/worm.so
|
||||||
%{_libdir}/samba/vfs/xattr_tdb.so
|
%{_libdir}/samba/vfs/xattr_tdb.so
|
||||||
|
|
||||||
%{_unitdir}/nmb.service
|
%{_unitdir}/nmb.service
|
||||||
@ -844,6 +841,7 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man8/vfs_extd_audit.8*
|
%{_mandir}/man8/vfs_extd_audit.8*
|
||||||
%{_mandir}/man8/vfs_fake_perms.8*
|
%{_mandir}/man8/vfs_fake_perms.8*
|
||||||
%{_mandir}/man8/vfs_fileid.8*
|
%{_mandir}/man8/vfs_fileid.8*
|
||||||
|
%{_mandir}/man8/vfs_fruit.8*
|
||||||
%{_mandir}/man8/vfs_full_audit.8*
|
%{_mandir}/man8/vfs_full_audit.8*
|
||||||
%{_mandir}/man8/vfs_gpfs.8*
|
%{_mandir}/man8/vfs_gpfs.8*
|
||||||
%{_mandir}/man8/vfs_linux_xfs_sgid.8*
|
%{_mandir}/man8/vfs_linux_xfs_sgid.8*
|
||||||
@ -859,11 +857,13 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man8/vfs_shadow_copy.8*
|
%{_mandir}/man8/vfs_shadow_copy.8*
|
||||||
%{_mandir}/man8/vfs_shadow_copy2.8*
|
%{_mandir}/man8/vfs_shadow_copy2.8*
|
||||||
%{_mandir}/man8/vfs_smb_traffic_analyzer.8*
|
%{_mandir}/man8/vfs_smb_traffic_analyzer.8*
|
||||||
|
%{_mandir}/man8/vfs_snapper.8*
|
||||||
%{_mandir}/man8/vfs_streams_depot.8*
|
%{_mandir}/man8/vfs_streams_depot.8*
|
||||||
%{_mandir}/man8/vfs_streams_xattr.8*
|
%{_mandir}/man8/vfs_streams_xattr.8*
|
||||||
%{_mandir}/man8/vfs_syncops.8*
|
%{_mandir}/man8/vfs_syncops.8*
|
||||||
%{_mandir}/man8/vfs_time_audit.8*
|
%{_mandir}/man8/vfs_time_audit.8*
|
||||||
%{_mandir}/man8/vfs_tsmsm.8*
|
%{_mandir}/man8/vfs_tsmsm.8*
|
||||||
|
%{_mandir}/man8/vfs_worm.8*
|
||||||
%{_mandir}/man8/vfs_xattr_tdb.8*
|
%{_mandir}/man8/vfs_xattr_tdb.8*
|
||||||
|
|
||||||
### CLIENT
|
### CLIENT
|
||||||
@ -872,7 +872,6 @@ rm -rf %{buildroot}
|
|||||||
%{_bindir}/cifsdd
|
%{_bindir}/cifsdd
|
||||||
%{_bindir}/dbwrap_tool
|
%{_bindir}/dbwrap_tool
|
||||||
%{_bindir}/nmblookup
|
%{_bindir}/nmblookup
|
||||||
%{_bindir}/nmblookup4
|
|
||||||
%{_bindir}/oLschema2ldif
|
%{_bindir}/oLschema2ldif
|
||||||
%{_bindir}/regdiff
|
%{_bindir}/regdiff
|
||||||
%{_bindir}/regpatch
|
%{_bindir}/regpatch
|
||||||
@ -883,7 +882,6 @@ rm -rf %{buildroot}
|
|||||||
%{_bindir}/sharesec
|
%{_bindir}/sharesec
|
||||||
%{_bindir}/smbcacls
|
%{_bindir}/smbcacls
|
||||||
%{_bindir}/smbclient
|
%{_bindir}/smbclient
|
||||||
%{_bindir}/smbclient4
|
|
||||||
%{_bindir}/smbcquotas
|
%{_bindir}/smbcquotas
|
||||||
%{_bindir}/smbget
|
%{_bindir}/smbget
|
||||||
#%{_bindir}/smbiconv
|
#%{_bindir}/smbiconv
|
||||||
@ -902,7 +900,6 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man1/regtree.1*
|
%{_mandir}/man1/regtree.1*
|
||||||
%exclude %{_mandir}/man1/findsmb.1*
|
%exclude %{_mandir}/man1/findsmb.1*
|
||||||
%{_mandir}/man1/log2pcap.1*
|
%{_mandir}/man1/log2pcap.1*
|
||||||
%{_mandir}/man1/nmblookup4.1*
|
|
||||||
%{_mandir}/man1/rpcclient.1*
|
%{_mandir}/man1/rpcclient.1*
|
||||||
%{_mandir}/man1/sharesec.1*
|
%{_mandir}/man1/sharesec.1*
|
||||||
%{_mandir}/man1/smbcacls.1*
|
%{_mandir}/man1/smbcacls.1*
|
||||||
@ -919,6 +916,7 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man8/ntdbtool.8*
|
%{_mandir}/man8/ntdbtool.8*
|
||||||
%{_mandir}/man8/samba-regedit.8*
|
%{_mandir}/man8/samba-regedit.8*
|
||||||
%{_mandir}/man8/smbpasswd.8*
|
%{_mandir}/man8/smbpasswd.8*
|
||||||
|
%{_mandir}/man5/smbpasswd.5*
|
||||||
%{_mandir}/man8/smbspool.8*
|
%{_mandir}/man8/smbspool.8*
|
||||||
%{_mandir}/man8/smbta-util.8*
|
%{_mandir}/man8/smbta-util.8*
|
||||||
|
|
||||||
@ -948,7 +946,16 @@ rm -rf %{buildroot}
|
|||||||
%{_bindir}/ldbmodify
|
%{_bindir}/ldbmodify
|
||||||
%{_bindir}/ldbrename
|
%{_bindir}/ldbrename
|
||||||
%{_bindir}/ldbsearch
|
%{_bindir}/ldbsearch
|
||||||
%{_libdir}/samba/ldb/
|
%{_libdir}/samba/libldb-cmdline.so
|
||||||
|
%dir %{_libdir}/samba/ldb
|
||||||
|
%{_libdir}/samba/ldb/asq.so
|
||||||
|
%{_libdir}/samba/ldb/paged_results.so
|
||||||
|
%{_libdir}/samba/ldb/paged_searches.so
|
||||||
|
%{_libdir}/samba/ldb/rdn_name.so
|
||||||
|
%{_libdir}/samba/ldb/sample.so
|
||||||
|
%{_libdir}/samba/ldb/server_sort.so
|
||||||
|
%{_libdir}/samba/ldb/skel.so
|
||||||
|
%{_libdir}/samba/ldb/tdb.so
|
||||||
%{_mandir}/man1/ldbadd.1.gz
|
%{_mandir}/man1/ldbadd.1.gz
|
||||||
%{_mandir}/man1/ldbdel.1.gz
|
%{_mandir}/man1/ldbdel.1.gz
|
||||||
%{_mandir}/man1/ldbedit.1.gz
|
%{_mandir}/man1/ldbedit.1.gz
|
||||||
@ -984,7 +991,6 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man1/testparm.1*
|
%{_mandir}/man1/testparm.1*
|
||||||
%{_mandir}/man5/lmhosts.5*
|
%{_mandir}/man5/lmhosts.5*
|
||||||
%{_mandir}/man5/smb.conf.5*
|
%{_mandir}/man5/smb.conf.5*
|
||||||
%{_mandir}/man5/smbpasswd.5*
|
|
||||||
%{_mandir}/man7/samba.7*
|
%{_mandir}/man7/samba.7*
|
||||||
%{_mandir}/man8/net.8*
|
%{_mandir}/man8/net.8*
|
||||||
%{_mandir}/man8/pdbedit.8*
|
%{_mandir}/man8/pdbedit.8*
|
||||||
@ -1103,6 +1109,7 @@ rm -rf %{buildroot}
|
|||||||
%{_includedir}/samba-4.0/charset.h
|
%{_includedir}/samba-4.0/charset.h
|
||||||
%{_includedir}/samba-4.0/core/doserr.h
|
%{_includedir}/samba-4.0/core/doserr.h
|
||||||
%{_includedir}/samba-4.0/core/error.h
|
%{_includedir}/samba-4.0/core/error.h
|
||||||
|
%{_includedir}/samba-4.0/core/hresult.h
|
||||||
%{_includedir}/samba-4.0/core/ntstatus.h
|
%{_includedir}/samba-4.0/core/ntstatus.h
|
||||||
%{_includedir}/samba-4.0/core/werror.h
|
%{_includedir}/samba-4.0/core/werror.h
|
||||||
%{_includedir}/samba-4.0/credentials.h
|
%{_includedir}/samba-4.0/credentials.h
|
||||||
@ -1150,6 +1157,8 @@ rm -rf %{buildroot}
|
|||||||
%{_includedir}/samba-4.0/lookup_sid.h
|
%{_includedir}/samba-4.0/lookup_sid.h
|
||||||
%{_includedir}/samba-4.0/machine_sid.h
|
%{_includedir}/samba-4.0/machine_sid.h
|
||||||
%{_includedir}/samba-4.0/ndr.h
|
%{_includedir}/samba-4.0/ndr.h
|
||||||
|
%dir %{_includedir}/samba-4.0/ndr
|
||||||
|
%{_includedir}/samba-4.0/ndr/ndr_dcerpc.h
|
||||||
%{_includedir}/samba-4.0/ndr/ndr_drsblobs.h
|
%{_includedir}/samba-4.0/ndr/ndr_drsblobs.h
|
||||||
%{_includedir}/samba-4.0/ndr/ndr_drsuapi.h
|
%{_includedir}/samba-4.0/ndr/ndr_drsuapi.h
|
||||||
%{_includedir}/samba-4.0/ndr/ndr_svcctl.h
|
%{_includedir}/samba-4.0/ndr/ndr_svcctl.h
|
||||||
@ -1169,6 +1178,7 @@ rm -rf %{buildroot}
|
|||||||
%{_includedir}/samba-4.0/smb2_constants.h
|
%{_includedir}/samba-4.0/smb2_constants.h
|
||||||
%{_includedir}/samba-4.0/smb2_create_blob.h
|
%{_includedir}/samba-4.0/smb2_create_blob.h
|
||||||
%{_includedir}/samba-4.0/smb2_lease.h
|
%{_includedir}/samba-4.0/smb2_lease.h
|
||||||
|
%{_includedir}/samba-4.0/smb2_lease_struct.h
|
||||||
%{_includedir}/samba-4.0/smb2_signing.h
|
%{_includedir}/samba-4.0/smb2_signing.h
|
||||||
%{_includedir}/samba-4.0/smb_cli.h
|
%{_includedir}/samba-4.0/smb_cli.h
|
||||||
%{_includedir}/samba-4.0/smb_cliraw.h
|
%{_includedir}/samba-4.0/smb_cliraw.h
|
||||||
@ -1190,11 +1200,15 @@ rm -rf %{buildroot}
|
|||||||
%{_includedir}/samba-4.0/tdr.h
|
%{_includedir}/samba-4.0/tdr.h
|
||||||
%{_includedir}/samba-4.0/tsocket.h
|
%{_includedir}/samba-4.0/tsocket.h
|
||||||
%{_includedir}/samba-4.0/tsocket_internal.h
|
%{_includedir}/samba-4.0/tsocket_internal.h
|
||||||
|
%{_includedir}/samba-4.0/tstream_smbXcli_np.h
|
||||||
%{_includedir}/samba-4.0/samba_util.h
|
%{_includedir}/samba-4.0/samba_util.h
|
||||||
|
%dir %{_includedir}/samba-4.0/util
|
||||||
%{_includedir}/samba-4.0/util/attr.h
|
%{_includedir}/samba-4.0/util/attr.h
|
||||||
%{_includedir}/samba-4.0/util/byteorder.h
|
%{_includedir}/samba-4.0/util/byteorder.h
|
||||||
%{_includedir}/samba-4.0/util/data_blob.h
|
%{_includedir}/samba-4.0/util/data_blob.h
|
||||||
%{_includedir}/samba-4.0/util/debug.h
|
%{_includedir}/samba-4.0/util/debug.h
|
||||||
|
%{_includedir}/samba-4.0/util/idtree.h
|
||||||
|
%{_includedir}/samba-4.0/util/idtree_random.h
|
||||||
%{_includedir}/samba-4.0/util/memory.h
|
%{_includedir}/samba-4.0/util/memory.h
|
||||||
%{_includedir}/samba-4.0/util/safe_string.h
|
%{_includedir}/samba-4.0/util/safe_string.h
|
||||||
%{_includedir}/samba-4.0/util/string_wrappers.h
|
%{_includedir}/samba-4.0/util/string_wrappers.h
|
||||||
@ -1325,6 +1339,7 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/samba/libflag_mapping.so
|
%{_libdir}/samba/libflag_mapping.so
|
||||||
%{_libdir}/samba/libgpo.so
|
%{_libdir}/samba/libgpo.so
|
||||||
%{_libdir}/samba/libgse.so
|
%{_libdir}/samba/libgse.so
|
||||||
|
%{_libdir}/samba/libhttp.so
|
||||||
%{_libdir}/samba/libinterfaces.so
|
%{_libdir}/samba/libinterfaces.so
|
||||||
%{_libdir}/samba/libkrb5samba.so
|
%{_libdir}/samba/libkrb5samba.so
|
||||||
%{_libdir}/samba/libldbsamba.so
|
%{_libdir}/samba/libldbsamba.so
|
||||||
@ -1341,6 +1356,7 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/samba/libnpa_tstream.so
|
%{_libdir}/samba/libnpa_tstream.so
|
||||||
%{_libdir}/samba/libprinting_migrate.so
|
%{_libdir}/samba/libprinting_migrate.so
|
||||||
%{_libdir}/samba/libreplace.so
|
%{_libdir}/samba/libreplace.so
|
||||||
|
%{_libdir}/samba/libsamba-debug.so
|
||||||
%{_libdir}/samba/libsamba-modules.so
|
%{_libdir}/samba/libsamba-modules.so
|
||||||
%{_libdir}/samba/libsamba-net.so
|
%{_libdir}/samba/libsamba-net.so
|
||||||
%{_libdir}/samba/libsamba-security.so
|
%{_libdir}/samba/libsamba-security.so
|
||||||
@ -1357,6 +1373,7 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/samba/libsmbldaphelper.so
|
%{_libdir}/samba/libsmbldaphelper.so
|
||||||
%{_libdir}/samba/libsmbpasswdparser.so
|
%{_libdir}/samba/libsmbpasswdparser.so
|
||||||
%{_libdir}/samba/libsmbregistry.so
|
%{_libdir}/samba/libsmbregistry.so
|
||||||
|
%{_libdir}/samba/libsocket-blocking.so
|
||||||
%{_libdir}/samba/libtdb-wrap.so
|
%{_libdir}/samba/libtdb-wrap.so
|
||||||
%{_libdir}/samba/libtdb_compat.so
|
%{_libdir}/samba/libtdb_compat.so
|
||||||
%{_libdir}/samba/libtrusts_util.so
|
%{_libdir}/samba/libtrusts_util.so
|
||||||
@ -1413,7 +1430,7 @@ rm -rf %{buildroot}
|
|||||||
%{_libdir}/samba/libtdb.so.%{tdb_version}
|
%{_libdir}/samba/libtdb.so.%{tdb_version}
|
||||||
%endif
|
%endif
|
||||||
%if %{with_internal_ntdb}
|
%if %{with_internal_ntdb}
|
||||||
%{_libdir}/samba/libntdb.so.0
|
%{_libdir}/samba/libntdb.so.1
|
||||||
%{_libdir}/samba/libntdb.so.%{ntdb_version}
|
%{_libdir}/samba/libntdb.so.%{ntdb_version}
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
@ -1587,6 +1604,9 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man8/pam_winbind.8*
|
%{_mandir}/man8/pam_winbind.8*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Nov 12 2014 - Andreas Schneider <asn@redhat.com> - 4.2.0-0.1.rc2
|
||||||
|
- Update to Samba 4.2.0rc2.
|
||||||
|
|
||||||
* Tue Oct 07 2014 - Andreas Schneider <asn@redhat.com> - 4.1.12-5
|
* Tue Oct 07 2014 - Andreas Schneider <asn@redhat.com> - 4.1.12-5
|
||||||
- resolves: #1033595 - Fix segfault in winbind.
|
- resolves: #1033595 - Fix segfault in winbind.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user