Update to Samba 4.4.0rc1
Guenther
This commit is contained in:
parent
a3be00049b
commit
ad1a351b44
1
.gitignore
vendored
1
.gitignore
vendored
@ -57,3 +57,4 @@ samba-3.6.0pre1.tar.gz
|
||||
/samba-4.3.2.tar.xz
|
||||
/samba-4.3.3.tar.xz
|
||||
/samba-4.3.4.tar.xz
|
||||
/samba-4.4.0rc1.tar.xz
|
||||
|
@ -1,65 +0,0 @@
|
||||
From d8a03eeab8ece3d9001b087fc658272174f92a25 Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Bokovoy <ab@samba.org>
|
||||
Date: Fri, 22 Jan 2016 11:44:03 +0200
|
||||
Subject: [PATCH] s3-parm: clean up defaults when removing global parameters
|
||||
|
||||
When globals are re-initialized, they are cleared and globals' talloc
|
||||
context is freed. However, parm_table still contains a reference to the
|
||||
global value in the defaults. This confuses lpcfg_string_free() after
|
||||
commit 795c543d858b2452f062a02846c2f908fe4cffe4 because it tries to
|
||||
free already freed pointer which is passed by lp_save_defaults():
|
||||
|
||||
....
|
||||
case P_STRING:
|
||||
case P_USTRING:
|
||||
lpcfg_string_set(Globals.ctx,
|
||||
&parm_table[i].def.svalue,
|
||||
*(char **)lp_parm_ptr(NULL, &parm_table[i]));
|
||||
....
|
||||
|
||||
here &parm_table[i].def.svalue is passed to lpcfg_string_free() but it
|
||||
is a pointer to a value allocated with previous Globals.ctx which
|
||||
already was freed.
|
||||
|
||||
This specifically affects registry backend of smb.conf in lp_load_ex()
|
||||
where init_globals() called explicitly to re-init globals after
|
||||
lp_save_defaults() if we have registry backend defined.
|
||||
|
||||
Signed-off-by: Alexander Bokovoy <ab@samba.org>
|
||||
---
|
||||
source3/param/loadparm.c | 17 +++++++++++++++++
|
||||
1 file changed, 17 insertions(+)
|
||||
|
||||
diff --git a/source3/param/loadparm.c b/source3/param/loadparm.c
|
||||
index 9f4a2b4..f8ecab7 100644
|
||||
--- a/source3/param/loadparm.c
|
||||
+++ b/source3/param/loadparm.c
|
||||
@@ -399,8 +399,25 @@ static void free_parameters_by_snum(int snum)
|
||||
*/
|
||||
static void free_global_parameters(void)
|
||||
{
|
||||
+ uint32_t i;
|
||||
+ struct parm_struct *parm;
|
||||
+
|
||||
free_param_opts(&Globals.param_opt);
|
||||
free_parameters_by_snum(GLOBAL_SECTION_SNUM);
|
||||
+
|
||||
+ /* Reset references in the defaults because the context is going to be freed */
|
||||
+ for (i=0; parm_table[i].label; i++) {
|
||||
+ parm = &parm_table[i];
|
||||
+ if ((parm->type == P_STRING) ||
|
||||
+ (parm->type == P_USTRING)) {
|
||||
+ if ((parm->def.svalue != NULL) &&
|
||||
+ (*(parm->def.svalue) != '\0')) {
|
||||
+ if (talloc_parent(parm->def.svalue) == Globals.ctx) {
|
||||
+ parm->def.svalue = NULL;
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
+ }
|
||||
TALLOC_FREE(Globals.ctx);
|
||||
}
|
||||
|
||||
--
|
||||
2.5.0
|
||||
|
64
samba-4.4.0rc2-ctdb-pkgconfig.patch
Normal file
64
samba-4.4.0rc2-ctdb-pkgconfig.patch
Normal file
@ -0,0 +1,64 @@
|
||||
From 86f71108636b19e7a2c9052e73b3f2251a98bcc3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?G=C3=BCnther=20Deschner?= <gd@samba.org>
|
||||
Date: Wed, 27 Jan 2016 15:40:33 +0100
|
||||
Subject: [PATCH] ctdb: do not provide a useless pkgconfig file for ctdb.
|
||||
|
||||
We neither have public headers nor a public library.
|
||||
|
||||
Guenther
|
||||
|
||||
Signed-off-by: Guenther Deschner <gd@samba.org>
|
||||
---
|
||||
ctdb/ctdb.pc.in | 19 -------------------
|
||||
ctdb/wscript | 9 ---------
|
||||
2 files changed, 28 deletions(-)
|
||||
delete mode 100644 ctdb/ctdb.pc.in
|
||||
|
||||
diff --git a/ctdb/ctdb.pc.in b/ctdb/ctdb.pc.in
|
||||
deleted file mode 100644
|
||||
index 5f5bfab..0000000
|
||||
--- a/ctdb/ctdb.pc.in
|
||||
+++ /dev/null
|
||||
@@ -1,19 +0,0 @@
|
||||
-prefix=@prefix@
|
||||
-exec_prefix=@exec_prefix@
|
||||
-datarootdir=@datarootdir@
|
||||
-includedir=@includedir@
|
||||
-libdir=@libdir@
|
||||
-bindir=@bindir@
|
||||
-sbindir=@sbindir@
|
||||
-mandir=@mandir@
|
||||
-localstatedir=@localstatedir@
|
||||
-srcdir=@srcdir@
|
||||
-etcdir=@sysconfdir@
|
||||
-
|
||||
-Name: ctdb
|
||||
-Description: A clustered database to store temporary data
|
||||
-Version: @PACKAGE_VERSION@
|
||||
-Libs: -L${libdir}
|
||||
-Cflags: -I${includedir}
|
||||
-URL: http://ctdb.samba.org/
|
||||
-
|
||||
diff --git a/ctdb/wscript b/ctdb/wscript
|
||||
index edd4aa4..e1fad17 100755
|
||||
--- a/ctdb/wscript
|
||||
+++ b/ctdb/wscript
|
||||
@@ -615,15 +615,6 @@ def build(bld):
|
||||
bld.install_dir(bld.env.CTDB_RUNDIR)
|
||||
bld.install_dir(bld.env.CTDB_VARDIR)
|
||||
|
||||
- sed_expr = 's/@PACKAGE_VERSION@/%s/g' % VERSION
|
||||
- t = bld.SAMBA_GENERATOR('ctdb-pc',
|
||||
- source='ctdb.pc.in',
|
||||
- target='ctdb.pc',
|
||||
- rule='sed -e "%s" ${SRC} > ${TGT}' % sed_expr,
|
||||
- dep_vars=['VERSION'])
|
||||
- t.env.VERSION = VERSION
|
||||
- bld.INSTALL_FILES('${LIBDIR}/pkgconfig', 'ctdb.pc')
|
||||
-
|
||||
# Unit tests
|
||||
ctdb_unit_tests = [
|
||||
'db_hash_test',
|
||||
--
|
||||
2.5.0
|
||||
|
224
samba.spec
224
samba.spec
@ -6,15 +6,15 @@
|
||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||
%bcond_without clustering
|
||||
|
||||
%define main_release 1
|
||||
%define main_release 0
|
||||
|
||||
%define samba_version 4.3.4
|
||||
%define talloc_version 2.1.3
|
||||
%define tdb_version 1.3.7
|
||||
%define tevent_version 0.9.25
|
||||
%define ldb_version 1.1.24
|
||||
%define samba_version 4.4.0
|
||||
%define talloc_version 2.1.5
|
||||
%define tdb_version 1.3.8
|
||||
%define tevent_version 0.9.26
|
||||
%define ldb_version 1.1.25
|
||||
# This should be rc1 or nil
|
||||
%define pre_release %nil
|
||||
%define pre_release rc1
|
||||
|
||||
%if "x%{?pre_release}" != "x"
|
||||
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
||||
@ -29,7 +29,6 @@
|
||||
%global with_libsmbclient 1
|
||||
%global with_libwbclient 1
|
||||
|
||||
%global with_pam_smbpass 0
|
||||
%global with_internal_talloc 0
|
||||
%global with_internal_tevent 0
|
||||
%global with_internal_tdb 0
|
||||
@ -107,7 +106,7 @@ Source6: samba.pamd
|
||||
Source200: README.dc
|
||||
Source201: README.downgrade
|
||||
|
||||
Patch1: samba-4.3-s3-parm-clean-up-defaults-when-removing-global-param.patch
|
||||
Patch0: samba-4.4.0rc2-ctdb-pkgconfig.patch
|
||||
|
||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||
|
||||
@ -183,28 +182,28 @@ BuildRequires: gnutls-devel
|
||||
BuildRequires: perl(Parse::Yapp)
|
||||
|
||||
%if ! %with_internal_talloc
|
||||
%global libtalloc_version 2.1.3
|
||||
%global libtalloc_version 2.1.5
|
||||
|
||||
BuildRequires: libtalloc-devel >= %{libtalloc_version}
|
||||
BuildRequires: pytalloc-devel >= %{libtalloc_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_tevent
|
||||
%global libtevent_version 0.9.25
|
||||
%global libtevent_version 0.9.26
|
||||
|
||||
BuildRequires: libtevent-devel >= %{libtevent_version}
|
||||
BuildRequires: python-tevent >= %{libtevent_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_ldb
|
||||
%global libldb_version 1.1.24
|
||||
%global libldb_version 1.1.25
|
||||
|
||||
BuildRequires: libldb-devel >= %{libldb_version}
|
||||
BuildRequires: pyldb-devel >= %{libldb_version}
|
||||
%endif
|
||||
|
||||
%if ! %with_internal_tdb
|
||||
%global libtdb_version 1.3.7
|
||||
%global libtdb_version 1.3.8
|
||||
|
||||
BuildRequires: libtdb-devel >= %{libtdb_version}
|
||||
BuildRequires: python-tdb >= %{libtdb_version}
|
||||
@ -239,6 +238,9 @@ Requires: libsmbclient = %{samba_depver}
|
||||
Provides: samba4-client = %{samba_depver}
|
||||
Obsoletes: samba4-client < %{samba_depver}
|
||||
|
||||
Requires(post): %{_sbindir}/update-alternatives
|
||||
Requires(postun): %{_sbindir}/update-alternatives
|
||||
|
||||
%description client
|
||||
The %{name}-client package provides some SMB/CIFS clients to complement
|
||||
the built-in SMB/CIFS filesystem in Linux. These clients allow access
|
||||
@ -375,6 +377,20 @@ Provides: samba-glusterfs
|
||||
Samba VFS module for GlusterFS integration.
|
||||
%endif
|
||||
|
||||
### KRB5-PRINTING
|
||||
%package krb5-printing
|
||||
Summary: Samba CUPS backend for printing with Kerberos
|
||||
Group: Applications/System
|
||||
Requires(pre): %{name}-client
|
||||
|
||||
Requires(post): %{_sbindir}/update-alternatives
|
||||
Requires(postun): %{_sbindir}/update-alternatives
|
||||
|
||||
%description krb5-printing
|
||||
If you need Kerberos for print jobs to a printer connection to cups via the SMB
|
||||
backend, then you need to install that package. It will allow cups to access
|
||||
the Kerberos credentials cache of the user issuing the print job.
|
||||
|
||||
### LIBS
|
||||
%package libs
|
||||
Summary: Samba libraries
|
||||
@ -503,21 +519,11 @@ Summary: Libraries need by the testing tools for Samba servers and clients
|
||||
Group: Applications/System
|
||||
Requires: %{name}-client-libs = %{samba_depver}
|
||||
Requires: %{name}-libs = %{samba_depver}
|
||||
Obsoletes: %{name}-test-devel < %{samba_depver}
|
||||
|
||||
%description test-libs
|
||||
%{name}-test-libs provides libraries required by the testing tools.
|
||||
|
||||
### TEST-DEVEL
|
||||
%package test-devel
|
||||
Summary: Testing devel files for Samba servers and clients
|
||||
Group: Applications/System
|
||||
Requires: %{name}-libs = %{samba_depver}
|
||||
Requires: %{name}-test-libs = %{samba_depver}
|
||||
|
||||
%description test-devel
|
||||
samba-test-devel provides testing devel files for both the server and client
|
||||
packages of Samba.
|
||||
|
||||
### WINBIND
|
||||
%package winbind
|
||||
Summary: Samba winbind
|
||||
@ -635,21 +641,6 @@ projects to store temporary data. If an application is already using TDB for
|
||||
temporary data it is very easy to convert that application to be cluster aware
|
||||
and use CTDB instead.
|
||||
|
||||
### CTDB-DEVEL
|
||||
%package -n ctdb-devel
|
||||
Summary: CTDB clustered database development package
|
||||
Group: Development/Libraries
|
||||
|
||||
Requires: ctdb = %{samba_depver}
|
||||
Provides: ctdb-static = %{samba_depver}
|
||||
|
||||
%description -n ctdb-devel
|
||||
Libraries, include files, etc you can use to develop CTDB applications.
|
||||
CTDB is a cluster implementation of the TDB database used by Samba and other
|
||||
projects to store temporary data. If an application is already using TDB for
|
||||
temporary data it is very easy to convert that application to be cluster aware
|
||||
and use CTDB instead.
|
||||
|
||||
### CTDB-TEST
|
||||
%package -n ctdb-tests
|
||||
Summary: CTDB clustered database test suite
|
||||
@ -659,6 +650,7 @@ Requires: samba-client-libs = %{samba_depver}
|
||||
|
||||
Requires: ctdb = %{samba_depver}
|
||||
Requires: nc
|
||||
Obsoletes: ctdb-devel < %{samba_depver}
|
||||
|
||||
%description -n ctdb-tests
|
||||
Test suite for CTDB.
|
||||
@ -672,7 +664,8 @@ and use CTDB instead.
|
||||
|
||||
%prep
|
||||
%setup -q -n samba-%{version}%{pre_release}
|
||||
%patch1 -p1
|
||||
|
||||
%patch0 -p1 -b .samba-4.4.0rc2-ctdb-pkgconfig.patch
|
||||
|
||||
%build
|
||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||
@ -753,9 +746,6 @@ and use CTDB instead.
|
||||
%endif
|
||||
%if %{with testsuite}
|
||||
--enable-selftest \
|
||||
%endif
|
||||
%if ! %with_pam_smbpass
|
||||
--without-pam_smbpass \
|
||||
%endif
|
||||
--with-systemd
|
||||
|
||||
@ -789,6 +779,11 @@ then
|
||||
exit -1
|
||||
fi
|
||||
|
||||
|
||||
# Move smbspool_krb5_wrapper
|
||||
install -d -m 0755 %{buildroot}%{_libexecdir}/samba
|
||||
mv %{buildroot}%{_bindir}/smbspool_krb5_wrapper %{buildroot}%{_libexecdir}/samba
|
||||
|
||||
# Install other stuff
|
||||
install -d -m 0755 %{buildroot}%{_sysconfdir}/logrotate.d
|
||||
install -m 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/logrotate.d/samba
|
||||
@ -879,6 +874,20 @@ if [ -d /var/cache/samba ]; then
|
||||
ln -sf /var/cache/samba /var/lib/samba/
|
||||
fi
|
||||
|
||||
|
||||
### CLIENT
|
||||
%post client
|
||||
%{_sbindir}/update-alternatives --install %{_libexecdir}/samba/cups_backend_smb \
|
||||
cups_backend_smb \
|
||||
%{_bindir}/smbspool 10
|
||||
|
||||
%postun client
|
||||
if [ $1 -eq 0 ] ; then
|
||||
%{_sbindir}/update-alternatives --remove cups_backend_smb %{_libexecdir}/samba/smbspool
|
||||
fi
|
||||
|
||||
### COMMON
|
||||
|
||||
%postun common -p /sbin/ldconfig
|
||||
|
||||
%if %with_dc
|
||||
@ -887,6 +896,18 @@ fi
|
||||
%postun dc-libs -p /sbin/ldconfig
|
||||
%endif # with_dc
|
||||
|
||||
### KRB5-PRINTING
|
||||
%post krb5-printing
|
||||
%{_sbindir}/update-alternatives --install %{_libexecdir}/samba/cups_backend_smb \
|
||||
cups_backend_smb \
|
||||
%{_libexecdir}/samba/smbspool_krb5_wrapper 50
|
||||
|
||||
%postun krb5-printing
|
||||
if [ $1 -eq 0 ] ; then
|
||||
%{_sbindir}/update-alternatives --remove cups_backend_smb %{_libexecdir}/samba/smbspool_krb5_wrapper
|
||||
fi
|
||||
|
||||
### LIBS
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
%postun libs -p /sbin/ldconfig
|
||||
@ -1000,7 +1021,6 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/samba/vfs/acl_xattr.so
|
||||
%{_libdir}/samba/vfs/aio_fork.so
|
||||
%{_libdir}/samba/vfs/aio_linux.so
|
||||
%{_libdir}/samba/vfs/aio_posix.so
|
||||
%{_libdir}/samba/vfs/aio_pthread.so
|
||||
%{_libdir}/samba/vfs/audit.so
|
||||
%{_libdir}/samba/vfs/btrfs.so
|
||||
@ -1019,15 +1039,14 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/samba/vfs/linux_xfs_sgid.so
|
||||
%{_libdir}/samba/vfs/media_harmony.so
|
||||
%{_libdir}/samba/vfs/netatalk.so
|
||||
%{_libdir}/samba/vfs/offline.so
|
||||
%{_libdir}/samba/vfs/preopen.so
|
||||
%{_libdir}/samba/vfs/readahead.so
|
||||
%{_libdir}/samba/vfs/readonly.so
|
||||
%{_libdir}/samba/vfs/recycle.so
|
||||
%{_libdir}/samba/vfs/scannedonly.so
|
||||
%{_libdir}/samba/vfs/shadow_copy.so
|
||||
%{_libdir}/samba/vfs/shadow_copy2.so
|
||||
%{_libdir}/samba/vfs/shell_snap.so
|
||||
%{_libdir}/samba/vfs/smb_traffic_analyzer.so
|
||||
%{_libdir}/samba/vfs/snapper.so
|
||||
%{_libdir}/samba/vfs/streams_depot.so
|
||||
%{_libdir}/samba/vfs/streams_xattr.so
|
||||
@ -1071,16 +1090,15 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man8/vfs_linux_xfs_sgid.8*
|
||||
%{_mandir}/man8/vfs_media_harmony.8*
|
||||
%{_mandir}/man8/vfs_netatalk.8*
|
||||
%{_mandir}/man8/vfs_offline.8*
|
||||
%{_mandir}/man8/vfs_prealloc.8*
|
||||
%{_mandir}/man8/vfs_preopen.8*
|
||||
%{_mandir}/man8/vfs_readahead.8*
|
||||
%{_mandir}/man8/vfs_readonly.8*
|
||||
%{_mandir}/man8/vfs_recycle.8*
|
||||
%{_mandir}/man8/vfs_scannedonly.8*
|
||||
%{_mandir}/man8/vfs_shadow_copy.8*
|
||||
%{_mandir}/man8/vfs_shadow_copy2.8*
|
||||
%{_mandir}/man8/vfs_shell_snap.8*
|
||||
%{_mandir}/man8/vfs_smb_traffic_analyzer.8*
|
||||
%{_mandir}/man8/vfs_snapper.8*
|
||||
%{_mandir}/man8/vfs_streams_depot.8*
|
||||
%{_mandir}/man8/vfs_streams_xattr.8*
|
||||
@ -1120,9 +1138,10 @@ rm -rf %{buildroot}
|
||||
#%{_bindir}/smbiconv
|
||||
%{_bindir}/smbprint
|
||||
%{_bindir}/smbspool
|
||||
%{_bindir}/smbta-util
|
||||
%{_bindir}/smbtar
|
||||
%{_bindir}/smbtree
|
||||
%dir %{_libexecdir}/samba
|
||||
%ghost %{_libexecdir}/samba/cups_backend_smb
|
||||
%{_mandir}/man1/dbwrap_tool.1*
|
||||
%{_mandir}/man1/nmblookup.1*
|
||||
%{_mandir}/man1/oLschema2ldif.1*
|
||||
@ -1143,7 +1162,6 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man1/smbtree.1*
|
||||
%{_mandir}/man8/samba-regedit.8*
|
||||
%{_mandir}/man8/smbspool.8*
|
||||
%{_mandir}/man8/smbta-util.8*
|
||||
|
||||
%if %{with_internal_tdb}
|
||||
%{_bindir}/tdbbackup
|
||||
@ -1185,22 +1203,21 @@ rm -rf %{buildroot}
|
||||
%files client-libs
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libdcerpc-binding.so.*
|
||||
%{_libdir}/libgensec.so.*
|
||||
%{_libdir}/libndr.so.*
|
||||
%{_libdir}/libndr-krb5pac.so.*
|
||||
%{_libdir}/libndr-nbt.so.*
|
||||
%{_libdir}/libndr-standard.so.*
|
||||
%{_libdir}/libnetapi.so.*
|
||||
%{_libdir}/libsamba-credentials.so.*
|
||||
%{_libdir}/libsamba-errors.so.*
|
||||
%{_libdir}/libsamba-passdb.so.*
|
||||
%{_libdir}/libsamba-util.so.*
|
||||
%{_libdir}/libsamba-hostconfig.so.*
|
||||
%{_libdir}/libsamdb.so.*
|
||||
%{_libdir}/libsmbconf.so.*
|
||||
%{_libdir}/libsmbclient-raw.so.*
|
||||
%{_libdir}/libsmbldap.so.*
|
||||
%{_libdir}/libtevent-unix-util.so.*
|
||||
%{_libdir}/libtevent-util.so.*
|
||||
%{_libdir}/libregistry.so.*
|
||||
%{_libdir}/libdcerpc.so.*
|
||||
|
||||
%dir %{_libdir}/samba
|
||||
@ -1221,10 +1238,10 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/samba/libcmdline-credentials-samba4.so
|
||||
%{_libdir}/samba/libdbwrap-samba4.so
|
||||
%{_libdir}/samba/libdcerpc-samba-samba4.so
|
||||
%{_libdir}/samba/liberrors-samba4.so
|
||||
%{_libdir}/samba/libevents-samba4.so
|
||||
%{_libdir}/samba/libflag-mapping-samba4.so
|
||||
%{_libdir}/samba/libgenrand-samba4.so
|
||||
%{_libdir}/samba/libgensec-samba4.so
|
||||
%{_libdir}/samba/libgpo-samba4.so
|
||||
%{_libdir}/samba/libgse-samba4.so
|
||||
%{_libdir}/samba/libhttp-samba4.so
|
||||
@ -1246,6 +1263,7 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/samba/libnpa-tstream-samba4.so
|
||||
%{_libdir}/samba/libprinting-migrate-samba4.so
|
||||
%{_libdir}/samba/libreplace-samba4.so
|
||||
%{_libdir}/samba/libregistry-samba4.so
|
||||
%{_libdir}/samba/libsamba-cluster-support-samba4.so
|
||||
%{_libdir}/samba/libsamba-debug-samba4.so
|
||||
%{_libdir}/samba/libsamba-modules-samba4.so
|
||||
@ -1257,6 +1275,7 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/samba/libserver-id-db-samba4.so
|
||||
%{_libdir}/samba/libserver-role-samba4.so
|
||||
%{_libdir}/samba/libsmb-transport-samba4.so
|
||||
%{_libdir}/samba/libsmbclient-raw-samba4.so
|
||||
%{_libdir}/samba/libsmbd-base-samba4.so
|
||||
%{_libdir}/samba/libsmbd-conn-samba4.so
|
||||
%{_libdir}/samba/libsmbd-shim-samba4.so
|
||||
@ -1267,6 +1286,7 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/samba/libtalloc-report-samba4.so
|
||||
%{_libdir}/samba/libtdb-wrap-samba4.so
|
||||
%{_libdir}/samba/libtime-basic-samba4.so
|
||||
%{_libdir}/samba/libtorture-samba4.so
|
||||
%{_libdir}/samba/libtrusts-util-samba4.so
|
||||
%{_libdir}/samba/libutil-cmdline-samba4.so
|
||||
%{_libdir}/samba/libutil-reg-samba4.so
|
||||
@ -1340,10 +1360,6 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/samba/pdb/tdbsam.so
|
||||
%{_libdir}/samba/pdb/wbc_sam.so
|
||||
|
||||
%if %with_pam_smbpass
|
||||
%{_libdir}/security/pam_smbpass.so
|
||||
%endif
|
||||
|
||||
%files common-tools
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/net
|
||||
@ -1482,15 +1498,12 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/samba-4.0/core/werror.h
|
||||
%{_includedir}/samba-4.0/credentials.h
|
||||
%{_includedir}/samba-4.0/dcerpc.h
|
||||
%{_includedir}/samba-4.0/dlinklist.h
|
||||
%{_includedir}/samba-4.0/domain_credentials.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/atsvc.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/auth.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/dcerpc.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/epmapper.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/krb5pac.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/lsa.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/mgmt.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/misc.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/nbt.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/drsblobs.h
|
||||
@ -1498,13 +1511,8 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_drsblobs.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_drsuapi.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_atsvc.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_atsvc_c.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_dcerpc.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_epmapper.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_epmapper_c.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_krb5pac.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_mgmt.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_mgmt_c.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_misc.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_nbt.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/ndr_samr.h
|
||||
@ -1516,11 +1524,6 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/samba-4.0/gen_ndr/security.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/server_id.h
|
||||
%{_includedir}/samba-4.0/gen_ndr/svcctl.h
|
||||
%{_includedir}/samba-4.0/gensec.h
|
||||
%{_includedir}/samba-4.0/ldap-util.h
|
||||
%{_includedir}/samba-4.0/ldap_errors.h
|
||||
%{_includedir}/samba-4.0/ldap_message.h
|
||||
%{_includedir}/samba-4.0/ldap_ndr.h
|
||||
%{_includedir}/samba-4.0/ldb_wrap.h
|
||||
%{_includedir}/samba-4.0/lookup_sid.h
|
||||
%{_includedir}/samba-4.0/machine_sid.h
|
||||
@ -1535,41 +1538,17 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/samba-4.0/param.h
|
||||
%{_includedir}/samba-4.0/passdb.h
|
||||
%{_includedir}/samba-4.0/policy.h
|
||||
%{_includedir}/samba-4.0/read_smb.h
|
||||
%{_includedir}/samba-4.0/registry.h
|
||||
%{_includedir}/samba-4.0/roles.h
|
||||
%{_includedir}/samba-4.0/rpc_common.h
|
||||
%{_includedir}/samba-4.0/samba/session.h
|
||||
%{_includedir}/samba-4.0/samba/version.h
|
||||
%{_includedir}/samba-4.0/share.h
|
||||
%{_includedir}/samba-4.0/smb2.h
|
||||
%{_includedir}/samba-4.0/smb2_constants.h
|
||||
%{_includedir}/samba-4.0/smb2_create_blob.h
|
||||
%{_includedir}/samba-4.0/smb2_lease.h
|
||||
%{_includedir}/samba-4.0/smb2_lease_struct.h
|
||||
%{_includedir}/samba-4.0/smb2_signing.h
|
||||
%{_includedir}/samba-4.0/smb_cli.h
|
||||
%{_includedir}/samba-4.0/smb_cliraw.h
|
||||
%{_includedir}/samba-4.0/smb_common.h
|
||||
%{_includedir}/samba-4.0/smb_composite.h
|
||||
%{_includedir}/samba-4.0/smbconf.h
|
||||
%{_includedir}/samba-4.0/smb_constants.h
|
||||
%{_includedir}/samba-4.0/smb_ldap.h
|
||||
%{_includedir}/samba-4.0/smbldap.h
|
||||
%{_includedir}/samba-4.0/smb_raw.h
|
||||
%{_includedir}/samba-4.0/smb_raw_interfaces.h
|
||||
%{_includedir}/samba-4.0/smb_raw_signing.h
|
||||
%{_includedir}/samba-4.0/smb_raw_trans2.h
|
||||
%{_includedir}/samba-4.0/smb_request.h
|
||||
%{_includedir}/samba-4.0/smb_seal.h
|
||||
%{_includedir}/samba-4.0/smb_signing.h
|
||||
%{_includedir}/samba-4.0/smb_unix_ext.h
|
||||
%{_includedir}/samba-4.0/smb_util.h
|
||||
%{_includedir}/samba-4.0/tdr.h
|
||||
%{_includedir}/samba-4.0/tsocket.h
|
||||
%{_includedir}/samba-4.0/tsocket_internal.h
|
||||
%{_includedir}/samba-4.0/tstream_smbXcli_np.h
|
||||
%{_includedir}/samba-4.0/samba_util.h
|
||||
%dir %{_includedir}/samba-4.0/util
|
||||
%{_includedir}/samba-4.0/util/attr.h
|
||||
%{_includedir}/samba-4.0/util/blocking.h
|
||||
@ -1592,41 +1571,35 @@ rm -rf %{buildroot}
|
||||
%{_includedir}/samba-4.0/util/time.h
|
||||
%{_includedir}/samba-4.0/util/xfile.h
|
||||
%{_includedir}/samba-4.0/util_ldb.h
|
||||
%{_libdir}/libdcerpc-atsvc.so
|
||||
%{_libdir}/libdcerpc-binding.so
|
||||
%{_libdir}/libdcerpc-samr.so
|
||||
%{_libdir}/libdcerpc.so
|
||||
%{_libdir}/libgensec.so
|
||||
%{_libdir}/libndr-krb5pac.so
|
||||
%{_libdir}/libndr-nbt.so
|
||||
%{_libdir}/libndr-standard.so
|
||||
%{_libdir}/libndr.so
|
||||
%{_libdir}/libnetapi.so
|
||||
%{_libdir}/libregistry.so
|
||||
%{_libdir}/libsamba-credentials.so
|
||||
%{_libdir}/libsamba-errors.so
|
||||
%{_libdir}/libsamba-hostconfig.so
|
||||
%{_libdir}/libsamba-policy.so
|
||||
%{_libdir}/libsamba-util.so
|
||||
%{_libdir}/libsamdb.so
|
||||
%{_libdir}/libsmbclient-raw.so
|
||||
%{_libdir}/libsmbconf.so
|
||||
%{_libdir}/libtevent-unix-util.so
|
||||
%{_libdir}/libtevent-util.so
|
||||
%{_libdir}/pkgconfig/dcerpc.pc
|
||||
%{_libdir}/pkgconfig/dcerpc_atsvc.pc
|
||||
%{_libdir}/pkgconfig/dcerpc_samr.pc
|
||||
%{_libdir}/pkgconfig/gensec.pc
|
||||
%{_libdir}/pkgconfig/ndr.pc
|
||||
%{_libdir}/pkgconfig/ndr_krb5pac.pc
|
||||
%{_libdir}/pkgconfig/ndr_nbt.pc
|
||||
%{_libdir}/pkgconfig/ndr_standard.pc
|
||||
%{_libdir}/pkgconfig/netapi.pc
|
||||
%{_libdir}/pkgconfig/registry.pc
|
||||
%{_libdir}/pkgconfig/samba-credentials.pc
|
||||
%{_libdir}/pkgconfig/samba-hostconfig.pc
|
||||
%{_libdir}/pkgconfig/samba-policy.pc
|
||||
%{_libdir}/pkgconfig/samba-util.pc
|
||||
%{_libdir}/pkgconfig/samdb.pc
|
||||
%{_libdir}/pkgconfig/smbclient-raw.pc
|
||||
%{_libdir}/libsamba-passdb.so
|
||||
%{_libdir}/libsmbldap.so
|
||||
|
||||
@ -1662,10 +1635,14 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man8/vfs_glusterfs.8*
|
||||
%endif
|
||||
|
||||
### KRB5-PRINTING
|
||||
%files krb5-printing
|
||||
%defattr(-,root,root)
|
||||
%attr(0700,root,root) %{_libexecdir}/samba/smbspool_krb5_wrapper
|
||||
|
||||
### LIBS
|
||||
%files libs
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libdcerpc-atsvc.so.*
|
||||
%{_libdir}/libdcerpc-samr.so.*
|
||||
%{_libdir}/libsamba-policy.so.*
|
||||
|
||||
@ -1805,20 +1782,12 @@ rm -rf %{buildroot}
|
||||
### TEST-LIBS
|
||||
%files test-libs
|
||||
%defattr(-,root,root)
|
||||
%{_libdir}/libtorture.so.*
|
||||
%if %with_dc
|
||||
%{_libdir}/samba/libdlz-bind9-for-torture-samba4.so
|
||||
%else
|
||||
%{_libdir}/samba/libdsdb-module-samba4.so
|
||||
%endif
|
||||
|
||||
### TEST-DEVEL
|
||||
%files test-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/samba-4.0/torture.h
|
||||
%{_libdir}/libtorture.so
|
||||
%{_libdir}/pkgconfig/torture.pc
|
||||
|
||||
### WINBIND
|
||||
%files winbind
|
||||
%defattr(-,root,root)
|
||||
@ -1890,6 +1859,7 @@ rm -rf %{buildroot}
|
||||
%dir %{_sysconfdir}/ctdb/events.d
|
||||
%{_sysconfdir}/ctdb/events.d/00.ctdb
|
||||
%{_sysconfdir}/ctdb/events.d/01.reclock
|
||||
%{_sysconfdir}/ctdb/events.d/05.system
|
||||
%{_sysconfdir}/ctdb/events.d/10.external
|
||||
%{_sysconfdir}/ctdb/events.d/10.interface
|
||||
%{_sysconfdir}/ctdb/events.d/11.natgw
|
||||
@ -1897,13 +1867,11 @@ rm -rf %{buildroot}
|
||||
%{_sysconfdir}/ctdb/events.d/13.per_ip_routing
|
||||
%{_sysconfdir}/ctdb/events.d/20.multipathd
|
||||
%{_sysconfdir}/ctdb/events.d/31.clamd
|
||||
%{_sysconfdir}/ctdb/events.d/40.fs_use
|
||||
%{_sysconfdir}/ctdb/events.d/40.vsftpd
|
||||
%{_sysconfdir}/ctdb/events.d/41.httpd
|
||||
%{_sysconfdir}/ctdb/events.d/49.winbind
|
||||
%{_sysconfdir}/ctdb/events.d/50.samba
|
||||
%{_sysconfdir}/ctdb/events.d/60.nfs
|
||||
%{_sysconfdir}/ctdb/events.d/62.cnfs
|
||||
%{_sysconfdir}/ctdb/events.d/70.iscsi
|
||||
%{_sysconfdir}/ctdb/events.d/91.lvs
|
||||
%{_sysconfdir}/ctdb/events.d/99.timeout
|
||||
@ -1914,6 +1882,8 @@ rm -rf %{buildroot}
|
||||
%{_sbindir}/ctdbd
|
||||
%{_sbindir}/ctdbd_wrapper
|
||||
%{_bindir}/ctdb
|
||||
%{_bindir}/ctdb_natgw
|
||||
%{_bindir}/ctdb_recovery_helper
|
||||
%{_bindir}/smnotify
|
||||
%{_bindir}/ping_pong
|
||||
%{_bindir}/ltdbtool
|
||||
@ -1933,19 +1903,12 @@ rm -rf %{buildroot}
|
||||
%{_mandir}/man7/ctdb-tunables.7.gz
|
||||
%{_mandir}/man7/ctdb-statistics.7.gz
|
||||
|
||||
%files -n ctdb-devel
|
||||
%defattr(-,root,root)
|
||||
%{_includedir}/samba-4.0/ctdb.h
|
||||
%{_includedir}/samba-4.0/ctdb_client.h
|
||||
%{_includedir}/samba-4.0/ctdb_protocol.h
|
||||
%{_includedir}/samba-4.0/ctdb_private.h
|
||||
%{_includedir}/samba-4.0/ctdb_typesafe_cb.h
|
||||
%{_includedir}/samba-4.0/ctdb_version.h
|
||||
%{_libdir}/pkgconfig/ctdb.pc
|
||||
|
||||
%files -n ctdb-tests
|
||||
%defattr(-,root,root)
|
||||
%dir %{_libdir}/ctdb-tests
|
||||
%{_libdir}/ctdb-tests/comm_client_test
|
||||
%{_libdir}/ctdb-tests/comm_server_test
|
||||
%{_libdir}/ctdb-tests/comm_test
|
||||
%{_libdir}/ctdb-tests/ctdb_bench
|
||||
%{_libdir}/ctdb-tests/ctdb_fetch
|
||||
%{_libdir}/ctdb-tests/ctdb_fetch_one
|
||||
@ -1964,7 +1927,14 @@ rm -rf %{buildroot}
|
||||
%{_libdir}/ctdb-tests/ctdb_traverse
|
||||
%{_libdir}/ctdb-tests/ctdb_update_record
|
||||
%{_libdir}/ctdb-tests/ctdb_update_record_persistent
|
||||
%{_libdir}/ctdb-tests/db_hash_test
|
||||
%{_libdir}/ctdb-tests/pkt_read_test
|
||||
%{_libdir}/ctdb-tests/pkt_write_test
|
||||
%{_libdir}/ctdb-tests/protocol_client_test
|
||||
%{_libdir}/ctdb-tests/protocol_types_test
|
||||
%{_libdir}/ctdb-tests/rb_test
|
||||
%{_libdir}/ctdb-tests/reqid_test
|
||||
%{_libdir}/ctdb-tests/srvid_test
|
||||
%{_bindir}/ctdb_run_tests
|
||||
%{_bindir}/ctdb_run_cluster_tests
|
||||
%dir %{_datadir}/ctdb-tests
|
||||
@ -1973,14 +1943,20 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/nfs-checks.d
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/nfs-linux-kernel-callout
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/statd-callout
|
||||
%{_datadir}/ctdb-tests/onnode/functions
|
||||
%{_datadir}/ctdb-tests/scripts/common.sh
|
||||
%{_datadir}/ctdb-tests/scripts/integration.bash
|
||||
%{_datadir}/ctdb-tests/scripts/test_wrap
|
||||
%{_datadir}/ctdb-tests/scripts/unit.sh
|
||||
%{_datadir}/ctdb-tests/simple/functions
|
||||
%{_datadir}/ctdb-tests/simple/nodes
|
||||
%doc ctdb/tests/README
|
||||
%endif # with_clustering_support
|
||||
|
||||
%changelog
|
||||
* Wed Jan 27 2016 Guenther Deschner <gdeschner@redhat.com> - 4.4.0rc1-0
|
||||
- Update to Samba 4.4.0rc1
|
||||
|
||||
* Fri Jan 22 2016 Alexander Bokovoy <abokovoy@redhat.com> - 4.3.4-1
|
||||
- resolves: #1300038 - PANIC: Bad talloc magic value - wrong talloc version used/mixed
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user