Update to 3.4.1
Guenther
This commit is contained in:
parent
6567f971a7
commit
a8896ac530
@ -1 +1 @@
|
|||||||
samba-3.4.0.tar.gz
|
samba-3.4.1.tar.gz
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
From 94565270786003d6fb97ec7289b904948db281cd Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jeremy Allison <jra@samba.org>
|
|
||||||
Date: Wed, 15 Jul 2009 14:00:41 -0700
|
|
||||||
Subject: [PATCH] Fix bug #6551 - win98 clients cannot connect after server upgrade to samba-3.4.0.
|
|
||||||
The values of vuid and tid were not being correctly updated in the struct smb_request
|
|
||||||
when passed to chain_reply inside sessionsetupX and tconX.
|
|
||||||
Jeremy.
|
|
||||||
|
|
||||||
---
|
|
||||||
source3/smbd/reply.c | 2 ++
|
|
||||||
source3/smbd/sesssetup.c | 1 +
|
|
||||||
2 files changed, 3 insertions(+), 0 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/source3/smbd/reply.c b/source3/smbd/reply.c
|
|
||||||
index 6fe4f88..f76ab6d 100644
|
|
||||||
--- a/source3/smbd/reply.c
|
|
||||||
+++ b/source3/smbd/reply.c
|
|
||||||
@@ -759,6 +759,7 @@ void reply_tcon_and_X(struct smb_request *req)
|
|
||||||
|
|
||||||
END_PROFILE(SMBtconX);
|
|
||||||
|
|
||||||
+ req->tid = conn->cnum;
|
|
||||||
chain_reply(req);
|
|
||||||
return;
|
|
||||||
}
|
|
||||||
@@ -1924,6 +1925,7 @@ void reply_ulogoffX(struct smb_request *req)
|
|
||||||
DEBUG( 3, ( "ulogoffX vuid=%d\n", req->vuid ) );
|
|
||||||
|
|
||||||
END_PROFILE(SMBulogoffX);
|
|
||||||
+ req->vuid = UID_FIELD_INVALID;
|
|
||||||
chain_reply(req);
|
|
||||||
}
|
|
||||||
|
|
||||||
diff --git a/source3/smbd/sesssetup.c b/source3/smbd/sesssetup.c
|
|
||||||
index 2c92c41..044e398 100644
|
|
||||||
--- a/source3/smbd/sesssetup.c
|
|
||||||
+++ b/source3/smbd/sesssetup.c
|
|
||||||
@@ -1805,6 +1805,7 @@ void reply_sesssetup_and_X(struct smb_request *req)
|
|
||||||
|
|
||||||
SSVAL(req->outbuf,smb_uid,sess_vuid);
|
|
||||||
SSVAL(req->inbuf,smb_uid,sess_vuid);
|
|
||||||
+ req->vuid = sess_vuid;
|
|
||||||
|
|
||||||
if (!done_sesssetup)
|
|
||||||
max_send = MIN(max_send,smb_bufsize);
|
|
||||||
--
|
|
||||||
1.5.4.3
|
|
||||||
|
|
@ -1,74 +0,0 @@
|
|||||||
commit 3b0bd19570894e5219878102a2564a08095f26cd
|
|
||||||
Author: Jelmer Vernooij <jelmer@samba.org>
|
|
||||||
AuthorDate: Thu Jun 11 04:57:58 2009 +0200
|
|
||||||
Commit: Günther Deschner <gd@samba.org>
|
|
||||||
CommitDate: Tue Jul 14 23:51:24 2009 +0200
|
|
||||||
|
|
||||||
Fix build with external talloc.
|
|
||||||
---
|
|
||||||
source3/configure.in | 29 +++++++++++++++++++++++++++--
|
|
||||||
source3/samba4.m4 | 4 ++++
|
|
||||||
2 files changed, 31 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/source3/configure.in b/source3/configure.in
|
|
||||||
index 111e89d..fc41b35 100644
|
|
||||||
--- a/source3/configure.in
|
|
||||||
+++ b/source3/configure.in
|
|
||||||
@@ -77,7 +77,6 @@ done
|
|
||||||
AC_SUBST(LIBTDB_OBJ0)
|
|
||||||
SAMBA_CPPFLAGS="-Iinclude -I${srcdir-.}/include -I. -I${srcdir-.}"
|
|
||||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/../lib/replace"
|
|
||||||
-SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TALLOC_CFLAGS}"
|
|
||||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TEVENT_CFLAGS}"
|
|
||||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TDB_CFLAGS}"
|
|
||||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/libaddns"
|
|
||||||
@@ -4748,7 +4747,33 @@ LINK_LIBSMBCLIENT=STATIC
|
|
||||||
# TODO: for talloc and tdb (at least), these should
|
|
||||||
# be extracted from their respective source directories
|
|
||||||
#
|
|
||||||
-SMB_LIBRARY(talloc, 1)
|
|
||||||
+AC_ARG_ENABLE(external_libtalloc, [AS_HELP_STRING([--enable-external-libtalloc], [Enable external talloc [default=auto]])],
|
|
||||||
+[ enable_external_libtalloc=$enableval ], [ enable_external_libtalloc=auto ])
|
|
||||||
+
|
|
||||||
+if test "x$enable_external_libtalloc" != xno
|
|
||||||
+then
|
|
||||||
+ PKG_CHECK_MODULES(LIBTALLOC, talloc >= 1.3.0,
|
|
||||||
+ [ enable_external_libtalloc=yes ],
|
|
||||||
+ [ if test x$enable_external_libtalloc = xyes; then
|
|
||||||
+ AC_MSG_ERROR([Unable to find libtalloc])
|
|
||||||
+ else
|
|
||||||
+ enable_external_libtalloc=no
|
|
||||||
+ fi
|
|
||||||
+ ])
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
+if test "x$enable_external_libtalloc" = xno
|
|
||||||
+then
|
|
||||||
+ m4_include(../lib/talloc/libtalloc.m4)
|
|
||||||
+ SMB_LIBRARY(talloc, 1)
|
|
||||||
+ LIBTALLOC_OBJ0=""
|
|
||||||
+ for obj in ${TALLOC_OBJ}; do
|
|
||||||
+ LIBTALLOC_OBJ0="${LIBTALLOC_OBJ0} ${tallocdir}/${obj}"
|
|
||||||
+ done
|
|
||||||
+ SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TALLOC_CFLAGS}"
|
|
||||||
+ AC_SUBST(LIBTALLOC_OBJ0)
|
|
||||||
+fi
|
|
||||||
+
|
|
||||||
SMB_LIBRARY(tdb, 1)
|
|
||||||
SMB_LIBRARY(netapi, 0)
|
|
||||||
SMB_LIBRARY(smbclient, 0)
|
|
||||||
diff --git a/source3/samba4.m4 b/source3/samba4.m4
|
|
||||||
index b5c7c74..0ea40db 100644
|
|
||||||
--- a/source3/samba4.m4
|
|
||||||
+++ b/source3/samba4.m4
|
|
||||||
@@ -75,6 +75,10 @@ SMB_EXT_LIB_FROM_PKGCONFIG(LIBTALLOC, talloc >= $TALLOC_MIN_VERSION,
|
|
||||||
SMB_INCLUDE_MK(../lib/talloc/config.mk)
|
|
||||||
]
|
|
||||||
)
|
|
||||||
+# Tallocdir isn't always set by the Samba3 c
|
|
||||||
+tallocdir=../lib/talloc
|
|
||||||
+AC_SUBST(tallocdir)
|
|
||||||
+CFLAGS="$CFLAGS -I../lib/talloc"
|
|
||||||
|
|
||||||
SMB_EXT_LIB_FROM_PKGCONFIG(LIBTDB, tdb >= $TDB_MIN_VERSION,
|
|
||||||
[],
|
|
@ -1,34 +0,0 @@
|
|||||||
commit ef891070288cd13aff7c730de7c1baf54dddb90f
|
|
||||||
Author: Jeremy Allison <jra@samba.org>
|
|
||||||
AuthorDate: Fri Aug 21 12:44:54 2009 +0200
|
|
||||||
Commit: Karolin Seeger <kseeger@samba.org>
|
|
||||||
CommitDate: Fri Aug 21 12:46:47 2009 +0200
|
|
||||||
|
|
||||||
Fix Red Hat bugzilla bug : https://bugzilla.redhat.com/show_bug.cgi?id=516165
|
|
||||||
nautilus fails to copy files from an SMB share. This is a show-stopper
|
|
||||||
for 3.4.1. Although gnome-vfs is doing *incredibly* stupid things by asking
|
|
||||||
for a read size of 65535 - this translates on the wire to a 65534 byte read
|
|
||||||
followed by a 1 byte read. Please send this back to the gnome developers that
|
|
||||||
they will ge horrid on the wire performance for this.
|
|
||||||
Jeremy.
|
|
||||||
|
|
||||||
Fixes bug #6649.
|
|
||||||
|
|
||||||
Fixed in master with commit 33d27797d3ae9ab3ff7e1aa940941cc450f5ad1d.
|
|
||||||
---
|
|
||||||
source3/libsmb/clireadwrite.c | 2 +-
|
|
||||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/source3/libsmb/clireadwrite.c b/source3/libsmb/clireadwrite.c
|
|
||||||
index f2f447b..b1064ba 100644
|
|
||||||
--- a/source3/libsmb/clireadwrite.c
|
|
||||||
+++ b/source3/libsmb/clireadwrite.c
|
|
||||||
@@ -185,7 +185,7 @@ NTSTATUS cli_read_andx_recv(struct async_req *req, ssize_t *received,
|
|
||||||
buf = (uint8_t *)smb_base(cli_req->inbuf) + SVAL(vwv+6, 0);
|
|
||||||
|
|
||||||
if (trans_oob(smb_len(cli_req->inbuf), SVAL(vwv+6, 0), size)
|
|
||||||
- || (buf < bytes)) {
|
|
||||||
+ || (size && (buf < bytes))) {
|
|
||||||
DEBUG(5, ("server returned invalid read&x data offset\n"));
|
|
||||||
return NT_STATUS_INVALID_NETWORK_RESPONSE;
|
|
||||||
}
|
|
13
samba.spec
13
samba.spec
@ -1,5 +1,5 @@
|
|||||||
%define main_release 43
|
%define main_release 44
|
||||||
%define samba_version 3.4.0
|
%define samba_version 3.4.1
|
||||||
%define tdb_version 1.1.3
|
%define tdb_version 1.1.3
|
||||||
%define talloc_version 1.3.0
|
%define talloc_version 1.3.0
|
||||||
#%define pre_release rc1
|
#%define pre_release rc1
|
||||||
@ -48,9 +48,6 @@ Patch104: samba-3.0.0rc3-nmbd-netbiosname.patch
|
|||||||
# The passwd part has been applied, but not the group part
|
# The passwd part has been applied, but not the group part
|
||||||
Patch107: samba-3.2.0pre1-grouppwd.patch
|
Patch107: samba-3.2.0pre1-grouppwd.patch
|
||||||
Patch200: samba-3.2.5-inotify.patch
|
Patch200: samba-3.2.5-inotify.patch
|
||||||
Patch201: samba-3.4.0-build.patch
|
|
||||||
Patch202: samba-3.4.0-bug6551.patch
|
|
||||||
Patch203: samba-3.4.0-cliread.patch
|
|
||||||
|
|
||||||
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
|
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
|
||||||
Requires: pam >= 0:0.64
|
Requires: pam >= 0:0.64
|
||||||
@ -261,9 +258,6 @@ cp %{SOURCE11} packaging/Fedora/
|
|||||||
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
|
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
|
||||||
%patch107 -p1 -b .grouppwd
|
%patch107 -p1 -b .grouppwd
|
||||||
%patch200 -p0 -b .inotify
|
%patch200 -p0 -b .inotify
|
||||||
%patch201 -p1 -b .build
|
|
||||||
%patch202 -p1 -b .bug6551
|
|
||||||
%patch203 -p1 -b .cliread
|
|
||||||
|
|
||||||
mv %samba_source/VERSION %samba_source/VERSION.orig
|
mv %samba_source/VERSION %samba_source/VERSION.orig
|
||||||
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < %samba_source/VERSION.orig > %samba_source/VERSION
|
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < %samba_source/VERSION.orig > %samba_source/VERSION
|
||||||
@ -890,6 +884,9 @@ exit 0
|
|||||||
%{_datadir}/pixmaps/samba/logo-small.png
|
%{_datadir}/pixmaps/samba/logo-small.png
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Sep 09 2009 Guenther Deschner <gdeschner@redhat.com> - 3.4.1-0.44
|
||||||
|
- Update to 3.4.1
|
||||||
|
|
||||||
* Thu Aug 20 2009 Guenther Deschner <gdeschner@redhat.com> - 3.4.0-0.43
|
* Thu Aug 20 2009 Guenther Deschner <gdeschner@redhat.com> - 3.4.0-0.43
|
||||||
- Fix cli_read()
|
- Fix cli_read()
|
||||||
- resolves: #516165
|
- resolves: #516165
|
||||||
|
Loading…
Reference in New Issue
Block a user