Update to 3.3.1
Guenther
This commit is contained in:
parent
ee7a00b914
commit
98da145e61
@ -1 +1 @@
|
|||||||
samba-3.3.0.tar.gz
|
samba-3.3.1.tar.gz
|
||||||
|
@ -1,37 +0,0 @@
|
|||||||
From d332da87068cd72489941010a33e372ab53d3bcc Mon Sep 17 00:00:00 2001
|
|
||||||
From: Michael Adam <obnox@samba.org>
|
|
||||||
Date: Thu, 29 Jan 2009 13:17:46 +0100
|
|
||||||
Subject: [PATCH] fix bug #6073: prevent ads_connect() from using SSL unless explicitly requested
|
|
||||||
|
|
||||||
This fixes "net ads join".
|
|
||||||
It copes with the changed default "ldap ssl = start tls".
|
|
||||||
A new boolean option "ldap ssl : ads" is added to allow for
|
|
||||||
explicitly requesting ssl with ads.
|
|
||||||
|
|
||||||
Michael
|
|
||||||
---
|
|
||||||
source/libads/ldap.c | 8 +++++---
|
|
||||||
1 files changed, 5 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/source/libads/ldap.c b/source/libads/ldap.c
|
|
||||||
index f3bc2c5..5c95d4f 100644
|
|
||||||
--- a/source/libads/ldap.c
|
|
||||||
+++ b/source/libads/ldap.c
|
|
||||||
@@ -672,9 +672,11 @@ got_connection:
|
|
||||||
|
|
||||||
ldap_set_option(ads->ldap.ld, LDAP_OPT_PROTOCOL_VERSION, &version);
|
|
||||||
|
|
||||||
- status = ADS_ERROR(smb_ldap_start_tls(ads->ldap.ld, version));
|
|
||||||
- if (!ADS_ERR_OK(status)) {
|
|
||||||
- goto out;
|
|
||||||
+ if (lp_parm_bool(-1, "ldap ssl", "ads", false)) {
|
|
||||||
+ status = ADS_ERROR(smb_ldap_start_tls(ads->ldap.ld, version));
|
|
||||||
+ if (!ADS_ERR_OK(status)) {
|
|
||||||
+ goto out;
|
|
||||||
+ }
|
|
||||||
}
|
|
||||||
|
|
||||||
/* fill in the current time and offsets */
|
|
||||||
--
|
|
||||||
1.6.0.2
|
|
||||||
|
|
@ -1,37 +0,0 @@
|
|||||||
diff --git a/source/Makefile.in b/source/Makefile.in
|
|
||||||
index a77ec48..f7b4431 100644
|
|
||||||
--- a/source/Makefile.in
|
|
||||||
+++ b/source/Makefile.in
|
|
||||||
@@ -194,7 +194,7 @@ BIN_PROGS3 = bin/smbpasswd@EXEEXT@ bin/rpcclient@EXEEXT@ bin/smbcacls@EXEEXT@ \
|
|
||||||
bin/profiles@EXEEXT@ bin/ntlm_auth@EXEEXT@ bin/sharesec@EXEEXT@ \
|
|
||||||
bin/smbcquotas@EXEEXT@ bin/eventlogadm@EXEEXT@
|
|
||||||
BIN_PROGS4 = bin/ldbedit@EXEEXT@ bin/ldbsearch@EXEEXT@ bin/ldbadd@EXEEXT@ \
|
|
||||||
- bin/ldbdel@EXEEXT@ bin/ldbmodify@EXEEXT@
|
|
||||||
+ bin/ldbdel@EXEEXT@ bin/ldbmodify@EXEEXT@ bin/ldbrename@EXEEXT@
|
|
||||||
|
|
||||||
TORTURE_PROGS = bin/smbtorture@EXEEXT@ bin/msgtest@EXEEXT@ \
|
|
||||||
bin/masktest@EXEEXT@ bin/locktest@EXEEXT@ \
|
|
||||||
@@ -1080,6 +1080,7 @@ LDBSEARCH_OBJ = $(LDB_CMDLINE_OBJ) lib/ldb/tools/ldbsearch.o
|
|
||||||
LDBADD_OBJ = $(LDB_CMDLINE_OBJ) lib/ldb/tools/ldbadd.o
|
|
||||||
LDBDEL_OBJ = $(LDB_CMDLINE_OBJ) lib/ldb/tools/ldbdel.o
|
|
||||||
LDBMODIFY_OBJ = $(LDB_CMDLINE_OBJ) lib/ldb/tools/ldbmodify.o
|
|
||||||
+LDBRENAME_OBJ = $(LDB_CMDLINE_OBJ) lib/ldb/tools/ldbrename.o
|
|
||||||
|
|
||||||
WINBIND_KRB5_LOCATOR_OBJ1 = nsswitch/winbind_krb5_locator.o
|
|
||||||
WINBIND_KRB5_LOCATOR_OBJ = $(WINBIND_KRB5_LOCATOR_OBJ1) $(LIBREPLACE_OBJ)
|
|
||||||
@@ -1579,6 +1580,12 @@ bin/ldbdel: $(BINARY_PREREQS) $(LDBDEL_OBJ) @BUILD_POPT@ @LIBTALLOC_SHARED@ @LIB
|
|
||||||
$(LIBS) $(POPT_LIBS) $(LDAP_LIBS) \
|
|
||||||
$(LIBTALLOC_LIBS) $(LIBTDB_LIBS) $(WINBIND_LIBS)
|
|
||||||
|
|
||||||
+bin/ldbrename: $(BINARY_PREREQS) $(LDBRENAME_OBJ) @BUILD_POPT@ @LIBTALLOC_SHARED@ @LIBTDB_SHARED@ @LIBWBCLIENT_SHARED@
|
|
||||||
+ @echo Linking $@
|
|
||||||
+ @$(CC) $(FLAGS) -o $@ $(LDBRENAME_OBJ) $(DYNEXP) $(LDFLAGS) \
|
|
||||||
+ $(LIBS) $(POPT_LIBS) $(LDAP_LIBS) \
|
|
||||||
+ $(LIBTALLOC_LIBS) $(LIBTDB_LIBS) $(WINBIND_LIBS)
|
|
||||||
+
|
|
||||||
|
|
||||||
#####################################################################
|
|
||||||
#
|
|
||||||
--
|
|
||||||
1.5.6.6
|
|
||||||
|
|
17
samba.spec
17
samba.spec
@ -1,5 +1,5 @@
|
|||||||
%define main_release 26
|
%define main_release 27
|
||||||
%define samba_version 3.3.0
|
%define samba_version 3.3.1
|
||||||
%define tdb_version 1.1.2
|
%define tdb_version 1.1.2
|
||||||
%define talloc_version 1.2.0
|
%define talloc_version 1.2.0
|
||||||
%define pre_release %nil
|
%define pre_release %nil
|
||||||
@ -42,9 +42,7 @@ Patch102: samba-3.2.0pre1-pipedir.patch
|
|||||||
Patch104: samba-3.0.0rc3-nmbd-netbiosname.patch
|
Patch104: samba-3.0.0rc3-nmbd-netbiosname.patch
|
||||||
# The passwd part has been applied, but not the group part
|
# The passwd part has been applied, but not the group part
|
||||||
Patch107: samba-3.2.0pre1-grouppwd.patch
|
Patch107: samba-3.2.0pre1-grouppwd.patch
|
||||||
Patch199: samba-3.3.0-ldbrename.patch
|
|
||||||
Patch200: samba-3.2.5-inotify.patch
|
Patch200: samba-3.2.5-inotify.patch
|
||||||
Patch201: 0001-fix-bug-6073-prevent-ads_connect-from-using-SSL.patch
|
|
||||||
|
|
||||||
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
|
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
|
||||||
Requires: pam >= 0:0.64
|
Requires: pam >= 0:0.64
|
||||||
@ -247,9 +245,7 @@ cp %{SOURCE11} packaging/Fedora/
|
|||||||
#%patch103 -p1 -b .logfiles
|
#%patch103 -p1 -b .logfiles
|
||||||
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
|
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
|
||||||
%patch107 -p1 -b .grouppwd
|
%patch107 -p1 -b .grouppwd
|
||||||
%patch199 -p1 -b .ldbrename
|
|
||||||
%patch200 -p0 -b .inotify
|
%patch200 -p0 -b .inotify
|
||||||
%patch201 -p1 -b .ldap_ssl
|
|
||||||
|
|
||||||
mv source/VERSION source/VERSION.orig
|
mv source/VERSION source/VERSION.orig
|
||||||
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < source/VERSION.orig > source/VERSION
|
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < source/VERSION.orig > source/VERSION
|
||||||
@ -458,7 +454,7 @@ mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbdel.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb
|
|||||||
mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbedit.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3edit.1
|
mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbedit.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3edit.1
|
||||||
mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbmodify.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3modify.1
|
mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbmodify.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3modify.1
|
||||||
mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbsearch.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3search.1
|
mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbsearch.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3search.1
|
||||||
#mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbrename.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3rename.1
|
mv -f $RPM_BUILD_ROOT%{_mandir}/man1/ldbrename.1 $RPM_BUILD_ROOT%{_mandir}/man1/ldb3rename.1
|
||||||
|
|
||||||
|
|
||||||
%clean
|
%clean
|
||||||
@ -699,6 +695,7 @@ exit 0
|
|||||||
%{_bindir}/smbspool
|
%{_bindir}/smbspool
|
||||||
%{_bindir}/smbtar
|
%{_bindir}/smbtar
|
||||||
%{_bindir}/smbtree
|
%{_bindir}/smbtree
|
||||||
|
%{_bindir}/sharesec
|
||||||
%{_mandir}/man1/findsmb.1*
|
%{_mandir}/man1/findsmb.1*
|
||||||
%{_mandir}/man1/nmblookup.1*
|
%{_mandir}/man1/nmblookup.1*
|
||||||
%{_mandir}/man1/rpcclient.1*
|
%{_mandir}/man1/rpcclient.1*
|
||||||
@ -707,6 +704,7 @@ exit 0
|
|||||||
%{_mandir}/man1/smbtar.1*
|
%{_mandir}/man1/smbtar.1*
|
||||||
%{_mandir}/man1/smbtree.1*
|
%{_mandir}/man1/smbtree.1*
|
||||||
%{_mandir}/man1/smbget.1*
|
%{_mandir}/man1/smbget.1*
|
||||||
|
%{_mandir}/man1/sharesec.1*
|
||||||
%{_mandir}/man8/smbspool.8*
|
%{_mandir}/man8/smbspool.8*
|
||||||
%{_mandir}/man8/mount.cifs.8*
|
%{_mandir}/man8/mount.cifs.8*
|
||||||
%{_mandir}/man8/umount.cifs.8*
|
%{_mandir}/man8/umount.cifs.8*
|
||||||
@ -752,7 +750,7 @@ exit 0
|
|||||||
%{_mandir}/man1/ldb3edit.1.gz
|
%{_mandir}/man1/ldb3edit.1.gz
|
||||||
%{_mandir}/man1/ldb3modify.1.gz
|
%{_mandir}/man1/ldb3modify.1.gz
|
||||||
%{_mandir}/man1/ldb3search.1.gz
|
%{_mandir}/man1/ldb3search.1.gz
|
||||||
#%{_mandir}/man1/ldb3rename.1.gz
|
%{_mandir}/man1/ldb3rename.1.gz
|
||||||
%{_mandir}/man1/profiles.1*
|
%{_mandir}/man1/profiles.1*
|
||||||
%{_mandir}/man1/smbcquotas.1*
|
%{_mandir}/man1/smbcquotas.1*
|
||||||
%{_mandir}/man1/smbcontrol.1*
|
%{_mandir}/man1/smbcontrol.1*
|
||||||
@ -846,6 +844,9 @@ exit 0
|
|||||||
%{_datadir}/pixmaps/samba/logo-small.png
|
%{_datadir}/pixmaps/samba/logo-small.png
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Feb 24 2009 Guenther Deschner <gdeschner@redhat.com> - 3.3.1-0.27
|
||||||
|
- Update to 3.3.1
|
||||||
|
|
||||||
* Thu Feb 21 2009 Simo Sorce <ssorce@redhat.com> - 3.3.0-0.26
|
* Thu Feb 21 2009 Simo Sorce <ssorce@redhat.com> - 3.3.0-0.26
|
||||||
- Rename ldb* tools to ldb3* to avoid conflicts with newer ldb releases
|
- Rename ldb* tools to ldb3* to avoid conflicts with newer ldb releases
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user