parent
c6c439ff35
commit
945aa6753a
1
.gitignore
vendored
1
.gitignore
vendored
@ -49,3 +49,4 @@ samba-3.6.0pre1.tar.gz
|
|||||||
/samba-4.2.0.tar.xz
|
/samba-4.2.0.tar.xz
|
||||||
/samba-4.2.1.tar.xz
|
/samba-4.2.1.tar.xz
|
||||||
/samba-4.2.2.tar.xz
|
/samba-4.2.2.tar.xz
|
||||||
|
/samba-4.2.3.tar.xz
|
||||||
|
@ -1,63 +0,0 @@
|
|||||||
commit c6ad8a10c12c8a79dc83cab1591e5279edd62bd6
|
|
||||||
Author: Evangelos Foutras <evangelos@foutrelis.com>
|
|
||||||
Date: Mon Apr 13 23:11:14 2015 +0300
|
|
||||||
|
|
||||||
s4:lib/tls: fix build with gnutls 3.4
|
|
||||||
|
|
||||||
gnutls_certificate_type_set_priority() was removed in GnuTLS 3.4.0. Use
|
|
||||||
gnutls_priority_set_direct instead.
|
|
||||||
|
|
||||||
BUG: https://bugzilla.samba.org/show_bug.cgi?id=8780
|
|
||||||
|
|
||||||
Signed-off-by: Björn Jacke <bj@sernet.de>
|
|
||||||
Reviewed-By: Jelmer Vernooij <jelmer@samba.org>
|
|
||||||
|
|
||||||
Autobuild-User(master): Björn Jacke <bj@sernet.de>
|
|
||||||
Autobuild-Date(master): Wed Apr 29 22:29:02 CEST 2015 on sn-devel-104
|
|
||||||
|
|
||||||
diff --git a/source4/lib/tls/tls.c b/source4/lib/tls/tls.c
|
|
||||||
index b9182ad..2fe4ff7 100644
|
|
||||||
--- a/source4/lib/tls/tls.c
|
|
||||||
+++ b/source4/lib/tls/tls.c
|
|
||||||
@@ -572,7 +572,6 @@ struct socket_context *tls_init_client(struct socket_context *socket_ctx,
|
|
||||||
{
|
|
||||||
struct tls_context *tls;
|
|
||||||
int ret = 0;
|
|
||||||
- const int cert_type_priority[] = { GNUTLS_CRT_X509, GNUTLS_CRT_OPENPGP, 0 };
|
|
||||||
struct socket_context *new_sock;
|
|
||||||
NTSTATUS nt_status;
|
|
||||||
|
|
||||||
@@ -598,7 +597,7 @@ struct socket_context *tls_init_client(struct socket_context *socket_ctx,
|
|
||||||
gnutls_certificate_set_x509_trust_file(tls->xcred, ca_path, GNUTLS_X509_FMT_PEM);
|
|
||||||
TLSCHECK(gnutls_init(&tls->session, GNUTLS_CLIENT));
|
|
||||||
TLSCHECK(gnutls_set_default_priority(tls->session));
|
|
||||||
- gnutls_certificate_type_set_priority(tls->session, cert_type_priority);
|
|
||||||
+ gnutls_priority_set_direct(tls->session, "NORMAL:+CTYPE-OPENPGP", NULL);
|
|
||||||
TLSCHECK(gnutls_credentials_set(tls->session, GNUTLS_CRD_CERTIFICATE, tls->xcred));
|
|
||||||
|
|
||||||
talloc_set_destructor(tls, tls_destructor);
|
|
||||||
diff --git a/source4/lib/tls/tls_tstream.c b/source4/lib/tls/tls_tstream.c
|
|
||||||
index f19f5c5..5b2329b 100644
|
|
||||||
--- a/source4/lib/tls/tls_tstream.c
|
|
||||||
+++ b/source4/lib/tls/tls_tstream.c
|
|
||||||
@@ -967,11 +967,6 @@ struct tevent_req *_tstream_tls_connect_send(TALLOC_CTX *mem_ctx,
|
|
||||||
#if ENABLE_GNUTLS
|
|
||||||
struct tstream_tls *tlss;
|
|
||||||
int ret;
|
|
||||||
- static const int cert_type_priority[] = {
|
|
||||||
- GNUTLS_CRT_X509,
|
|
||||||
- GNUTLS_CRT_OPENPGP,
|
|
||||||
- 0
|
|
||||||
- };
|
|
||||||
#endif /* ENABLE_GNUTLS */
|
|
||||||
|
|
||||||
req = tevent_req_create(mem_ctx, &state,
|
|
||||||
@@ -1014,7 +1009,7 @@ struct tevent_req *_tstream_tls_connect_send(TALLOC_CTX *mem_ctx,
|
|
||||||
return tevent_req_post(req, ev);
|
|
||||||
}
|
|
||||||
|
|
||||||
- gnutls_certificate_type_set_priority(tlss->tls_session, cert_type_priority);
|
|
||||||
+ gnutls_priority_set_direct(tlss->tls_session, "NORMAL:+CTYPE-OPENPGP", NULL);
|
|
||||||
|
|
||||||
ret = gnutls_credentials_set(tlss->tls_session,
|
|
||||||
GNUTLS_CRD_CERTIFICATE,
|
|
@ -1,34 +0,0 @@
|
|||||||
commit 1ff9ffea061e4bdecea65749d8d0e3c082e25d77
|
|
||||||
Author: Günther Deschner <gd@samba.org>
|
|
||||||
AuthorDate: Thu Apr 30 11:20:58 2015 +0200
|
|
||||||
Commit: Günther Deschner <gd@samba.org>
|
|
||||||
CommitDate: Thu Apr 30 11:22:26 2015 +0200
|
|
||||||
|
|
||||||
s3-rpc_server: fix rpc_create_tcpip_sockets() processing of interfaces.
|
|
||||||
|
|
||||||
We were supplying an empty value for the "host" binding string option, causing
|
|
||||||
dcerpc_binding_vector_add_port() call to fail.
|
|
||||||
|
|
||||||
Fixes: https://bugzilla.samba.org/show_bug.cgi?id=11245
|
|
||||||
Guenther
|
|
||||||
|
|
||||||
Signed-off-by: Günther Deschner <gd@samba.org>
|
|
||||||
Pair-Programmed-With: Alexander Bokovoy <ab@samba.org>
|
|
||||||
---
|
|
||||||
source3/rpc_server/rpc_sock_helper.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/source3/rpc_server/rpc_sock_helper.c b/source3/rpc_server/rpc_sock_helper.c
|
|
||||||
index 8f371b8..7aced63 100644
|
|
||||||
--- a/source3/rpc_server/rpc_sock_helper.c
|
|
||||||
+++ b/source3/rpc_server/rpc_sock_helper.c
|
|
||||||
@@ -138,7 +138,7 @@ NTSTATUS rpc_create_tcpip_sockets(const struct ndr_interface_table *iface,
|
|
||||||
if (bvec != NULL) {
|
|
||||||
status = dcerpc_binding_vector_add_port(iface,
|
|
||||||
bvec,
|
|
||||||
- sock_ptr,
|
|
||||||
+ sock_tok,
|
|
||||||
p);
|
|
||||||
if (!NT_STATUS_IS_OK(status)) {
|
|
||||||
close(fd);
|
|
||||||
|
|
19
samba.spec
19
samba.spec
@ -6,13 +6,13 @@
|
|||||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||||
%bcond_without clustering
|
%bcond_without clustering
|
||||||
|
|
||||||
%define main_release 1
|
%define main_release 0
|
||||||
|
|
||||||
%define samba_version 4.2.2
|
%define samba_version 4.2.3
|
||||||
%define talloc_version 2.1.2
|
%define talloc_version 2.1.2
|
||||||
%define ntdb_version 1.0
|
%define ntdb_version 1.0
|
||||||
%define tdb_version 1.3.4
|
%define tdb_version 1.3.6
|
||||||
%define tevent_version 0.9.24
|
%define tevent_version 0.9.25
|
||||||
%define ldb_version 1.1.20
|
%define ldb_version 1.1.20
|
||||||
# This should be rc1 or nil
|
# This should be rc1 or nil
|
||||||
%define pre_release %nil
|
%define pre_release %nil
|
||||||
@ -99,9 +99,7 @@ URL: http://www.samba.org/
|
|||||||
|
|
||||||
Source0: samba-%{version}%{pre_release}.tar.xz
|
Source0: samba-%{version}%{pre_release}.tar.xz
|
||||||
|
|
||||||
Patch2: samba-4.2-fix-rpc-helper.patch
|
|
||||||
Patch3: samba-4.2-auth-credentials-if-credentials-have-principal-set-t.patch
|
Patch3: samba-4.2-auth-credentials-if-credentials-have-principal-set-t.patch
|
||||||
Patch4: samba-4.2-fix-gnutls-deprecation.patch
|
|
||||||
|
|
||||||
# Red Hat specific replacement-files
|
# Red Hat specific replacement-files
|
||||||
Source1: samba.log
|
Source1: samba.log
|
||||||
@ -191,7 +189,7 @@ BuildRequires: pytalloc-devel >= %{libtalloc_version}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if ! %with_internal_tevent
|
%if ! %with_internal_tevent
|
||||||
%global libtevent_version 0.9.22
|
%global libtevent_version 0.9.25
|
||||||
|
|
||||||
BuildRequires: libtevent-devel >= %{libtevent_version}
|
BuildRequires: libtevent-devel >= %{libtevent_version}
|
||||||
BuildRequires: python-tevent >= %{libtevent_version}
|
BuildRequires: python-tevent >= %{libtevent_version}
|
||||||
@ -205,7 +203,7 @@ BuildRequires: pyldb-devel >= %{libldb_version}
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%if ! %with_internal_tdb
|
%if ! %with_internal_tdb
|
||||||
%global libtdb_version 1.3.4
|
%global libtdb_version 1.3.6
|
||||||
|
|
||||||
BuildRequires: libtdb-devel >= %{libtdb_version}
|
BuildRequires: libtdb-devel >= %{libtdb_version}
|
||||||
BuildRequires: python-tdb >= %{libtdb_version}
|
BuildRequires: python-tdb >= %{libtdb_version}
|
||||||
@ -651,9 +649,7 @@ and use CTDB instead.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n samba-%{version}%{pre_release}
|
%setup -q -n samba-%{version}%{pre_release}
|
||||||
|
|
||||||
%patch2 -p1 -b .samba-4.2-fix-rpc-helper.patch
|
|
||||||
%patch3 -p1 -b .samba-4.2-auth-credentials-if-credentials-have-principal-set-t.patch
|
%patch3 -p1 -b .samba-4.2-auth-credentials-if-credentials-have-principal-set-t.patch
|
||||||
%patch4 -p1 -b .samba-4.2-fix-gnutls-deprecation.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||||
@ -1952,6 +1948,9 @@ rm -rf %{buildroot}
|
|||||||
%endif # with_clustering_support
|
%endif # with_clustering_support
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 14 2015 Guenther Deschner <gdeschner@redhat.com> - 4.2.3-0
|
||||||
|
- resolves: #1088911 - Update to Samba 4.2.3
|
||||||
|
|
||||||
* Fri Jun 19 2015 Andreas Schneider <asn@redhat.com> - 4.2.2-1
|
* Fri Jun 19 2015 Andreas Schneider <asn@redhat.com> - 4.2.2-1
|
||||||
- resolves: #1227911 - Enable tar support for smbclient
|
- resolves: #1227911 - Enable tar support for smbclient
|
||||||
- resolves: #1234908 - Own the /var/lib/samba directory
|
- resolves: #1234908 - Own the /var/lib/samba directory
|
||||||
|
Loading…
Reference in New Issue
Block a user