Try to fix the build with the new gcc
This commit is contained in:
parent
e503b7cb1c
commit
93f41dc7d9
10
samba-3.2.0pre1-buildfix.patch
Normal file
10
samba-3.2.0pre1-buildfix.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- samba-3.2.0pre1.orig/source/client/mount.cifs.c 2007-09-28 11:48:04.000000000 -0400
|
||||||
|
+++ samba-3.2.0pre1/source/client/mount.cifs.c 2008-02-22 12:48:39.000000000 -0500
|
||||||
|
@@ -37,6 +37,7 @@
|
||||||
|
#include <string.h>
|
||||||
|
#include <mntent.h>
|
||||||
|
#include <fcntl.h>
|
||||||
|
+#include <limits.h>
|
||||||
|
|
||||||
|
#define MOUNT_CIFS_VERSION_MAJOR "1"
|
||||||
|
#define MOUNT_CIFS_VERSION_MINOR "10"
|
15
samba.spec
15
samba.spec
@ -2,7 +2,7 @@ Summary: The Samba Suite of programs
|
|||||||
Name: samba
|
Name: samba
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
Version: 3.2.0
|
Version: 3.2.0
|
||||||
Release: 1.pre1.2%{?dist}
|
Release: 1.pre1.3%{?dist}
|
||||||
License: GPLv3+ and LGPLv3+
|
License: GPLv3+ and LGPLv3+
|
||||||
Group: System Environment/Daemons
|
Group: System Environment/Daemons
|
||||||
URL: http://www.samba.org/
|
URL: http://www.samba.org/
|
||||||
@ -42,6 +42,7 @@ Patch110: samba-3.0.21pre1-smbspool.patch
|
|||||||
Patch111: samba-3.0.13-smbclient.patch
|
Patch111: samba-3.0.13-smbclient.patch
|
||||||
Patch200: samba-3.0.25rc1-inotifiy.patch
|
Patch200: samba-3.0.25rc1-inotifiy.patch
|
||||||
Patch201: samba-3.2.0pre1-winbindd-padding.patch
|
Patch201: samba-3.2.0pre1-winbindd-padding.patch
|
||||||
|
patch202: samba-3.2.0pre1-buildfix.patch
|
||||||
|
|
||||||
|
|
||||||
Requires(pre): samba-common = %{epoch}:%{version}-%{release}
|
Requires(pre): samba-common = %{epoch}:%{version}-%{release}
|
||||||
@ -160,6 +161,7 @@ cp %{SOURCE11} packaging/Fedora/
|
|||||||
%patch111 -p1 -b .smbclient
|
%patch111 -p1 -b .smbclient
|
||||||
%patch200 -p0 -b .inotify
|
%patch200 -p0 -b .inotify
|
||||||
%patch201 -p0 -b .winbind-padding
|
%patch201 -p0 -b .winbind-padding
|
||||||
|
%patch202 -p1 -b .buildfix
|
||||||
|
|
||||||
mv source/VERSION source/VERSION.orig
|
mv source/VERSION source/VERSION.orig
|
||||||
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{release}\"/' < source/VERSION.orig > source/VERSION
|
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{release}\"/' < source/VERSION.orig > source/VERSION
|
||||||
@ -185,18 +187,21 @@ EXTRA="-D_LARGEFILE64_SOURCE"
|
|||||||
%endif
|
%endif
|
||||||
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" %configure \
|
CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" %configure \
|
||||||
--with-dnsupdate \
|
--with-dnsupdate \
|
||||||
|
--with-ads \
|
||||||
--with-acl-support \
|
--with-acl-support \
|
||||||
--with-automount \
|
--with-automount \
|
||||||
|
--with-dnsupdate \
|
||||||
--with-libsmbclient \
|
--with-libsmbclient \
|
||||||
--with-libsmbsharemodes \
|
--with-libsmbsharemodes \
|
||||||
--with-mmap \
|
--with-mmap \
|
||||||
--with-pam \
|
--with-pam \
|
||||||
--with-pam_smbpass \
|
--with-pam_smbpass \
|
||||||
--with-quotas \
|
--with-quotas \
|
||||||
|
--with-sendfile-support \
|
||||||
--with-syslog \
|
--with-syslog \
|
||||||
--with-utmp \
|
--with-utmp \
|
||||||
--with-vfs \
|
--with-vfs \
|
||||||
--with-sendfile-support \
|
--with-winbind \
|
||||||
--without-smbwrapper \
|
--without-smbwrapper \
|
||||||
--with-lockdir=/var/lib/samba \
|
--with-lockdir=/var/lib/samba \
|
||||||
--with-piddir=/var/run \
|
--with-piddir=/var/run \
|
||||||
@ -665,6 +670,12 @@ exit 0
|
|||||||
#%{_includedir}/libmsrpc.h
|
#%{_includedir}/libmsrpc.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 22 2008 Simo Sorce <ssorce@redhat.com> - 3.2.0-0.pre1.3
|
||||||
|
- Try to fix GCC 4.3 build
|
||||||
|
- Add --with-dnsupdate flag and also make sure other flags are required just to
|
||||||
|
be sure the features are included without relying on autodetection to be
|
||||||
|
successful
|
||||||
|
|
||||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:3.2.0-1.pre1.2
|
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:3.2.0-1.pre1.2
|
||||||
- Autorebuild for GCC 4.3
|
- Autorebuild for GCC 4.3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user