Fix crash in rpcd_classic
resolves: rhbz#2106279
This commit is contained in:
parent
a277091065
commit
7eb74bfea1
66
samba-4.16-rpc_server3-mangle_fns.patch
Normal file
66
samba-4.16-rpc_server3-mangle_fns.patch
Normal file
@ -0,0 +1,66 @@
|
|||||||
|
From dfdd5805c1bc4bda8af8ffe40ec0af997aa9b1f9 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Volker Lendecke <vl@samba.org>
|
||||||
|
Date: Fri, 8 Jul 2022 14:14:22 +0200
|
||||||
|
Subject: [PATCH] rpc_server3: Initialize mangle_fns in classic and spoolss
|
||||||
|
MIME-Version: 1.0
|
||||||
|
Content-Type: text/plain; charset=UTF-8
|
||||||
|
Content-Transfer-Encoding: 8bit
|
||||||
|
|
||||||
|
Bug: https://bugzilla.samba.org/show_bug.cgi?id=15118
|
||||||
|
Signed-off-by: Volker Lendecke <vl@samba.org>
|
||||||
|
Reviewed-by: Pavel Filipenský <pfilipensky@samba.org>
|
||||||
|
|
||||||
|
Autobuild-User(master): Pavel Filipensky <pfilipensky@samba.org>
|
||||||
|
Autobuild-Date(master): Tue Jul 12 13:33:14 UTC 2022 on sn-devel-184
|
||||||
|
|
||||||
|
(cherry picked from commit 11d3d2aeac599ebbedd5332c5520465970319448)
|
||||||
|
---
|
||||||
|
source3/rpc_server/rpcd_classic.c | 3 +++
|
||||||
|
source3/rpc_server/rpcd_spoolss.c | 3 +++
|
||||||
|
2 files changed, 6 insertions(+)
|
||||||
|
|
||||||
|
diff --git a/source3/rpc_server/rpcd_classic.c b/source3/rpc_server/rpcd_classic.c
|
||||||
|
index d3607d2e19c..4f6164c814c 100644
|
||||||
|
--- a/source3/rpc_server/rpcd_classic.c
|
||||||
|
+++ b/source3/rpc_server/rpcd_classic.c
|
||||||
|
@@ -33,6 +33,7 @@
|
||||||
|
#include "librpc/gen_ndr/ndr_initshutdown_scompat.h"
|
||||||
|
#include "source3/include/secrets.h"
|
||||||
|
#include "locking/share_mode_lock.h"
|
||||||
|
+#include "source3/smbd/proto.h"
|
||||||
|
|
||||||
|
static size_t classic_interfaces(
|
||||||
|
const struct ndr_interface_table ***pifaces,
|
||||||
|
@@ -81,6 +82,8 @@ static size_t classic_servers(
|
||||||
|
|
||||||
|
lp_load_with_shares(get_dyn_CONFIGFILE());
|
||||||
|
|
||||||
|
+ mangle_reset_cache();
|
||||||
|
+
|
||||||
|
*_ep_servers = ep_servers;
|
||||||
|
return ARRAY_SIZE(ep_servers);
|
||||||
|
}
|
||||||
|
diff --git a/source3/rpc_server/rpcd_spoolss.c b/source3/rpc_server/rpcd_spoolss.c
|
||||||
|
index 733e70764a5..16b4667cd02 100644
|
||||||
|
--- a/source3/rpc_server/rpcd_spoolss.c
|
||||||
|
+++ b/source3/rpc_server/rpcd_spoolss.c
|
||||||
|
@@ -24,6 +24,7 @@
|
||||||
|
#include "source3/printing/queue_process.h"
|
||||||
|
#include "source3/include/messages.h"
|
||||||
|
#include "source3/include/secrets.h"
|
||||||
|
+#include "source3/smbd/proto.h"
|
||||||
|
|
||||||
|
static size_t spoolss_interfaces(
|
||||||
|
const struct ndr_interface_table ***pifaces,
|
||||||
|
@@ -68,6 +69,8 @@ static size_t spoolss_servers(
|
||||||
|
exit(1);
|
||||||
|
}
|
||||||
|
|
||||||
|
+ mangle_reset_cache();
|
||||||
|
+
|
||||||
|
*_ep_servers = ep_servers;
|
||||||
|
return ARRAY_SIZE(ep_servers);
|
||||||
|
}
|
||||||
|
--
|
||||||
|
2.36.1
|
||||||
|
|
14
samba.spec
14
samba.spec
@ -134,7 +134,7 @@
|
|||||||
|
|
||||||
%define samba_requires_eq() %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
|
%define samba_requires_eq() %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
|
||||||
|
|
||||||
%global baserelease 101
|
%global baserelease 102
|
||||||
|
|
||||||
%global samba_version 4.16.2
|
%global samba_version 4.16.2
|
||||||
%global talloc_version 2.3.3
|
%global talloc_version 2.3.3
|
||||||
@ -207,6 +207,7 @@ Source201: README.downgrade
|
|||||||
Patch0: samba-s4u.patch
|
Patch0: samba-s4u.patch
|
||||||
# https://gitlab.com/samba-team/samba/-/merge_requests/2477
|
# https://gitlab.com/samba-team/samba/-/merge_requests/2477
|
||||||
Patch1: samba-4.16-waf-crypto.patch
|
Patch1: samba-4.16-waf-crypto.patch
|
||||||
|
Patch2: samba-4.16-rpc_server3-mangle_fns.patch
|
||||||
|
|
||||||
Requires(pre): /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/groupadd
|
||||||
Requires(post): systemd
|
Requires(post): systemd
|
||||||
@ -365,12 +366,18 @@ BuildRequires: lmdb-devel
|
|||||||
%if %{with dc} || %{with testsuite}
|
%if %{with dc} || %{with testsuite}
|
||||||
BuildRequires: bind
|
BuildRequires: bind
|
||||||
BuildRequires: krb5-server >= %{required_mit_krb5}
|
BuildRequires: krb5-server >= %{required_mit_krb5}
|
||||||
BuildRequires: ldb-tools
|
|
||||||
BuildRequires: python3-gpg
|
BuildRequires: python3-gpg
|
||||||
BuildRequires: python3-markdown
|
BuildRequires: python3-markdown
|
||||||
BuildRequires: python3-setproctitle
|
BuildRequires: python3-setproctitle
|
||||||
BuildRequires: python3-cryptography
|
BuildRequires: python3-cryptography
|
||||||
|
|
||||||
|
%if %{without includelibs}
|
||||||
BuildRequires: tdb-tools
|
BuildRequires: tdb-tools
|
||||||
|
BuildRequires: ldb-tools
|
||||||
|
#endif without includelibs
|
||||||
|
%endif
|
||||||
|
|
||||||
|
#endif with dc || with testsuite
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# filter out perl requirements pulled in from examples in the docdir.
|
# filter out perl requirements pulled in from examples in the docdir.
|
||||||
@ -4155,6 +4162,9 @@ fi
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jul 13 2022 Pavel Filipenský <pfilipen@redhat.com> - 4.16.2-102
|
||||||
|
- resolves: rhbz#2106279 - Fix crash in rpcd_classic
|
||||||
|
|
||||||
* Tue Jun 14 2022 Pavel Filipenský <pfilipen@redhat.com> - 4.16.2-101
|
* Tue Jun 14 2022 Pavel Filipenský <pfilipen@redhat.com> - 4.16.2-101
|
||||||
- resolves: rhbz#2093833 - Fix weak dependency on logrotate
|
- resolves: rhbz#2093833 - Fix weak dependency on logrotate
|
||||||
- resolves: rhbz#2096813 - Fix printer displays only after 300 seconds timeout
|
- resolves: rhbz#2096813 - Fix printer displays only after 300 seconds timeout
|
||||||
|
Loading…
Reference in New Issue
Block a user