Update to Samba 4.4.0rc2
Guenther
This commit is contained in:
parent
cbc54b4d41
commit
724f5ab99a
1
.gitignore
vendored
1
.gitignore
vendored
@ -58,3 +58,4 @@ samba-3.6.0pre1.tar.gz
|
|||||||
/samba-4.3.3.tar.xz
|
/samba-4.3.3.tar.xz
|
||||||
/samba-4.3.4.tar.xz
|
/samba-4.3.4.tar.xz
|
||||||
/samba-4.4.0rc1.tar.xz
|
/samba-4.4.0rc1.tar.xz
|
||||||
|
/samba-4.4.0rc2.tar.xz
|
||||||
|
@ -1,64 +0,0 @@
|
|||||||
From 86f71108636b19e7a2c9052e73b3f2251a98bcc3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?G=C3=BCnther=20Deschner?= <gd@samba.org>
|
|
||||||
Date: Wed, 27 Jan 2016 15:40:33 +0100
|
|
||||||
Subject: [PATCH] ctdb: do not provide a useless pkgconfig file for ctdb.
|
|
||||||
|
|
||||||
We neither have public headers nor a public library.
|
|
||||||
|
|
||||||
Guenther
|
|
||||||
|
|
||||||
Signed-off-by: Guenther Deschner <gd@samba.org>
|
|
||||||
---
|
|
||||||
ctdb/ctdb.pc.in | 19 -------------------
|
|
||||||
ctdb/wscript | 9 ---------
|
|
||||||
2 files changed, 28 deletions(-)
|
|
||||||
delete mode 100644 ctdb/ctdb.pc.in
|
|
||||||
|
|
||||||
diff --git a/ctdb/ctdb.pc.in b/ctdb/ctdb.pc.in
|
|
||||||
deleted file mode 100644
|
|
||||||
index 5f5bfab..0000000
|
|
||||||
--- a/ctdb/ctdb.pc.in
|
|
||||||
+++ /dev/null
|
|
||||||
@@ -1,19 +0,0 @@
|
|
||||||
-prefix=@prefix@
|
|
||||||
-exec_prefix=@exec_prefix@
|
|
||||||
-datarootdir=@datarootdir@
|
|
||||||
-includedir=@includedir@
|
|
||||||
-libdir=@libdir@
|
|
||||||
-bindir=@bindir@
|
|
||||||
-sbindir=@sbindir@
|
|
||||||
-mandir=@mandir@
|
|
||||||
-localstatedir=@localstatedir@
|
|
||||||
-srcdir=@srcdir@
|
|
||||||
-etcdir=@sysconfdir@
|
|
||||||
-
|
|
||||||
-Name: ctdb
|
|
||||||
-Description: A clustered database to store temporary data
|
|
||||||
-Version: @PACKAGE_VERSION@
|
|
||||||
-Libs: -L${libdir}
|
|
||||||
-Cflags: -I${includedir}
|
|
||||||
-URL: http://ctdb.samba.org/
|
|
||||||
-
|
|
||||||
diff --git a/ctdb/wscript b/ctdb/wscript
|
|
||||||
index edd4aa4..e1fad17 100755
|
|
||||||
--- a/ctdb/wscript
|
|
||||||
+++ b/ctdb/wscript
|
|
||||||
@@ -615,15 +615,6 @@ def build(bld):
|
|
||||||
bld.install_dir(bld.env.CTDB_RUNDIR)
|
|
||||||
bld.install_dir(bld.env.CTDB_VARDIR)
|
|
||||||
|
|
||||||
- sed_expr = 's/@PACKAGE_VERSION@/%s/g' % VERSION
|
|
||||||
- t = bld.SAMBA_GENERATOR('ctdb-pc',
|
|
||||||
- source='ctdb.pc.in',
|
|
||||||
- target='ctdb.pc',
|
|
||||||
- rule='sed -e "%s" ${SRC} > ${TGT}' % sed_expr,
|
|
||||||
- dep_vars=['VERSION'])
|
|
||||||
- t.env.VERSION = VERSION
|
|
||||||
- bld.INSTALL_FILES('${LIBDIR}/pkgconfig', 'ctdb.pc')
|
|
||||||
-
|
|
||||||
# Unit tests
|
|
||||||
ctdb_unit_tests = [
|
|
||||||
'db_hash_test',
|
|
||||||
--
|
|
||||||
2.5.0
|
|
||||||
|
|
12
samba.spec
12
samba.spec
@ -14,7 +14,7 @@
|
|||||||
%define tevent_version 0.9.26
|
%define tevent_version 0.9.26
|
||||||
%define ldb_version 1.1.25
|
%define ldb_version 1.1.25
|
||||||
# This should be rc1 or nil
|
# This should be rc1 or nil
|
||||||
%define pre_release rc1
|
%define pre_release rc2
|
||||||
|
|
||||||
%if "x%{?pre_release}" != "x"
|
%if "x%{?pre_release}" != "x"
|
||||||
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
%define samba_release 0.%{main_release}.%{pre_release}%{?dist}
|
||||||
@ -75,7 +75,7 @@
|
|||||||
|
|
||||||
Name: samba
|
Name: samba
|
||||||
Version: %{samba_version}
|
Version: %{samba_version}
|
||||||
Release: %{samba_release}.1
|
Release: %{samba_release}
|
||||||
|
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
Epoch: 0
|
Epoch: 0
|
||||||
@ -106,8 +106,6 @@ Source6: samba.pamd
|
|||||||
Source200: README.dc
|
Source200: README.dc
|
||||||
Source201: README.downgrade
|
Source201: README.downgrade
|
||||||
|
|
||||||
Patch0: samba-4.4.0rc2-ctdb-pkgconfig.patch
|
|
||||||
|
|
||||||
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
|
||||||
|
|
||||||
Requires(pre): /usr/sbin/groupadd
|
Requires(pre): /usr/sbin/groupadd
|
||||||
@ -665,8 +663,6 @@ and use CTDB instead.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n samba-%{version}%{pre_release}
|
%setup -q -n samba-%{version}%{pre_release}
|
||||||
|
|
||||||
%patch0 -p1 -b .samba-4.4.0rc2-ctdb-pkgconfig.patch
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||||
%global _tevent_lib ,tevent,pytevent
|
%global _tevent_lib ,tevent,pytevent
|
||||||
@ -1639,6 +1635,7 @@ rm -rf %{buildroot}
|
|||||||
%files krb5-printing
|
%files krb5-printing
|
||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%attr(0700,root,root) %{_libexecdir}/samba/smbspool_krb5_wrapper
|
%attr(0700,root,root) %{_libexecdir}/samba/smbspool_krb5_wrapper
|
||||||
|
%{_mandir}/man8/smbspool_krb5_wrapper.8*
|
||||||
|
|
||||||
### LIBS
|
### LIBS
|
||||||
%files libs
|
%files libs
|
||||||
@ -1958,6 +1955,9 @@ rm -rf %{buildroot}
|
|||||||
%endif # with_clustering_support
|
%endif # with_clustering_support
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 10 2016 Guenther Deschner <gdeschner@redhat.com> - 4.4.0rc2-0
|
||||||
|
- Update to Samba 4.4.0rc2
|
||||||
|
|
||||||
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2:4.4.0-0.0.rc1.1
|
* Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2:4.4.0-0.0.rc1.1
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user