Update to 3.4.0 final.
Guenther
This commit is contained in:
parent
a9317bf26d
commit
6d76452800
@ -1 +1 @@
|
||||
samba-3.4.0rc1.tar.gz
|
||||
samba-3.4.0.tar.gz
|
||||
|
74
samba-3.4.0-build.patch
Normal file
74
samba-3.4.0-build.patch
Normal file
@ -0,0 +1,74 @@
|
||||
commit 3b0bd19570894e5219878102a2564a08095f26cd
|
||||
Author: Jelmer Vernooij <jelmer@samba.org>
|
||||
AuthorDate: Thu Jun 11 04:57:58 2009 +0200
|
||||
Commit: Günther Deschner <gd@samba.org>
|
||||
CommitDate: Tue Jul 14 23:51:24 2009 +0200
|
||||
|
||||
Fix build with external talloc.
|
||||
---
|
||||
source3/configure.in | 29 +++++++++++++++++++++++++++--
|
||||
source3/samba4.m4 | 4 ++++
|
||||
2 files changed, 31 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/source3/configure.in b/source3/configure.in
|
||||
index 111e89d..fc41b35 100644
|
||||
--- a/source3/configure.in
|
||||
+++ b/source3/configure.in
|
||||
@@ -77,7 +77,6 @@ done
|
||||
AC_SUBST(LIBTDB_OBJ0)
|
||||
SAMBA_CPPFLAGS="-Iinclude -I${srcdir-.}/include -I. -I${srcdir-.}"
|
||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/../lib/replace"
|
||||
-SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TALLOC_CFLAGS}"
|
||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TEVENT_CFLAGS}"
|
||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TDB_CFLAGS}"
|
||||
SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} -I${srcdir-.}/libaddns"
|
||||
@@ -4748,7 +4747,33 @@ LINK_LIBSMBCLIENT=STATIC
|
||||
# TODO: for talloc and tdb (at least), these should
|
||||
# be extracted from their respective source directories
|
||||
#
|
||||
-SMB_LIBRARY(talloc, 1)
|
||||
+AC_ARG_ENABLE(external_libtalloc, [AS_HELP_STRING([--enable-external-libtalloc], [Enable external talloc [default=auto]])],
|
||||
+[ enable_external_libtalloc=$enableval ], [ enable_external_libtalloc=auto ])
|
||||
+
|
||||
+if test "x$enable_external_libtalloc" != xno
|
||||
+then
|
||||
+ PKG_CHECK_MODULES(LIBTALLOC, talloc >= 1.3.0,
|
||||
+ [ enable_external_libtalloc=yes ],
|
||||
+ [ if test x$enable_external_libtalloc = xyes; then
|
||||
+ AC_MSG_ERROR([Unable to find libtalloc])
|
||||
+ else
|
||||
+ enable_external_libtalloc=no
|
||||
+ fi
|
||||
+ ])
|
||||
+fi
|
||||
+
|
||||
+if test "x$enable_external_libtalloc" = xno
|
||||
+then
|
||||
+ m4_include(../lib/talloc/libtalloc.m4)
|
||||
+ SMB_LIBRARY(talloc, 1)
|
||||
+ LIBTALLOC_OBJ0=""
|
||||
+ for obj in ${TALLOC_OBJ}; do
|
||||
+ LIBTALLOC_OBJ0="${LIBTALLOC_OBJ0} ${tallocdir}/${obj}"
|
||||
+ done
|
||||
+ SAMBA_CPPFLAGS="${SAMBA_CPPFLAGS} ${TALLOC_CFLAGS}"
|
||||
+ AC_SUBST(LIBTALLOC_OBJ0)
|
||||
+fi
|
||||
+
|
||||
SMB_LIBRARY(tdb, 1)
|
||||
SMB_LIBRARY(netapi, 0)
|
||||
SMB_LIBRARY(smbclient, 0)
|
||||
diff --git a/source3/samba4.m4 b/source3/samba4.m4
|
||||
index b5c7c74..0ea40db 100644
|
||||
--- a/source3/samba4.m4
|
||||
+++ b/source3/samba4.m4
|
||||
@@ -75,6 +75,10 @@ SMB_EXT_LIB_FROM_PKGCONFIG(LIBTALLOC, talloc >= $TALLOC_MIN_VERSION,
|
||||
SMB_INCLUDE_MK(../lib/talloc/config.mk)
|
||||
]
|
||||
)
|
||||
+# Tallocdir isn't always set by the Samba3 c
|
||||
+tallocdir=../lib/talloc
|
||||
+AC_SUBST(tallocdir)
|
||||
+CFLAGS="$CFLAGS -I../lib/talloc"
|
||||
|
||||
SMB_EXT_LIB_FROM_PKGCONFIG(LIBTDB, tdb >= $TDB_MIN_VERSION,
|
||||
[],
|
14
samba.spec
14
samba.spec
@ -1,9 +1,9 @@
|
||||
%define main_release 38
|
||||
%define main_release 40
|
||||
%define samba_version 3.4.0
|
||||
%define tdb_version 1.1.3
|
||||
%define talloc_version 1.2.0
|
||||
#%define pre_release %nil
|
||||
%define pre_release rc1
|
||||
#%define pre_release rc1
|
||||
%define pre_release %nil
|
||||
|
||||
%define samba_release 0%{pre_release}.%{main_release}%{?dist}
|
||||
|
||||
@ -48,6 +48,7 @@ Patch104: samba-3.0.0rc3-nmbd-netbiosname.patch
|
||||
# The passwd part has been applied, but not the group part
|
||||
Patch107: samba-3.2.0pre1-grouppwd.patch
|
||||
Patch200: samba-3.2.5-inotify.patch
|
||||
Patch201: samba-3.4.0-build.patch
|
||||
|
||||
Requires(pre): samba-common = %{epoch}:%{samba_version}-%{release}
|
||||
Requires: pam >= 0:0.64
|
||||
@ -56,7 +57,7 @@ BuildRoot: %{_tmppath}/%{name}-%{samba_version}-%{release}-root
|
||||
Requires(post): /sbin/chkconfig, /sbin/service
|
||||
Requires(preun): /sbin/chkconfig, /sbin/service
|
||||
BuildRequires: pam-devel, readline-devel, ncurses-devel, libacl-devel, krb5-devel, openldap-devel, openssl-devel, cups-devel, ctdb-devel
|
||||
BuildRequires: autoconf, gawk, popt-devel, gtk2-devel, libcap-devel
|
||||
BuildRequires: autoconf, gawk, popt-devel, gtk2-devel, libcap-devel, libuuid-devel
|
||||
%if ! %enable_talloc
|
||||
BuildRequires: libtalloc-devel
|
||||
%endif
|
||||
@ -258,6 +259,7 @@ cp %{SOURCE11} packaging/Fedora/
|
||||
#%patch104 -p1 -b .nmbd-netbiosname # FIXME: does not apply
|
||||
%patch107 -p1 -b .grouppwd
|
||||
%patch200 -p0 -b .inotify
|
||||
%patch201 -p1 -b .build
|
||||
|
||||
mv %samba_source/VERSION %samba_source/VERSION.orig
|
||||
sed -e 's/SAMBA_VERSION_VENDOR_SUFFIX=$/&\"%{samba_release}\"/' < %samba_source/VERSION.orig > %samba_source/VERSION
|
||||
@ -312,7 +314,6 @@ CFLAGS="$RPM_OPT_FLAGS -D_GNU_SOURCE -DLDAP_DEPRECATED" %configure \
|
||||
--with-shared-modules=idmap_ad,idmap_rid,idmap_adex,idmap_hash,idmap_tdb2 \
|
||||
--with-cifsupcall \
|
||||
--with-cluster-support
|
||||
|
||||
# --with-aio-support \
|
||||
|
||||
|
||||
@ -885,6 +886,9 @@ exit 0
|
||||
%{_datadir}/pixmaps/samba/logo-small.png
|
||||
|
||||
%changelog
|
||||
* Fri Jul 03 2009 Guenther Deschner <gdeschner@redhat.com> - 3.4.0-0.40
|
||||
- Update to 3.4.0
|
||||
|
||||
* Fri Jun 19 2009 Guenther Deschner <gdeschner@redhat.com> - 3.4.0rc1-0.39
|
||||
- Update to 3.4.0rc1
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user