Update to Samba 4.5.2
Guenther
This commit is contained in:
parent
3a3f2e0c38
commit
64da37fff9
1
.gitignore
vendored
1
.gitignore
vendored
@ -72,3 +72,4 @@ samba-3.6.0pre1.tar.gz
|
||||
/samba-4.5.0rc3.tar.xz
|
||||
/samba-4.5.0.tar.xz
|
||||
/samba-4.5.1.tar.xz
|
||||
/samba-4.5.2.tar.xz
|
||||
|
@ -1,49 +0,0 @@
|
||||
From 730c0a2fab4b0c494122f29355068cc2bbf0f672 Mon Sep 17 00:00:00 2001
|
||||
From: Michael Adam <obnox@samba.org>
|
||||
Date: Fri, 21 Oct 2016 00:15:06 +0200
|
||||
Subject: [PATCH] vfs:glusterfs: preallocate result for glfs_realpath
|
||||
|
||||
https://bugzilla.samba.org/show_bug.cgi?id=12404
|
||||
|
||||
This makes us independent of the allocation
|
||||
method used inside glfs_realpath.
|
||||
|
||||
Signed-off-by: Michael Adam <obnox@samba.org>
|
||||
Reviewed-by: Ira Cooper <ira@samba.org>
|
||||
|
||||
Autobuild-User(master): Jeremy Allison <jra@samba.org>
|
||||
Autobuild-Date(master): Sat Oct 22 00:28:41 CEST 2016 on sn-devel-144
|
||||
|
||||
(cherry picked from commit 92a0a56c3852726e0812d260e043957c879aefa4)
|
||||
---
|
||||
source3/modules/vfs_glusterfs.c | 15 ++++++++++++++-
|
||||
1 file changed, 14 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/source3/modules/vfs_glusterfs.c b/source3/modules/vfs_glusterfs.c
|
||||
index 732ca51..fc40a90 100644
|
||||
--- a/source3/modules/vfs_glusterfs.c
|
||||
+++ b/source3/modules/vfs_glusterfs.c
|
||||
@@ -1036,7 +1036,20 @@ static int vfs_gluster_fallocate(struct vfs_handle_struct *handle,
|
||||
static char *vfs_gluster_realpath(struct vfs_handle_struct *handle,
|
||||
const char *path)
|
||||
{
|
||||
- return glfs_realpath(handle->data, path, 0);
|
||||
+ char *result = NULL;
|
||||
+ char *resolved_path = SMB_MALLOC_ARRAY(char, PATH_MAX+1);
|
||||
+
|
||||
+ if (resolved_path == NULL) {
|
||||
+ errno = ENOMEM;
|
||||
+ return NULL;
|
||||
+ }
|
||||
+
|
||||
+ result = glfs_realpath(handle->data, path, resolved_path);
|
||||
+ if (result == NULL) {
|
||||
+ SAFE_FREE(resolved_path);
|
||||
+ }
|
||||
+
|
||||
+ return result;
|
||||
}
|
||||
|
||||
static bool vfs_gluster_lock(struct vfs_handle_struct *handle,
|
||||
--
|
||||
2.7.4
|
48
samba.spec
48
samba.spec
@ -6,9 +6,9 @@
|
||||
# ctdb is enabled by default, you can disable it with: --without clustering
|
||||
%bcond_without clustering
|
||||
|
||||
%define main_release 2
|
||||
%define main_release 0
|
||||
|
||||
%define samba_version 4.5.1
|
||||
%define samba_version 4.5.2
|
||||
%define talloc_version 2.1.8
|
||||
%define tdb_version 1.3.10
|
||||
%define tevent_version 0.9.29
|
||||
@ -106,8 +106,6 @@ Source6: samba.pamd
|
||||
Source200: README.dc
|
||||
Source201: README.downgrade
|
||||
|
||||
Patch0: samba-4.5.1-vfs_gluster_realpath.patch
|
||||
|
||||
Requires(pre): /usr/sbin/groupadd
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
@ -662,8 +660,6 @@ and use CTDB instead.
|
||||
%prep
|
||||
%setup -q -n samba-%{version}%{pre_release}
|
||||
|
||||
%patch0 -p 1 -b .samba-4.5.1-vfs_gluster_realpath.patch
|
||||
|
||||
%build
|
||||
%global _talloc_lib ,talloc,pytalloc,pytalloc-util
|
||||
%global _tevent_lib ,tevent,pytevent
|
||||
@ -1014,7 +1010,8 @@ rm -rf %{buildroot}
|
||||
### SAMBA
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc COPYING README WHATSNEW.txt
|
||||
%license COPYING
|
||||
%doc README WHATSNEW.txt
|
||||
%doc examples/autofs examples/LDAP examples/misc
|
||||
%doc examples/printer-accounting examples/printing
|
||||
%doc packaging/README.downgrade
|
||||
@ -1953,27 +1950,30 @@ rm -rf %{buildroot}
|
||||
%{_libexecdir}/ctdb/tests/update_record_persistent
|
||||
%{_bindir}/ctdb_run_tests
|
||||
%{_bindir}/ctdb_run_cluster_tests
|
||||
%dir %{_datadir}/ctdb-tests/eventscripts
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/events.d
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/functions
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/nfs-checks.d
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/nfs-linux-kernel-callout
|
||||
%{_datadir}/ctdb-tests/eventscripts/etc-ctdb/statd-callout
|
||||
%dir %{_datadir}/ctdb-tests/onnode
|
||||
%{_datadir}/ctdb-tests/onnode/functions
|
||||
%dir %{_datadir}/ctdb-tests/scripts
|
||||
%{_datadir}/ctdb-tests/scripts/common.sh
|
||||
%{_datadir}/ctdb-tests/scripts/integration.bash
|
||||
%{_datadir}/ctdb-tests/scripts/script_install_paths.sh
|
||||
%{_datadir}/ctdb-tests/scripts/test_wrap
|
||||
%{_datadir}/ctdb-tests/scripts/unit.sh
|
||||
%dir %{_datadir}/ctdb-tests/simple
|
||||
%{_datadir}/ctdb-tests/simple/functions
|
||||
%{_datadir}/ctdb-tests/simple/nodes
|
||||
%dir %{_datadir}/ctdb/tests/eventscripts
|
||||
%{_datadir}/ctdb/tests/eventscripts/etc-ctdb/events.d
|
||||
%{_datadir}/ctdb/tests/eventscripts/etc-ctdb/functions
|
||||
%{_datadir}/ctdb/tests/eventscripts/etc-ctdb/nfs-checks.d
|
||||
%{_datadir}/ctdb/tests/eventscripts/etc-ctdb/nfs-linux-kernel-callout
|
||||
%{_datadir}/ctdb/tests/eventscripts/etc-ctdb/statd-callout
|
||||
%dir %{_datadir}/ctdb/tests/onnode
|
||||
%{_datadir}/ctdb/tests/onnode/functions
|
||||
%dir %{_datadir}/ctdb/tests/scripts
|
||||
%{_datadir}/ctdb/tests/scripts/common.sh
|
||||
%{_datadir}/ctdb/tests/scripts/integration.bash
|
||||
%{_datadir}/ctdb/tests/scripts/script_install_paths.sh
|
||||
%{_datadir}/ctdb/tests/scripts/test_wrap
|
||||
%{_datadir}/ctdb/tests/scripts/unit.sh
|
||||
%dir %{_datadir}/ctdb/tests/simple
|
||||
%{_datadir}/ctdb/tests/simple/functions
|
||||
%{_datadir}/ctdb/tests/simple/nodes
|
||||
%doc ctdb/tests/README
|
||||
%endif # with_clustering_support
|
||||
|
||||
%changelog
|
||||
* Wed Dec 07 2016 Guenther Deschner <gdeschner@redhat.com> - 4.5.2-0
|
||||
- Update to Samba 4.5.2
|
||||
|
||||
* Mon Dec 05 2016 Rex Dieter <rdieter@fedoraproject.org> - -
|
||||
- rebuild (libldb)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user